LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 06-18-2003, 09:40 PM   #1
x2000koh
Member
 
Registered: Jul 2002
Location: singapore
Distribution: red had 7.2
Posts: 109

Rep: Reputation: 15
How to make build in Ethernet work on RED HAT 8


Hi ! Linux user
I have purchased two computers with PC200 Systemboard its come with Built-in Ehternet Lan. The next day I purchased the 8 port switch hub, and try to connet with cat 5.

After I have installed RED HAT 8.
I did ifconfig, its does not detect the eth0. It only show lo (the loopback).

I try a various ways, it still said the device is not found.
1) restart the network service
etc/init.d/network restart

2) ifconfig eth0 up

3) cat /proc/net/dev

4)/etc/init.d/network status
it shows
configured devices
lo

currently active devices
lo

5) reboot
shutdown -h now

The above method, it does not detect the build in nic.

Appreciate if anyone can help.

x2000koh
 
Old 06-18-2003, 10:22 PM   #2
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 60
Command:

cat /proc/pci

Look through the list and see if you can find it. I have a board with an integrated lan and this is my result:
Code:
 Bus  0, device   3, function  0:
    Ethernet controller: Silicon Integrated Systems [SiS] SiS900 10/100 Ethernet (rev 144).
      IRQ 10.
      Master Capable.  Latency=64.  Min Gnt=52.Max Lat=11.
      I/O at 0xd800 [0xd8ff].
      Non-prefetchable 32 bit memory at 0xcfffd000 [0xcfffdfff].
# Redhat links
RedHat Linux Manuals
Get your mp3 support here
Maximum RPM
rpmfind
Easier software management: apt4rpm - Red Carpet
RedHat 8.0 Tips & Tricks

# Redhat 7.3 down configuration commands
setup leads to several configuration tools

# Redhat 7.3 up configuration commands
Configure soundcard:
redhat-config-soundcard
Configure X server:
redhat-config-xfree86
Configure network:
redhat-config-network

Last edited by fancypiper; 06-18-2003 at 10:23 PM.
 
Old 06-19-2003, 01:47 AM   #3
x2000koh
Member
 
Registered: Jul 2002
Location: singapore
Distribution: red had 7.2
Posts: 109

Original Poster
Rep: Reputation: 15
what is the solution ?

fancypiper,
Thanks for reply.
If I do cat /proc/pci

1) I am not able to see the similar output display.
What can I do to make the build in NIC to work ?

2) If I see the output display but ifconfig still did not indicate eth0 what can should I do to make the build in NIC to work ?

Appreciate your help.

x2000koh
 
Old 06-19-2003, 03:49 PM   #4
SystemShock
LQ Newbie
 
Registered: Jun 2003
Posts: 3

Rep: Reputation: 0
Is the module installed?

If not, make the modules, and then do insmod.

I had the same problem, turns out, the modules was already installed.
 
Old 06-19-2003, 09:23 PM   #5
x2000koh
Member
 
Registered: Jul 2002
Location: singapore
Distribution: red had 7.2
Posts: 109

Original Poster
Rep: Reputation: 15
SystemShock,
Yes, the module has installed.
When I do /etc/module.conf it shown the aliase xxxx.....

A question, on RED HAT 8 when I go to system tool -> network.
I can add, edit, delete, activate the eth0. I try to delete the add again. Should I add the IRQ, DMA and etc...?

Appreciate your help.

x2000koh
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Red Hat Cant See Ethernet why? kkathman Linux - Networking 1 03-07-2005 09:32 PM
anyone make NetGear MA111 work well in Red Hat Linux 9.0? jarrywhu Linux - Wireless Networking 1 10-18-2004 08:05 AM
KDE build for Red Hat ?? its_sandy_here Red Hat 1 03-27-2004 03:20 AM
Ethernet help w/Red Hat 9 & Win. XP USMC S/S Linux - Networking 3 03-06-2004 07:09 AM
best ethernet card for Red Hat 6.2 cliffyman Linux - Software 6 10-19-2001 11:02 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 10:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration