LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 07-01-2004, 10:53 PM   #1
puneetloiya
LQ Newbie
 
Registered: Jul 2004
Posts: 18

Rep: Reputation: 0
how to install linux by kickstart method


Hello all,

I want to install Red Hat 9.0 by kick start method. i m givin u all the steps wat i m doin and after tht wat i m gettin .

1> i made a copy of anaconda-ks.cfg as ks.cfg by using command :-
# cp anaconda-ks.cfg ks.cfg

2> after this i copied ks.cfg file in to floppy
# mcopy ks.cfg a:

now i was gettin the error

Can't open /dev/fd0: Device or resource busy
Cannot initialize 'A:'
Bad target a:

3> so i copied in the GUI mode

now i am checkin the files by "ls" command
in the floppy i m gettin ks.cfg

4> now after this i insert the cd 1 where i want to installation .
5> at th eboot prompt i typed

boot: linux ks=file:fd0/ks.cfg

after this command i should see the formation of the hard disk but i m gettin error like :--

error opening kickstart file
fd0/ks.cfg : no such file or directory

so plz suggest me how to come out from this problem.


regards
puneet
 
Old 07-01-2004, 11:08 PM   #2
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 50
mount the floppy with

#mount /mnt/floppy
#cp /pathto/ks.cfg /mnt/floppy
#ls /mnt/floppy

You should find ks.cfg on the floppy disk.

#umount /mnt/floppy

and get back to the kickstart process.
 
Old 07-02-2004, 02:48 AM   #3
puneetloiya
LQ Newbie
 
Registered: Jul 2004
Posts: 18

Original Poster
Rep: Reputation: 0
hello there

i copied the ks.cfg file accordin to teh given command
but the error i m gettin is after givin the followin command :--

boot: linux ks=file:fd0/ks.cfg

error is :--

Error opening
kickstart file
fd0/ks.cfg:No such file or directory

plz help me

puneet
 
Old 07-02-2004, 03:24 AM   #4
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 50
after copying the file using the cp command, you must have run the ls command.

could you see ks.cfg then?
 
Old 07-02-2004, 04:10 AM   #5
puneetloiya
LQ Newbie
 
Registered: Jul 2004
Posts: 18

Original Poster
Rep: Reputation: 0
hello there

yeah i m seein the ks.cfg file

is there any chance of bad sector coz of tht problem is comin
but floppy is new

puneet
 
Old 07-02-2004, 04:14 AM   #6
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 50
You can try to

$cat /mnt/floppy/ks.cfg

Also, on the PC that you want to perform kickstart, try

boot: linux ks=floppy
 
Old 07-02-2004, 04:17 AM   #7
puneetloiya
LQ Newbie
 
Registered: Jul 2004
Posts: 18

Original Poster
Rep: Reputation: 0
i tried by this command
it goes in to linux askmethod
it doesnt perform kickstart installation
 
Old 07-02-2004, 04:42 AM   #8
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 50
Are you booting off a floppy / cdrom?

If you are booting off a cdrom, try

linux ks=hd:fd0:/ks.cfg
 
Old 07-02-2004, 05:51 AM   #9
puneetloiya
LQ Newbie
 
Registered: Jul 2004
Posts: 18

Original Poster
Rep: Reputation: 0
yeah i m bootin frm the cdrom

i m givin this command
error comes :=----

installation terminated --- received error 11

Puneet
 
Old 07-02-2004, 06:41 AM   #10
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 50
some progress ... although not much.... it recognises ks.cfg now ????

At what stage does it come up with this error.
 
Old 07-02-2004, 06:53 AM   #11
puneetloiya
LQ Newbie
 
Registered: Jul 2004
Posts: 18

Original Poster
Rep: Reputation: 0
when i typed

linux ks=hd:fd0:/ks.cfg

and it waits for a few sec. and after showin "running /sbin/loader"

it gives error




puneet
 
Old 07-02-2004, 10:37 AM   #12
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 50
Can you Ctrl-Alt-F2, Ctrl-Alt-F3, Ctrl-Alt-F4 and gather some information -- about where exactly it is failing.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
kickstart network install of rh 9 baz2 Red Hat 13 03-04-2005 09:42 AM
Using Kickstart --Prompt for Install Location? caps_phisto Fedora - Installation 1 01-12-2005 07:08 AM
KickStart Network install hasan Linux - Networking 1 04-29-2004 01:05 AM
rh9 kickstart post install help stockcowboy Linux - Newbie 1 12-05-2003 11:45 AM
Kickstart Post-install tasks TheRealDeal Linux - General 0 09-03-2003 01:13 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 04:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration