LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 11-18-2008, 04:44 AM   #1
Funkster
LQ Newbie
 
Registered: Nov 2008
Posts: 8

Rep: Reputation: 0
How to export http_proxy when username contains an @ symbol?


Hi all,

First post here, hope I'm in the right area. I've searched t'internet in general and on this forum, but can't find an answer to this one...

I would like to get http proxying working from the console, but as my Linux box is behind a corporate network it just so happens that my username for the proxy server contains an @ symbol. So, when I try to use the following type of command:

Code:
export http_proxy=http://username:password@proxy.thing.com:8080/
I insert my username and end up with something like:

Code:
export http_proxy=http://ted@thing.com:password@proxy.thing.com:8080/
This seems to break things, presumably because something is parsing everything after the first @ as the address of the proxy.

Can anyone give me any hints as to how I can get it to work? I've tried # and % as delimiters but just get different errors, as presumably the proxy server itself isn't set up to accept anything other than @.


As an aside, the only reason I really need to get this to work is so that I can try to use YUM from the console, as when I put an openSuSE 10.3 repository in as an installation source, YaST's Online Update utility just disappears shortly after I run it. So, if anyone has any bright ideas on that one then it'll avoid the need to fix the proxy issue!


Many thanks in advance,
--
Olly
 
Old 11-18-2008, 09:04 AM   #2
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 23,120

Rep: Reputation: 6451Reputation: 6451Reputation: 6451Reputation: 6451Reputation: 6451Reputation: 6451Reputation: 6451Reputation: 6451Reputation: 6451Reputation: 6451Reputation: 6451
Quote:
Originally Posted by Funkster View Post
Hi all,

First post here, hope I'm in the right area. I've searched t'internet in general and on this forum, but can't find an answer to this one...

I would like to get http proxying working from the console, but as my Linux box is behind a corporate network it just so happens that my username for the proxy server contains an @ symbol. So, when I try to use the following type of command:

Code:
export http_proxy=http://username:password@proxy.thing.com:8080/
I insert my username and end up with something like:

Code:
export http_proxy=http://ted@thing.com:password@proxy.thing.com:8080/
This seems to break things, presumably because something is parsing everything after the first @ as the address of the proxy.

Can anyone give me any hints as to how I can get it to work? I've tried # and % as delimiters but just get different errors, as presumably the proxy server itself isn't set up to accept anything other than @.


As an aside, the only reason I really need to get this to work is so that I can try to use YUM from the console, as when I put an openSuSE 10.3 repository in as an installation source, YaST's Online Update utility just disappears shortly after I run it. So, if anyone has any bright ideas on that one then it'll avoid the need to fix the proxy issue!


Many thanks in advance,
--
Olly
Welcome!

Try to escape the @ character with a backslash \, and see if it works. You can also set up a .wgetrc/.netrc file, that has the proxy_user and proxy_passwd variables set, and that may work for you.
 
Old 11-18-2008, 10:44 AM   #3
Funkster
LQ Newbie
 
Registered: Nov 2008
Posts: 8

Original Poster
Rep: Reputation: 0
Hi there!

Thanks for the suggestion... I had a go with username\@domain@proxy.domain but it still falls over, wget gives the error:

Resolving domain@proxy.domain... failed: Name or service not known.

I guess the first time it sees an @ it figures whatever is after that is supposed to be the address of the proxy.

I'll have a play with .wgetrc and see if it helps :o)

Cheers,
--
Olly
 
Old 11-18-2008, 11:24 AM   #4
Funkster
LQ Newbie
 
Registered: Nov 2008
Posts: 8

Original Poster
Rep: Reputation: 0
Hallo,

I made a .wgetrc with the separate proxy_user and proxy_passwd fields set, and that works perfectly for wget!

Sadly, setting similar fields up for yum in /etc/yum.conf did not work - presumably yum cannot parse a username with an @ in. :o(

Back to the drawing board!

Many thanks,
--
Olly
 
Old 11-18-2008, 12:05 PM   #5
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 23,120

Rep: Reputation: 6451Reputation: 6451Reputation: 6451Reputation: 6451Reputation: 6451Reputation: 6451Reputation: 6451Reputation: 6451Reputation: 6451Reputation: 6451Reputation: 6451
Quote:
Originally Posted by Funkster View Post
Hallo,

I made a .wgetrc with the separate proxy_user and proxy_passwd fields set, and that works perfectly for wget!

Sadly, setting similar fields up for yum in /etc/yum.conf did not work - presumably yum cannot parse a username with an @ in. (

Back to the drawing board!

Many thanks,
--
Olly
Glad it helped some. Tried this http://docs.fedoraproject.org/yum/sn...xy-server.html ?
 
Old 11-18-2008, 12:38 PM   #6
DotHQ
Member
 
Registered: Mar 2006
Location: Ohio, USA
Distribution: Red Hat, Fedora, Knoppix,
Posts: 548

Rep: Reputation: 33
Can't you simply change the username ...or add another username that does not have the @ symbol?
 
Old 11-19-2008, 03:38 AM   #7
Funkster
LQ Newbie
 
Registered: Nov 2008
Posts: 8

Original Poster
Rep: Reputation: 0
The domain controller is very much not under my control, what with it belonging to the IT department of a multinational company :o)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
./firefox-bin :symbol lookup error:/lib/libgthread-2.0.so.0: undefined symbol: arulupsaras Linux - General 1 11-08-2008 04:48 AM
symbol lookup error: /usr/lib/libgtk-x11.2.0.so.0: undefined symbol:... IamI Slackware 17 02-29-2008 11:10 AM
Workaround: 'symbol lookup error: k3b: undefined symbol: lstat64' devdol Linux - Software 2 02-15-2008 03:36 AM
howto forcing ld to export external symbol? kkk139 Programming 1 07-17-2007 12:10 AM
export symbol from module to kernel dogalmity Programming 0 06-05-2006 04:38 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration