LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 04-11-2004, 08:56 PM   #1
jonow
LQ Newbie
 
Registered: Apr 2004
Posts: 4

Rep: Reputation: 0
Lightbulb How to connect Mandrake 9.2 to WinXP using crossover


This is the first time installing linux for me, I have Mandrake 9.2 on one box and I want to connect it to a WinXP box via a crossover cable. I realise I can't just plug the wire in and expect them to run, but that said I can't find any decent step by step documentation as to how to do it. So heres what has happened so far...

Initially when booting I got the message setting up eth0 interface ... [failed] or something along those lines. I got rid of that by deselecting 'Network Hotplugging' option in the expert setup mode wizard thing.

Secondly I assigned an IP address 192.168.0.2, with mask 255.255.255.0, and then after that I managed to get the LAN configuration in a state of 'UP' which was nice. I set this to start at boot so now it happens each time I boot.

Basically I want to be able to ping the other machine, but I can't seem to make it work. I get a 'connect: network is unreachable' message. I though tmaybe this had to do with firewall settings so I turned it off, but not such luck. I can ping localhost ok though.

So any help would be much appreciated. I figured if I make this thread nice and step - by - step and generic other people might be able to use it.

Cheers, Jono
 
Old 04-11-2004, 09:13 PM   #2
mrcheeks
Senior Member
 
Registered: Mar 2004
Location: far enough
Distribution: OS X 10.6.7
Posts: 1,690

Rep: Reputation: 52
example

pc1
inet 192.168.10.1
netmask 255.255.255.0

pc2
inet 192.168.10.2
netmask 255.255.255.0

ping pc2(no firewall or firewall well configured)

maybe we will be looking for something call samba soon.
 
Old 04-11-2004, 09:16 PM   #3
tekhead2
Member
 
Registered: Apr 2004
Distribution: slackware/FreeBSD/Vector
Posts: 291

Rep: Reputation: 52
Also too dont forget to configure your smb.conf file in etc/samba/ You should insert your ms workgroup name into here. The default is just workgroup. You should also have a share directory setup.
 
Old 04-11-2004, 10:21 PM   #4
jonow
LQ Newbie
 
Registered: Apr 2004
Posts: 4

Original Poster
Rep: Reputation: 0
Umm im not quite sure what you are asking here..!

My mandrake box (PC1) has inet addr:
192.168.0.2 mask 255.255.255.0

My XPBox (PC2) configuration

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Autoconfiguration IP Address. . . : 169.254.232.144
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :

PPP adapter Paradise Net:

Connection-specific DNS Suffix . :
IP Address. . . . . . . . . . . . : 203.96.147.188
Subnet Mask . . . . . . . . . . . : 255.255.255.255
Default Gateway . . . . . . . . . : 203.96.147.188

I can't ping PC2 from PC1.. thats when I get the 'cannot access network' error.

I dont want to setup filesharing or anything, I just want to be able to telnet or ssh accross from my winxp box to my linux box, and share internet from my winxp box to my linux box

Cheer

Quote:
Originally posted by mrcheeks
example

pc1
inet 192.168.10.1
netmask 255.255.255.0

pc2
inet 192.168.10.2
netmask 255.255.255.0

ping pc2(no firewall or firewall well configured)

maybe we will be looking for something call samba soon.
 
Old 04-12-2004, 04:26 AM   #5
mrcheeks
Senior Member
 
Registered: Mar 2004
Location: far enough
Distribution: OS X 10.6.7
Posts: 1,690

Rep: Reputation: 52
your problem is ip addresses.

Frank is leaving in united states
Joe is leaving in china
Can Frank see joe face to face, no.
 
Old 04-12-2004, 07:23 AM   #6
jonow
LQ Newbie
 
Registered: Apr 2004
Posts: 4

Original Poster
Rep: Reputation: 0
ok cheers for your help... so would anyone else like to help in a way that isn't written in riddles?
 
Old 04-12-2004, 08:24 AM   #7
dtournas
Member
 
Registered: Aug 2003
Location: Charlotte, North Carolina
Distribution: Red Hat (and look-alike), SUSE (when drunk), Slackware (when mad)
Posts: 148

Rep: Reputation: 16
OK, it looks like your problem is that the network card interface (also known as NIC) isn't configured well. What you have to do is to configure both NICs (on the linux and the xp PCs) to use IP addresses (those numbers that look like 192.168.1.2 etc) to very similar. That is what mrcheeks said:
Quote:
pc1
inet 192.168.10.1
netmask 255.255.255.0

pc2
inet 192.168.10.2
netmask 255.255.255.0
In this example, lets just rename pc1 as linux and pc2 as winXP. Because doing that on the linux maybe a little tricky, we will try to do this on your winXP. I need some information though. Try to open a Command Line from the winXPand type the following command: ipconfig. This command will show the numbers that we need to go on. As long as you have these, post them to the forum and I will tell you what to do next.

In short, you may have to change the settings of your TCP/IP. That changes from:
Start > Control Panel > Network Connections > Local Network Connection

Once you open that, you should change some numbers. I'll get back to you for this.

Hope that will help! Cheerz!
 
Old 04-12-2004, 08:58 AM   #8
Ajarn
Member
 
Registered: Aug 2003
Location: Thailand
Distribution: Mandiva2005
Posts: 86

Rep: Reputation: 15
***Frank is leaving in united states
***Joe is leaving in china
***Can Frank see joe face to face, no.

Very technical and very helpful.
Please don't piss of these guys, they are trying.
 
Old 04-12-2004, 10:30 AM   #9
BIACS
Member
 
Registered: Apr 2004
Location: Arlington, TX
Distribution: Fedora Core 4 64bit
Posts: 95

Rep: Reputation: 15
jonow, the problem is that your XP box is set to DHCP. The address you are getting on your XP box 169.254.*.* is based on APIPA (automatic private IP addressing). You need to set a static address on the XP box to 192.168.0.* (any number other than 2 since that is what your linux box is already using).

Right click the My Network Places on your desktop - choose Properties
Right click Local Area Connection - choose Properties
Double click Internet Protocol [TCP/IP]
Select the radio button - Use the following IP address and enter
192.168.0.3
255.255.255.0

Once you save out of that you should be able to ping the linux box.
 
Old 04-12-2004, 10:37 AM   #10
BIACS
Member
 
Registered: Apr 2004
Location: Arlington, TX
Distribution: Fedora Core 4 64bit
Posts: 95

Rep: Reputation: 15
I forgot to add, if you want to use the XP box to share its internet connection with the linux box, then you need to setup ICS on the NIC that is connected to your cable/dsl modem. I don't have the options in front of me right now but I believe when you right click the NIC that is connected to your modem and go to properties, one of the tabs will have an option for Internet Connection Sharing. When that is completed you can set your linux box to receive its IP from DHCP as your XP box will act as a simple DHCP server.
 
Old 04-12-2004, 07:34 PM   #11
jonow
LQ Newbie
 
Registered: Apr 2004
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks heaps for your help guys... much appreciated

Jono
 
Old 05-07-2004, 01:26 PM   #12
pbenson68
LQ Newbie
 
Registered: May 2004
Posts: 1

Rep: Reputation: 0
Thanks I had exactly the same problem yesterday.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
crossover cable for linux and winxp stanley_shilov Linux - Networking 26 11-21-2005 12:13 AM
Cannot connect to internet in Mandrake 9.2, but can in WinXP TravisOSF Linux - Networking 27 04-22-2004 01:11 AM
How doi I connect my Mandrake 9.2 to WinXP Shared Folders and Printer? nicolo Linux - Newbie 3 03-10-2004 03:20 AM
Redhat 7.3 via crossover to WinXP astraw2000 Linux - Newbie 2 03-04-2003 01:11 AM
WinXP to Mandrake 8.2 can't connect. BBlalock Linux - Networking 0 06-30-2002 10:55 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 06:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration