-   Linux - Networking (
-   -   How to connect CUPS to a USB LPR network print server? (

fedoralinuxjunkie 11-18-2010 10:33 PM

How to connect CUPS to a USB LPR network print server?
Hey all. I just recently bought a WinStar USB LPR Network Print Server so that I could connect my printer to my network so all the machines on my network could print, and everything would be OS independent. The problem I'm having is that I can't get CUPS to connect to the printer. It either never prints anything, saying that the printer is not connected, or saying that LPR is spooling the job, but it never completes. I've been configuring it as a network printer in CUPS, and trying all the different configuration options to no avail. The print server is located on and is pingable. The print server I have is this one:

WinStars Networking USB LPR Print Server

What is the correct way to set up a print server like this so I can print to it? Thanks :).

stress_junkie 11-18-2010 10:43 PM

Look on the print server for error messages via its web interface. You may see things like authentication errors or incorrect printer driver messages. That would give you a starting point.

fedoralinuxjunkie 11-18-2010 10:47 PM

Just looked through the web interface and manual for the print server... unfortunately it keeps no logs :(

stress_junkie 11-18-2010 11:01 PM

You could try using Wireshark to the Linux machine. The network exchange may have enough ASCII content to tell you what is going wrong. Hopefully your distribution has Wireshark in its software package repository. Otherwise you will have to compile it, unfortunately.
Wireshark is excellent once you get used to it.

fedoralinuxjunkie 11-18-2010 11:37 PM

Alright, so I installed and ran Wireshark and tried to print again. The printer was connected to, but when I tried to print, I get a steady string of something similar to this the whole time LPR is trying to spool the job:


174        53.147391        TCP        [TCP Dup ACK 140#6] printer > 1023 [PSH, ACK] Seq=5 Ack=7473 Win=1460 Len=0
And that keeps happening until I reset the printer...

markush 11-19-2010 03:59 AM

Hi fedoralinuxjunkie,

could you please post your cups-configuration?
Be aware that there is a difference between a networkprinter, (i.e. a printer with it's own NIC) and a printer which is connected to another computer/printserver.


fedoralinuxjunkie 11-21-2010 10:23 PM

Actually after looking more closely at the logs and at the error logs for CUPS, I found out that this printer is just not supported by this print server. This USB print server requires that all processing is done by the printer, and no helper applications are used to process the print job (the bossman where I work at told me this when I bought it, but I did not know my printer was not supported). So it is not the fault of CUPS in this case. I do appreciate all the help though :).

miguelmello 07-08-2014 09:37 PM

Right URI for USB LPR Network Print Server
I was able to print from Fedora 20 by setting the following URI in CUPS:


Even my printer (OKI MB260) not officially supported by the Win-Star WS-NU72P11 Print Server, I was able to get cups print though the Print Server with no futher problems.

jasonelve 07-15-2014 02:44 AM

Look at print server for mistake information via its web interface. You may see things like verification mistakes or wrong printer driver information. That would give you a kick start.

All times are GMT -5. The time now is 05:00 PM.