-   Linux - Networking (
-   -   How to connect CUPS to a USB LPR network print server? (

n56 10-20-2012 12:09 AM

How to connect CUPS to a USB LPR network print server?
I've got one of those Winstars Technology Co., Ltd. Networking USB LPR Print Servers (Model WS-NU62P1) as shown here

But I can't get a good test page printout when I use it with Linux (Ubuntu 10.04 Lucid Lynx).

Wireshark shows lots of TCP retransmissions from my Linux box and something like 239 TCP Dup ACKs coming from the server for every TCP retransmission from my Linux box.

Eventually something comes out of the printer. But when it finally does, it's mostly blank sheets of paper with only the top portion of the test page showing somewhere in the middle of the dozens of sheets that come out of the printer. I don't know if the entire test page would get printed because I cancel the job before much more paper gets wasted.

I can print directly to the printer from Linux just fine through either the parallel port (/dev/lp0), or direct USB. All 3 configurations (parallel, USB, and printer server) are using the CUPS driver for my printer.

When I set the printer device URI in Ubuntu, I tell it to "Find Network Printer", which it does. And when it probes, it comes back with the queue as "PASSTHRU".

So the full Device URI ends up being: lpd://ip_address/PASSTHRU (where ip_address is really a numeric IP address on my local network)

I can also print to the printer through the printer server using OSX. Those test pages come out right away on one sheet as they should.

So it doesn't seem to be an issue where the printer isn't supported by the print server.

Unfortunately, although this printer server has its own web server, the only diagnostic info it provides is a link status of either "Online" (when it's idle) or "Busy" (when it's processing a print job), and a device status of either "Unsupported" (when the printer is powering up) or "Ready" (after the printer powers up). I can find no logging information. No telnet or rsh either into the device either.

By the way, the Ubuntu printer properties show "Printer State: Processing - Spooling LPR job, 0% complete..." for the longest time. I didn't bother to notice what that changes to when paper finally starts coming out of the printer.

Anyone have any ideas on how to get Linux to print properly with this printer server?

Note that I did see this thread which was marked as "SOLVED" in 2010: That thread was closed out when the original poster found out that his printer was not supported by his printer server.

aetratus 10-20-2012 10:32 PM


cd /usr/lib/cups/backend && ./bjnp
What's that report? I suspect you should be using lp, not passthru for the queue (specs say it's supported).

n56 10-21-2012 05:07 AM

It reports:

network bjnp "Unknown" "Canon network printer"
I don't have a Canon printer. And that message looks to be what you get if:


(num_printers = bjnp_discover_printers (printers)) == 0)
But it could just be my installation of cups-bjnp. I had to download the source and build/install it first. And I had to install libcups2-dev and libcupsdriver1-dev to get it to build.


I suspect you should be using lp, not passthru for the queue
I can change (and have changed) the queue to lp, but it doesn't seem to make a difference.

Bummer. Looks like I'll be stuck using the non-network option to print from my Linux box.

aetratus 10-22-2012 12:27 AM

Yuck. Have you tried changing it to lpd://ip_address:8611 just for giggles? For that matter, try scanning it to see which ports are open on it (nmap), then test connecting to those ports (nc -v)...might want to look up the manual commands for lp to test printing that way.

All times are GMT -5. The time now is 06:38 PM.