LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 10-20-2008, 03:51 AM   #1
srinivas1224
LQ Newbie
 
Registered: Oct 2008
Posts: 5

Rep: Reputation: 0
how to check whether ipv6 is enables or not in my system


Hi,

I'm using Linux Fedora core6, I want to check whether the my system is enable to ipv6 or not. Is there any commands to check this.
 
Old 10-20-2008, 06:37 AM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,733

Rep: Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835
You can run
Code:
ifconfig
and see if your nic has an ipv6 address, or
Code:
lsmod|grep ipv6
to see if the ipv6 module is loaded into the kernel.
 
Old 10-21-2008, 01:16 AM   #3
srinivas1224
LQ Newbie
 
Registered: Oct 2008
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by bathory View Post
You can run
Code:
ifconfig
and see if your nic has an ipv6 address, or
Code:
lsmod|grep ipv6
to see if the ipv6 module is loaded into the kernel.
hi bathory !

Thanks for reply.

Already I did the same. but my network manager is arguing reg in my system ipv6 is disabled but kernel is ready to support ipv6, if ipv6 service is enabled.

Case1:
[root@srinivas ~]# cat /etc/sysconfig/network
NETWORKING=yes
NETWORKING_IPV6=no
HOSTNAME=localhost.localdomain


Case2:

[root@srinivas ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth0
# Intel Corporation 82557/8/9 [Ethernet Pro 100]
DEVICE=eth0
ONBOOT=yes
NETMASK=255.255.255.0
IPADDR=192.168.0.119
GATEWAY=192.168.0.13
TYPE=Ethernet
USERCTL=no
IPV6INIT=no
PEERDNS=yes
BOOTPROTO=none
HWADDR=00:a0:c9:db:90:81
[root@srinivas ~]#



As per you mail these are the results for those commands,

[root@srinivas ~]# lsmod|grep ipv6
ipv6 267745 14

[root@srinivas ~]# ifconfig
eth0 Link encap:Ethernet HWaddr 00:A0:C9B:90:81
inet addr:192.168.0.119 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::2a0:c9ff:fedb:9081/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:72774 errors:3 dropped:0 overruns:0 frame:3
TX packets:53070 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:20612174 (19.6 MiB) TX bytes:6169872 (5.8 MiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1982 errors:0 dropped:0 overruns:0 frame:0
TX packets:1982 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:6740142 (6.4 MiB) TX bytes:6740142 (6.4 MiB)

[root@srinivas ~]#

Let me know is really ipv6 is enabled in my system or not. Incase if it is enabled how can I disable it.
 
Old 10-21-2008, 03:50 AM   #4
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,733

Rep: Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835
Quote:
[root@srinivas ~]# lsmod|grep ipv6
ipv6 267745 14
The ipv6 module is loaded into kernel, that means that your system supports ipv6 (you can say it's enabled). But according to your nic configuration you've stop the ipv6 networking ability.
If you want to disable it completely, then make sure that the ipv6 module is not loaded at startup. I don't know about Fedora, but in general you can put the module in /etc/modprobe.d/blacklist to prevent it from loading on boot.

Regards
 
Old 10-21-2008, 12:46 PM   #5
srinivas1224
LQ Newbie
 
Registered: Oct 2008
Posts: 5

Original Poster
Rep: Reputation: 0
how can I set the disabling ipv6 environment to existing /etc/modprobe.d/blacklist file. Is there any problem with this update?
 
Old 10-21-2008, 12:58 PM   #6
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,733

Rep: Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835Reputation: 1835
Add the following in /etc/modprobe.d/blacklist:
Code:
blacklist ipv6
There would be no problem disabling ipv6, if you don't need it.

Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
An error Occurred during the file system check. Dropping you to shell; the system wil aneikei Linux - Newbie 3 02-11-2010 07:38 PM
how can I check my system? Perquisitor Linux - Security 12 12-10-2007 12:04 PM
How to set IPv6 address on IPv6 router tlemons Linux - Networking 3 09-17-2007 01:25 PM
Linux set up that enables ie6... GNewbie Linux - General 4 10-29-2005 08:14 PM
Server doesn't work with port forwarding enables Dawyea Linux - Networking 7 06-19-2004 09:57 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 10:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration