LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   How to allow specific user to login Vsftp server (https://www.linuxquestions.org/questions/linux-networking-3/how-to-allow-specific-user-to-login-vsftp-server-446064/)

winxandlinx 05-18-2006 10:15 AM

How to allow specific user to login Vsftp server
 

Hi Everyone ,

i just started the service of vsftpd in

the fedora core 4 ,now its loogging in through

anonymous login ,so how i can i allow only specify user

to login through the ftp server ?

well and good if any one can helop out of this issue

Thanks & Regards
winxandlinx

mchitrakar 05-18-2006 10:52 AM

working in /etc/vsftpd/vsftd.conf will do the job. and also see these files: vsftpd.ftpusers vsftpd.user_list

winxandlinx 05-18-2006 11:08 AM

Hi mchitrakar,

Thanks for your Reply ,But can you describe briefly

Since i am new to linux thats y

Thanks & Regards
winxandlinx

mchitrakar 05-18-2006 12:29 PM

do in vsftpd.conf:
anonymous_user=NO
...
userlist_enable=YES
userlist_deny=NO
and add your user to "vsftpd.user_list"
check that your user is not in "vsftpd.ftpusers"

winxandlinx 05-24-2006 07:47 AM

i am getting the login screen but i accnot able to login through

root and other username also ,anything has to be done apart from

that


here my vsftpd.conf file


Example config file /etc/vsftpd.conf

#
# Allow anonymous FTP?
anonymous_enable=NO
#
# Uncomment this to allow local users to log in.
local_enable=YES
#
# Uncomment this to enable any form of FTP write command.
write_enable=YES

local_umask=022

#anon_upload_enable=YES
dirmessage_enable=YES
#
# Activate logging of uploads/downloads.
xferlog_enable=YES

connect_from_port_20=YES
# If you want, you can have your log file in standard ftpd xferlog format
xferlog_std_format=YES
You may fully customise the login banner string:
ftpd_banner=Welcome to blah FTP service.
pam_service_name=vsftpd
userlist_enable=YES

#enable for standalone mode
listen=YES
tcp_wrappers=YES

my vsftpd.user_list file

vsftpd userlist
# If userlist_deny=NO, only allow users in this file
# If userlist_deny=YES (default), never allow users in this file, and
# do not even prompt for a password.
# Note that the default vsftpd pam config also checks /etc/vsftpd.ftpusers
# for users that are denied.

bin
daemon
adm
lp
sync
shutdown
halt
mail
news
uucp
operator
games
nobody

my vsftpd.ftpusers

# Users that are not allowed to login via ftp
root
bin
daemon
adm
lp
sync
shutdown
halt
mail
news
uucp
operator
games
nobody


Thanks & Regards
winxandlinx


All times are GMT -5. The time now is 03:19 PM.