LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 04-14-2004, 09:20 AM   #1
Sm1ler
Member
 
Registered: Apr 2004
Location: UK
Distribution: Fedora Core (all), Knoppix, RHEL, Centos, Debian
Posts: 100

Rep: Reputation: 16
Lightbulb How do I install/configure ssh?


Hi everyone and best wishes to you all,

Does anyone know where I can find a simple step by step guide to setting up an ssh connection from an XP box to my Mandrake/Samba server? I just want to be able to access a secure shell or maybe an Xwindow from my XP system so I can administer my samba box without the requirement for a monitor, keyboard and mouse etc. Any help or simple guides would be great, I have only ever done this with VNC before and I would like to secure things a little more than that!!! I am suck using my XP system at the moment as my main system is down with a hardware fault and to top things off I am having samba/XP authentication issues so ssh and maybe PuTTy? Could really help me out.

Regards
Sm1ler
 
Old 04-14-2004, 10:49 AM   #2
PenguinPwrdBox
Member
 
Registered: Oct 2003
Posts: 568

Rep: Reputation: 30
well, doing an ssh install is quite easy. Unless you diabled it, sshd should start with your machine. If you did, simply type sshd at a bash prompt. Most ssh clients use the following syntax from a DOS prompt:

Code:
ssh %host% /user:username
You will be prompted to accept/reject the machines keys, and provided you say yes, enter your password, and bingo........

If you have no keys configured, then on the *nix box, type ssh-keygen at a bash prompt.
This will create RSA keys (RSA is the default encryption mech) in /home/%USER%/.ssh/
Try to connect again......you should be good.

If for whatever reason, you aren't a fan of RSA, you can specify several different encryption schemes, if you desire. Most distros support a lot of schemes, and if your fav is not found, you can load the module for it. 3DES is availible by default, but if you dig Blowfish, etc......you can do that as well.....it's up to you. If you deviate from RSA, though, you may need to specify that to your Windows client........check the docs that come with it for steps on how to do that.
 
Old 04-14-2004, 11:58 AM   #3
Sm1ler
Member
 
Registered: Apr 2004
Location: UK
Distribution: Fedora Core (all), Knoppix, RHEL, Centos, Debian
Posts: 100

Original Poster
Rep: Reputation: 16
Great, thanks very much for your assistance I will give it a go as soon as I get a chance later tonight... I am sure that when I installed Mandrake and Samba I selected ssh to be installed... Will ssh listen for connections automatically or will I have to configure that? Sm1ler
 
Old 04-14-2004, 04:31 PM   #4
PenguinPwrdBox
Member
 
Registered: Oct 2003
Posts: 568

Rep: Reputation: 30
If you have sshd running, it is listening. You can change the port that it is listening on by editing /etc/sshd/sshd.conf.
 
Old 04-14-2004, 04:35 PM   #5
Inexactitude
Member
 
Registered: Oct 2003
Distribution: Slackware 12.2, Ubuntu 9.04
Posts: 477

Rep: Reputation: 30
Also remember to turn root login off!

For me, setting up sshd was pretty easy, there really isn't much that can go wrong. So have fun.
 
Old 04-15-2004, 04:37 AM   #6
Sm1ler
Member
 
Registered: Apr 2004
Location: UK
Distribution: Fedora Core (all), Knoppix, RHEL, Centos, Debian
Posts: 100

Original Poster
Rep: Reputation: 16
Thanks everyone for all your help, Enabled sshd last night and downloaded the puTTY.exe to my XP system and all worked first time with no issues or config. Great news - I can now put my Samba server in the corner of the room on a shelf out the way with no keyboard monitor or mouse and just let it do it's job...

Just one other quick Q for - Inexactitude - how do I disable sshd root login?

Regards and thanks to everyone
Sm1ler
 
Old 04-15-2004, 03:56 PM   #7
Inexactitude
Member
 
Registered: Oct 2003
Distribution: Slackware 12.2, Ubuntu 9.04
Posts: 477

Rep: Reputation: 30
Just add PermitRootLogin no to your sshd_config file and you'll be all set.
 
Old 04-16-2004, 05:36 AM   #8
Sm1ler
Member
 
Registered: Apr 2004
Location: UK
Distribution: Fedora Core (all), Knoppix, RHEL, Centos, Debian
Posts: 100

Original Poster
Rep: Reputation: 16
Once again thanks to everyone for all your assistance, added that line to my sshd_config late last night so I trust it will all be ok... I will test it over the weekend and if I have any problems I will let you all know.

Thanks again and best Wishes
Sm1ler
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Help:how to configure ssh in colinux 0.6.2(debian 2.6 image) sssslang Linux - Security 1 08-22-2005 09:32 AM
configure terminal to send keepalives for ssh naijaguy Linux - Newbie 3 03-22-2005 05:40 PM
ssh ./configure problem mrobb Red Hat 1 08-05-2004 03:08 PM
configure: error: when trying to install / configure new software ? met tomfer007 Linux - Software 1 07-25-2004 04:52 PM
How to further configure Ssh? toastermaker Linux - Newbie 10 11-07-2003 04:12 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 10:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration