Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 07-15-2006, 04:11 AM   #1
Registered: Aug 2004
Location: United Kingdom
Distribution: Debian
Posts: 88

Rep: Reputation: 15
Question How do I find/determine faulty network hardware?


I'm seeing the following error (followed by some kind of dump info) in syslog, sometimes dozens of times per day:

Jul 14 23:01:06 samba kernel: eth0: Transmit error, Tx status register 82.
Jul 14 23:01:06 samba kernel: Probably a duplex mismatch.  See Documentation/net
So I checked vortext.txt and it says of the error:
"This is a common error which is almost always caused by another host on the same network being in full-duplex mode, while this host is in half-duplex mode. You need to find that other host and make it run in half-duplex mode or fix this host to run in full-duplex mode.

As a last resort, you can force the 3c59x driver into full-duplex mode with

options 3c59x full_duplex=1

but this has to be viewed as a workaround for broken network gear and should only really be used for equipment which cannot autonegotiate."

How would I determine which Windows machine (there are only 8) or hub is responsible for this? slight problem is I'm 100 miles away, so anything I can do remotely would be much preferred (I have full remote access to everything).

Many thanks,
Old 07-15-2006, 09:58 AM   #2
LQ Guru
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, CoreOS, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 6,986
Blog Entries: 14

Rep: Reputation: 1187Reputation: 1187Reputation: 1187Reputation: 1187Reputation: 1187Reputation: 1187Reputation: 1187Reputation: 1187Reputation: 1187
Ignore the comment about last resort. Autonegotiate does not work well at all on 10/100 networks (it has be used on 1000 as there is no way to turn it off).

Almost always issue is autonegotiate. Setting everything to Speed 100 and Duplex Full helps. Not familiar with vortex. Have a look at ethtool or mii-tool. ethtool is better but some older cards don't work with it.

ethtool eth0

Will show you current settings of eth0. See if autonegotiate is on and if so turn it off with ethtool. (man ethtool - shows you documentation for this command). Also make sure to set speed to 100 and Duplex to Full.

Ideally all your systems should have 100 Full rather than autonegotiate.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Use Linux to determine hardware specs?? LaCampanas Linux - Software 7 03-31-2010 12:33 AM
how to determine hardware requirement for lamp applicaiton LinuxLover Linux - General 3 06-28-2006 02:47 PM
determine whether 'find' cmd found the file or not mufy Linux - General 7 03-16-2005 07:24 AM
Linux is extremely slow, network faulty? niklasa Linux - Networking 4 02-10-2003 01:03 AM
Could not determine network interfaces? _TK_ Linux - Networking 1 12-16-2002 03:38 PM > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 09:12 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration