-   Linux - Networking (
-   -   How can I mount a NFS share that have a SMB share mounted? (

perezyanez 09-23-2008 12:39 PM

How can I mount a NFS share that have a SMB share mounted?
I have a Knoppix 5.1 machine that have a SMB share mounted. This machine shares the smb mount point via NFS.
How can access in a Solaris 8 machine without Samba the SMB share mounted in Knoppix through NFS?
The NFS server just tell me: "Permission denied".
I supposse that the problem are the credentials to the SMB share, but... how can I give this credentials in a NFS mount command?

Woodypecker 09-23-2008 02:24 PM

Hmm, we @w0rkplace have a setup where the server mounts san volumes and exports them locally
with samba for the windows clients, but some as well via nfs over wan to make them accessable
for remote clients. On the branch office servers, they are mounted using nfs, but reexported
with samba - for the local win clients.
That's a way to provide "roaming home shares".
What we have, is a common ldap database which is used for authentication by win clients
and 'nix machines as well.
Now, reexporting samba via nfs (the other way round) does not work, according to where you may find a
solution/workaround (sharity, sharity light) as well.
Indeed, sharity is available for other 'nix platforms as well, it may work just
fine on the solaris box to import the windows share directly.

perezyanez 09-26-2008 09:03 AM

New approach
Thank you for your response.

I have found a solution to my original problem: backup files in several Windows servers to a tape drive in a Solaris machine (but this Solaris machine have not Samba and I can not install any software in it nor in the Windows servers).

Using a different approach, now I am using a Linux machine like a bridge, it connect to the SMB shares in Windows servers and then perform the backup to the tape in Solaris using:

tar -cvf - SMB_mount_points_separated_with_spaces | rsh IP_address_of_the_Solaris_machine dd of=/dev/rmt/1c

But first:

In Solaris I created the same user whom execute the piped tar command in Linux, this user must have permissions rw on the /dev/rmt/1c and rx on the dd command, both on Solaris.

Also in Solaris I created the files:

/etc/hosts.equiv, that contain just a single string: the IP address of the Linux machine

/.rhosts, containing a single line: the IP address of the Linux machine, a space, the name of the Linux's user whom execute the piped tar command.

If you can not set the apropiate permissions or have another problem with the dd command or the /dev/rmt/1 device, then use the Linux's root to execute the same piped tar command (is not good idea), or use the Solaris's root to execute only the dd command (is not good idea neither), adding the -l option:

tar -cvf - SMB_mount_points_separated_with_spaces | rsh -l root IP_address_of_the_Solaris_machine dd of=/dev/rmt/1c

In both, you must change the user in the /.rhosts file to root

Note: If you can use rsh with Kerberos (see the man page of rsh) or ssh instead rsh... is better

All times are GMT -5. The time now is 04:43 PM.