LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 05-11-2015, 02:35 PM   #1
micropup
LQ Newbie
 
Registered: May 2015
Posts: 5

Rep: Reputation: Disabled
Question Hostname resolution failed - how can I troubleshoot this error in my router?


I'm new to networking. Here is my situation -

I just setup remote desktop connection on my Ubuntu 14.04. Everything works like a charm it's great and it was not difficult to setup.

One thing I had to do was to setup port forwarding on my router. This also was easy.

So far everything works. Then I tested my system. I shutdown my computer (the one sharing it's desktop 'Ubuntu').

After restarting, I was not able to connect to it again.

I solved the issue by logging into my router and deleting the portforwarding entry and setting it up again. Since the entry was stuck on resolving. It couldn't automatically resolve it.

I don't know enough about this, but I noticed something confusing. My computer (Ubuntu) has 2 IP addresses. 1 is the name of the computer and 2 is new-host.

Can someone pleas explain to me how I can set this up. I may have to reboot my computer when I'm away, and I need it to be able to startup again so i can connect to it.
 
Old 05-11-2015, 02:56 PM   #2
camorri
LQ 5k Club
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 15.0, current, slackware-arm-currnet
Posts: 6,248

Rep: Reputation: 861Reputation: 861Reputation: 861Reputation: 861Reputation: 861Reputation: 861Reputation: 861
This is just my best guess. I suspect you have Ubuntu set up to get its IP address from DHCP, probably in your router. I'm thinking after the reboot, your system got a different IP address than the earlier time.

You can display the current IP address by running ifconfig for a wired connection, or run iwconfig for a wireless connection.

There are two ways to stop this behaviour. One is to set a static IP address in Ubuntu so you always know what address it is. The second way, in your router, there should be an option to always assign a specific IP to a MAC address. MAC addresses are the hardware address of the nic, wired or wireless. Since I have no idea what make and model of router you have, I can't be more specific. Look in the documentation for the router, most panels and options should be documented there.

If you can not figure that out, post the make and model of the router. Possibly someone can help more then.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Hostname resolution diogosalazar Linux - Networking 1 03-16-2011 12:27 PM
New Install of Debian Failed to Load Grub Troubleshoot options Gutsy_Iain_08 Linux - Newbie 1 03-21-2010 01:37 AM
"X error of failed request" when switching to higher resolution Jesse Anders Linux - Hardware 0 03-28-2007 07:52 PM
Router port forwarding troubleshoot andresesfm Linux - Networking 1 09-22-2006 04:26 AM
ERROR: Dependency resolution failed tronica SUSE / openSUSE 5 06-27-2006 09:52 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration