LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 11-01-2016, 01:46 AM   #1
poplinux
Member
 
Registered: May 2012
Posts: 111

Rep: Reputation: Disabled
hostapd fail, Intel 7260 module.


Dear Sir.

I want to use the 802.11ac AP. But have a some problem.

My env is see below.

OS : ubuntu 16.04.1
kernel : 4.4.0-45-generic
hostapd : V 2.4
Wifi Module : Intel 7260HMW

My first test is setup 802.11 g mode. It is successfully running.
hostapd.conf
Code:
interface=wlp1s0
bssid=08:10:79:17:c5:9e
driver=nl80211
ssid=poplinux
hw_mode=g
channel=1
auth_algs=1
ignore_broadcast_ssid=0
wpa=3
wpa_passphrase=1234567890
wpa_key_mgmt=WPA-PSK
wpa_pairwise=CCMP
rsn_pairwise=CCMP
My second test is 802.11 ac mode. This mode is have a some problem
Code:
### hostapd configuration file
ctrl_interface=/var/run/hostapd
ctrl_interface_group=0
interface=wlp1s0
bssid=08:10:79:17:c5:9e
driver=nl80211

### IEEE 802.11
ssid=poplinux
hw_mode=a
channel=44
max_num_sta=128
auth_algs=1

### DFS
country_code=US
ieee80211d=1
ieee80211h=0

### IEEE 802.11n
ieee80211n=1
ht_capab=[HT40+][LDPC][SHORT-GI-20][SHORT-GI-40][TX-STBC][RX-STBC1][DSSS_CCK-40]

### IEEE 802.11ac
ieee80211ac=1
vht_oper_chwidth=1
vht_capab=[MAX-MPDU-11454][RXLDPC][SHORT-GI-80][TX-STBC-2BY1][RX-STBC-1]
vht_oper_centr_freq_seg0_idx=62

### IEEE 802.11i
wpa=3
wpa_passphrase=1234567890
wpa_key_mgmt=WPA-PSK
wpa_pairwise=CCMP
rsn_pairwise=CCMP

### hostapd event logger
logger_syslog=-1
logger_syslog_level=2
logger_stdout=-1
logger_stdout_level=2
and running hostapd using this hostapd.conf.ac. log message is see below.
Code:
Configuration file: ./hostapd.conf.ac
wlp1s0: interface state UNINITIALIZED->COUNTRY_UPDATE
wlp1s0: IEEE 802.11 Configured channel (44) not found from the channel list of current mode (2) IEEE 802.11a
wlp1s0: IEEE 802.11 Hardware does not support configured channel
Could not select hw_mode and channel. (-3)
wlp1s0: interface state COUNTRY_UPDATE->DISABLED
wlp1s0: AP-DISABLED 
wlp1s0: Unable to setup interface.
wlp1s0: interface state DISABLED->DISABLED
wlp1s0: AP-DISABLED 
hostapd_free_hapd_data: Interface wlp1s0 wasn't started
nl80211: deinit ifname=wlp1s0 disabled_11b_rates=0
So, I'm try to use ACS mode. just modify the "channel=44" to "channel=0".
But ACS is fail.
Code:
Configuration file: ./hostapd.conf.ac
wlp1s0: interface state UNINITIALIZED->COUNTRY_UPDATE
ACS: Automatic channel selection started, this may take a bit
wlp1s0: interface state COUNTRY_UPDATE->ACS
wlp1s0: ACS-STARTED 
ACS: Unable to collect survey data
ACS: All study options have failed
Interface initialization failed
wlp1s0: interface state ACS->DISABLED
wlp1s0: AP-DISABLED 
ACS: Possibly channel configuration is invalid, please report this along with your config file.
ACS: Failed to start
wlp1s0: AP-DISABLED 
hostapd_free_hapd_data: Interface wlp1s0 wasn't started
nl80211: deinit ifname=wlp1s0 disabled_11b_rates=0
wlp1s0: interface state DISABLED->DISABLED
wlp1s0: interface state DISABLED->DISABLED
wlp1s0: AP-DISABLED 
hostapd_free_hapd_data: Interface wlp1s0 wasn't started

Please help me.
 
Old 11-01-2016, 02:09 AM   #2
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: USA
Distribution: Lubuntu 14.04, 22.04, Windows 8.1 and 10
Posts: 6,282
Blog Entries: 4

Rep: Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842
Quote:
Originally Posted by poplinux View Post
Please help me.
I found a thread concerning another hostapd issue here that might be relevant, although I don't know if the bug mentioned also applies to 16.04. I also found another thread here. It might be worth contacting the folks over at hostapd, in case you get no further response here.

Regards...

Last edited by ardvark71; 11-01-2016 at 02:15 AM. Reason: Changed and added information.
 
Old 11-01-2016, 11:27 PM   #3
poplinux
Member
 
Registered: May 2012
Posts: 111

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by ardvark71 View Post
I found a thread concerning another hostapd issue here that might be relevant, although I don't know if the bug mentioned also applies to 16.04. I also found another thread here. It might be worth contacting the folks over at hostapd, in case you get no further response here.

Regards...
Thank's your advise.

All link's are "use ACS". But ACS is just support ath5k,ath9k,ath10k modules. Not support Intel 7260 module.
 
Old 11-01-2016, 11:32 PM   #4
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: USA
Distribution: Lubuntu 14.04, 22.04, Windows 8.1 and 10
Posts: 6,282
Blog Entries: 4

Rep: Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842
Quote:
Originally Posted by poplinux View Post
Thank's your advise.
You're welcome, I hope someone comes along who can offer a better solution for you.

Regards...
 
Old 11-17-2016, 06:32 PM   #5
poplinux
Member
 
Registered: May 2012
Posts: 111

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by ardvark71 View Post
You're welcome, I hope someone comes along who can offer a better solution for you.

Regards...
Dear Friend.

Intel 7260 is only support AP mode on 2.4G. and not support AP mode on 5G.

It is spec of HW.

So, I was give-up to running the 802.11 ac mode on this module.

Thank you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel 7260 ac not recognized endhx Linux - Networking 7 06-22-2014 09:33 AM
[SOLVED] Intel Dual Band Wireless-N 7260 headache in 14.1 FireBlast Slackware 9 05-24-2014 12:28 PM
[SOLVED] Intel 7260 on Slack 14.1 aihaike Slackware 2 12-22-2013 04:24 PM
Updated firmware for Intel 3160/7260 xflow7 Slackware 0 12-17-2013 04:44 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 07:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration