LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 05-11-2005, 09:26 AM   #1
hamish
Member
 
Registered: Aug 2003
Location: Edinburgh
Distribution: Server: Gentoo2004; Desktop: Ubuntu
Posts: 720

Rep: Reputation: 30
Horde-IMP : missing Options links. Preferences not saved


Hello

I might be being really dumb, but my install (using emerge (Gentoo)) of Horde does not have an "Options" link at the top of the page. I assume that I need to enable users to change their preferences, however, I cannot find how to do this. No doubt something in the config file.

Could someone please point me in the right direction.

Also, I can go to http://domain.com/horde/imp/prefs.php and the Options page is there. I can add edit the default entry. However, when I submit the changes, it says they are submitted, but in fact they don't ever change. I suspect these two problems are related and that once I allow preferences to be edited, the menu link will be there.

Could someone lpease help.

thanks
hamish
 
Old 05-11-2005, 04:27 PM   #2
hamish
Member
 
Registered: Aug 2003
Location: Edinburgh
Distribution: Server: Gentoo2004; Desktop: Ubuntu
Posts: 720

Original Poster
Rep: Reputation: 30
SOLVED. I found what I was looking for. Here's some details in case someone else needs this:

Code:
to get horde preferences working:

# vim /usr/www/horde/config/horde.php

	and, in the Preference System Settings section, set this line (it will originally be written as = 'none':
		$conf['prefs']['driver'] = 'sql';

	Just underneath, uncomment the example of the sql database and set it as follows:

	$conf['prefs']['params']['phptype'] = 'mysql';
	$conf['prefs']['params']['hostspec'] = 'localhost';
	$conf['prefs']['params']['username'] = 'horder';
	$conf['prefs']['params']['password'] = 'password';
	$conf['prefs']['params']['database'] = 'horde_imp';
	$conf['prefs']['params']['table'] = 'horde_prefs';

# vim /usr/www/horde/scripts/db/prefs.sql

	add the following lines at the top:

		DROP DATABASE IF EXISTS horde_imp;
		create database horde_imp;
		use horde_imp;

	and change the last line to add the password for the user:

		grant select, insert, update, delete on horde_prefs to horde identified by 'password';

update the database:
#  mysql -u root -p < /usr/www/horde/scripts/db/prefs.sql


You should now have the Options link and be allowed to change the identies.
hamish
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
IMP+Horde on PHP 4.3.7 Ryand833 Linux - Software 0 07-04-2004 01:58 PM
imp+horde linuxtesting2 Linux - General 0 06-27-2004 07:51 PM
horde/imp configuring koningshoed Linux - Software 1 02-17-2004 05:36 AM
Horde and IMP works 50% leeman_s Linux - General 1 11-17-2003 11:19 PM
Horde/IMP george3k Programming 0 09-14-2001 10:07 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 09:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration