Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 04-27-2006, 05:49 PM   #1
Registered: May 2003
Location: Adelaide, Australia
Distribution: Fedora Core 3
Posts: 52

Rep: Reputation: 15
Home LAN Setup

Hi there Guys,
I've got myself in a bit of a pickle. I am trying to setup my FC5 box at home to take care of the internet connection using rp-pppoe. I tried the other day without a huge amount of success.

I have my ADSL2 modem / router in Pure bridged mode which from my understanding just forwards packets off to the interface, to that a cable going directly into eth0 on the linux box

eth1 (2nd nic) in the linux box then goes off to a switch and rest of the network.

I can establish a connection from the linux box using rp-pppoe and browse sites no worries at all from the linux box but not on windows, I can't even ping IP's but I am close I feel and it can only be something simple.

Where my confusion sets in is eth0 is set to use DHCP, do I need an IP address, subnet mask etc set on this one?

I have eth1 set to as the IP and as the gateway.

Should I need to set eth0 with an IP of some description, ppp0 gets an IP from my provider (dynamic) so I'm thinking perhaps I do the iptables to ppp0 rather than eth0?

Any help would be great, as I mentioned previously I feel I am very close but not entirely sure where I'm going wrong.


Old 04-27-2006, 06:06 PM   #2
Registered: Apr 2006
Location: Pittsburgh
Distribution: Debian Sid AMD64
Posts: 296

Rep: Reputation: 30
I don't have DSL (I have cable instead), so I can't help with DSL-specific things like the difference between ppp0 and eth0, but...

If an interface uses DHCP, you don't have to set any other parameters for it.

In order to forward packets from eth1 to eth0, you have to explicitly allow forwarding. This is done by setting "net.ipv4.ip_forward=1" in /etc/sysctl.conf. If you want it to take effect before you reboot you can run "sysctl -w net.ipv4.ip_forward=1" as root.
Old 04-27-2006, 06:07 PM   #3
LQ Guru
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 62
Have you enable IP Forwarding? If not that is what you need to do to allow network traffic to cross from eth1 to eth0. Also do not define a gateway on eth1. It will confuse a simple setup. You can leave eth0 as dhcp. Check out this site to build a simple firewall script and sets up ip forwarding for you as well all in one script.

Old 04-28-2006, 07:03 AM   #4
Registered: May 2003
Location: Adelaide, Australia
Distribution: Fedora Core 3
Posts: 52

Original Poster
Rep: Reputation: 15
Thanks for your help guys, I messed up my iptables.

I put in eth0 where it should have been ppp0, it was easy once I used that generator, I could see exactly where I went wrong.

Thanks again..



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting up a small home LAN ccin1492 Linux - Networking 21 07-31-2005 03:10 PM
sharing internet over home lan! 94gsr Linux - Networking 13 05-04-2004 03:10 AM
Setting up a server for home LAN tawalker Linux - Software 0 04-28-2004 10:57 AM
Advice for home LAN setup dkaplowitz Linux - Networking 7 08-09-2003 06:02 PM
Home LAN/Internet Share? JustinS Linux - Newbie 10 11-12-2001 06:41 PM > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 01:25 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration