-   Linux - Networking (
-   -   Help with WOL Wake on LAN (

Knight Templar 07-18-2006 07:55 PM

Help with WOL Wake on LAN
i have Mandriva 2006 , and i have been trying to configure my PC in order to WOL (wake On lan)
anyways My nic is a NC3121 Fast Ethernet NIC (WOL) and it must support WOL

lspci shows

00:0d.0 Ethernet controller: Intel Corporation 82557/8/9 [Ethernet Pro 100] (rev 05)
Subsystem: Compaq Computer Corporation NC3121 Fast Ethernet NIC (WOL)
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
Latency: 66 (2000ns min, 14000ns max), cache line size 08
Interrupt: pin A routed to IRQ 11
Region 0: Memory at 41200000 (32-bit, prefetchable) [size=4K]
Region 1: I/O ports at 2040 [size=32]
Region 2: Memory at 41100000 (32-bit, non-prefetchable) [size=1M]
Expansion ROM at <unassigned> [disabled] [size=1M]
Capabilities: [dc] Power Management version 1
Flags: PMEClk- DSI+ D1+ D2+ AuxCurrent=0mA PME(D0+,D1+,D2+,D3hot+,D3cold+)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-

i downloded the ethtools and it shows this
[root@localhost admin]# ethtool eth0
Settings for eth0:
Supported ports: [ TP MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Advertised auto-negotiation: Yes
Speed: 100Mb/s
Duplex: Full
Port: MII
Transceiver: internal
Auto-negotiation: on
Current message level: 0x000020c1 (8385)
Link detected: yes

when i do the ethtool -s eth0 wol g it goes like this

[root@localhost admin]# ethtool -s eth0 wol g
Cannot get current wake-on-lan settings: Operation not supported
not setting wol

I have been trying to turn on my linux box using the wol program from a windows box, but it says in someway that the client is non reachable , the only way the magic packets is recieved is when i turn on the pc and i suppose it should not be that way hmm.

can anyone help set this ? i checked my bios settings but it seems to be old , the 3 pin connector is connect from the NIC to the motherboard but still doesn't work. what can i do ?

mickyg 07-19-2006 07:50 AM

I believe, but don't hold me to this, that WOL is controlled by the BIOS. So if it isn't there, your BIOS doesn't support it. Have you tried googling for you BIOS to see what info there is? Or flashing your BIOS with the latest version?

Knight Templar 07-19-2006 05:08 PM

my bios says Wake on PME , so it is Wake on Power management event , i don't now the version of my Bios it doesn't say :mad:

Knight Templar 07-19-2006 10:45 PM

i downloaded a program called Mc-WOL for windows that lets me send packages to wake my pc this is the result that i got ,

:\Documents and Settings\**********\My Documents>MC-WOL 00:50:8B:0D:8C:84

WakeOnLAN v1.0 Copyright (c)2001, MATCODE Software.
Author: Vitaly Evseenko,
Sending "Magic Packet" to 00:50:8b:0d:8c:84 - Success!

C:/Documents and Settings/***********/My Documents>

I checked my linux box but it didn't wake, i don't get it i mean the light in the card is on , it should be working please help me

All times are GMT -5. The time now is 12:22 AM.