LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 07-14-2006, 02:27 AM   #1
escobar1
LQ Newbie
 
Registered: Jul 2006
Posts: 2

Rep: Reputation: 0
Help with lan card


De: "Freebird" <peoplel@hotmail.com>
Assunto: Help with lan card
Data: quarta-feira, 12 de julho de 2006 03:57

Hello you all,

I'm running a Linus Debian, 2.4.27.2.386 ( that's what uname -a says ) on a
notebook compaq armada 7800.

It's all working fine but the lan card.

I'm not really sure about which lan card I've, but when I plug the lan card
on the notebook, it seems to recognize well, but when I try 'ifconfig', I
only see the loopback information.

Here's what my dmesg says:


Linux version 2.4.27-2-386 (horms@tabatha.lab.ultramonkey.org) (gcc version
3.3.5 (Debian 1:3.3.5-13)) #1 Wed Aug 17 09:33:35 UTC 2005
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 0000000007ff6000 (usable)
BIOS-e820: 0000000007ff6000 - 0000000008000000 (ACPI NVS)
127MB LOWMEM available.
On node 0 totalpages: 32758
zone(0): 4096 pages.
zone(1): 28662 pages.
zone(2): 0 pages.
DMI not present.
ACPI: RSDP (v000 COMPAQ ) @ 0x000ffed0
ACPI: RSDT (v001 COMPAQ CPQB01B 0x00000001 CPQ 0x00000001) @ 0x07ff6000
ACPI: FADT (v001 COMPAQ FACPTBL 0x19990601 CPQ 0x00000001) @ 0x07ff6028
ACPI: DSDT (v001 COMPAQ ARMADA7X 0x00010000 MSFT 0x0100000a) @ 0x00000000
Kernel command line: root=/dev/hda1 ro
Local APIC disabled by BIOS -- reenabling.
Could not enable APIC!
Initializing CPU#0
Detected 365.691 MHz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 730.72 BogoMIPS
Memory: 123616k/131032k available (1069k kernel code, 7028k reserved, 459k
data, 96k init, 0k highmem)
Dentry cache hash table entries: 16384 (order: 5, 131072 bytes)
Inode cache hash table entries: 8192 (order: 4, 65536 bytes)
Mount cache hash table entries: 512 (order: 0, 4096 bytes)
Buffer cache hash table entries: 4096 (order: 2, 16384 bytes)
Page-cache hash table entries: 32768 (order: 5, 131072 bytes)
CPU: L1 I cache: 16K, L1 D cache: 16K
CPU: L2 cache: 256K
CPU: After generic, caps: 0183f9ff 00000000 00000000 00000000
CPU: Common caps: 0183f9ff 00000000 00000000 00000000
CPU: Intel Mobile Pentium II stepping 0a
Enabling fast FPU save and restore... done.
Checking 'hlt' instruction... OK.
Checking for popad bug... OK.
POSIX conformance testing by UNIFIX
ACPI: Subsystem revision 20040326
ACPI: Interpreter disabled.
PCI: PCI BIOS revision 2.10 entry at 0xf0474, last bus=1
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: ACPI tables contain no PCI IRQ routing entries
PCI: Probing PCI hardware (bus 00)
PCI: Ignoring BAR0-3 of IDE controller 00:0e.1
PCI: Using IRQ router default [0e11/ae69] at 00:0e.0
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
Starting kswapd
VFS: Disk quotas vdquot_6.5.1
devfs: v1.12c (20020818) Richard Gooch (rgooch@atnf.csiro.au)
devfs: boot_options: 0x0
pty: 256 Unix98 ptys configured
Serial driver version 5.05c (2001-07-08) with HUB-6 MANY_PORTS MULTIPORT
SHARE_IRQ SERIAL_PCI enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
COMX: driver version 0.85 (C) 1995-1999 ITConsult-Pro Co. <info@itc.hu>
RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize
Initializing Cryptographic API
NET4: Linux TCP/IP 1.0 for NET4.0
IP: routing cache hash table of 512 buckets, 4Kbytes
TCP: Hash tables configured (established 8192 bind 16384)
Linux IP multicast router 0.06 plus PIM-SM
RAMDISK: cramfs filesystem found at block 0
RAMDISK: Loading 3692 blocks [1 disk] into ram disk...
|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-done.
Freeing initrd memory: 3692k freed
VFS: Mounted root (cramfs filesystem).
Freeing unused kernel memory: 96k freed
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
ide: late registration of driver.
TRIFLEX: IDE controller at PCI slot 00:0e.1
TRIFLEX: chipset revision 1
TRIFLEX: not 100% native mode: will probe irqs later
ide0: BM-DMA at 0x1000-0x1007, BIOS settings: hdaMA, hdbMA
hda: IBM-DCYA-214000, ATA DISK drive
hdb: COMPAQ DVD-ROM DV22E 11, ATAPI CD/DVD-ROM drive
blk: queue c8825b60, I/O limit 4095Mb (mask 0xffffffff)
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hda: attached ide-disk driver.
hda: 27609120 sectors (14136 MB) w/420KiB Cache, CHS=27390/16/63, (U)DMA
Partition check:
/dev/ide/host0/bus0/target0/lun0: [PTBL] [1718/255/63] p1 p2 < p5 >
Journalled Block Device driver loaded
kjournald starting. Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
Adding Swap: 377488k swap-space (priority -1)
EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,1), internal journal
Real Time Clock Driver v1.10f
hdb: attached ide-cdrom driver.
hdb: ATAPI 20X DVD-ROM drive, 512kB Cache, DMA
Uniform CD-ROM driver Revision: 3.12
SCSI subsystem driver Revision: 1.00
Linux Kernel Card Services 3.1.22
options: [pci] [cardbus] [pm]
Yenta ISA IRQ mask 0x0690, PCI irq 11
Socket status: 30000006
Yenta ISA IRQ mask 0x0690, PCI irq 11
Socket status: 30000020
scsi0 : SCSI host adapter emulation for IDE ATAPI devices
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb-ohci.c: USB OHCI at membase 0xc886d000, IRQ 11
usb-ohci.c: usb-00:0e.2, Compaq Computer Corporation ZFMicro Chipset USB
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
hub.c: new USB device 00:0e.2-1, assigned address 2
spurious 8259A interrupt: IRQ7.
usb.c: USB device 2 (vend/prod 0x55d/0x2020) is not claimed by any active
driver.
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x1001
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
pciehp: acpi_pciehprm:get_device PCI ROOT HID fail=0x1001
Initializing USB Mass Storage driver...
usb.c: registered new driver usb-storage
scsi1 : SCSI emulation for USB Mass Storage devices
Vendor: SMSC Model: USB FDC Rev: 2.10
Type: Direct-Access ANSI SCSI revision: 02
Vendor: SMSC Model: USB FDC Rev: 2.10
Type: Direct-Access ANSI SCSI revision: 02
Vendor: SMSC Model: USB FDC Rev: 2.10
Type: Direct-Access ANSI SCSI revision: 02
Vendor: SMSC Model: USB FDC Rev: 2.10
Type: Direct-Access ANSI SCSI revision: 02
Vendor: SMSC Model: USB FDC Rev: 2.10
Type: Direct-Access ANSI SCSI revision: 02
Vendor: SMSC Model: USB FDC Rev: 2.10
Type: Direct-Access ANSI SCSI revision: 02
Vendor: SMSC Model: USB FDC Rev: 2.10
Type: Direct-Access ANSI SCSI revision: 02
Vendor: SMSC Model: USB FDC Rev: 2.10
Type: Direct-Access ANSI SCSI revision: 02
Attached scsi removable disk sda at scsi1, channel 0, id 0, lun 0
Attached scsi removable disk sdb at scsi1, channel 0, id 0, lun 1
Attached scsi removable disk sdc at scsi1, channel 0, id 0, lun 2
Attached scsi removable disk sdd at scsi1, channel 0, id 0, lun 3
Attached scsi removable disk sde at scsi1, channel 0, id 0, lun 4
Attached scsi removable disk sdf at scsi1, channel 0, id 0, lun 5
Attached scsi removable disk sdg at scsi1, channel 0, id 0, lun 6
Attached scsi removable disk sdh at scsi1, channel 0, id 0, lun 7
spurious 8259A interrupt: IRQ15.
SCSI device sda: 2880 512-byte hdwr sectors (1 MB)
sda: Write Protect is off
/dev/scsi/host1/bus0/target0/lun0:<3>ldm_parse_privhead(): Cannot find
PRIVHEAD structure. LDM database is corrupt. Aborting.
ldm_validate_privheads(): Cannot find PRIVHEAD 1.
unable to read partition table
SCSI device sdb: 2880 512-byte hdwr sectors (1 MB)
sdb: Write Protect is off
/dev/scsi/host1/bus0/target0/lun1:<3>ldm_parse_privhead(): Cannot find
PRIVHEAD structure. LDM database is corrupt. Aborting.
ldm_validate_privheads(): Cannot find PRIVHEAD 1.
unable to read partition table
SCSI device sdc: 2880 512-byte hdwr sectors (1 MB)
sdc: Write Protect is off
/dev/scsi/host1/bus0/target0/lun2:<3>ldm_parse_privhead(): Cannot find
PRIVHEAD structure. LDM database is corrupt. Aborting.
ldm_validate_privheads(): Cannot find PRIVHEAD 1.
unable to read partition table
SCSI device sdd: 2880 512-byte hdwr sectors (1 MB)
sdd: Write Protect is off
/dev/scsi/host1/bus0/target0/lun3:<3>ldm_parse_privhead(): Cannot find
PRIVHEAD structure. LDM database is corrupt. Aborting.
ldm_validate_privheads(): Cannot find PRIVHEAD 1.
unable to read partition table
SCSI device sde: 2880 512-byte hdwr sectors (1 MB)
sde: Write Protect is off
/dev/scsi/host1/bus0/target0/lun4:<3>ldm_parse_privhead(): Cannot find
PRIVHEAD structure. LDM database is corrupt. Aborting.
ldm_validate_privheads(): Cannot find PRIVHEAD 1.
unable to read partition table
SCSI device sdf: 2880 512-byte hdwr sectors (1 MB)
sdf: Write Protect is off
/dev/scsi/host1/bus0/target0/lun5:<3>ldm_parse_privhead(): Cannot find
PRIVHEAD structure. LDM database is corrupt. Aborting.
ldm_validate_privheads(): Cannot find PRIVHEAD 1.
unable to read partition table
SCSI device sdg: 2880 512-byte hdwr sectors (1 MB)
sdg: Write Protect is off
/dev/scsi/host1/bus0/target0/lun6:<3>ldm_parse_privhead(): Cannot find
PRIVHEAD structure. LDM database is corrupt. Aborting.
ldm_validate_privheads(): Cannot find PRIVHEAD 1.
unable to read partition table
SCSI device sdh: 2880 512-byte hdwr sectors (1 MB)
sdh: Write Protect is off
/dev/scsi/host1/bus0/target0/lun7:<3>ldm_parse_privhead(): Cannot find
PRIVHEAD structure. LDM database is corrupt. Aborting.
ldm_validate_privheads(): Cannot find PRIVHEAD 1.
unable to read partition table
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 2
USB Mass Storage support registered.
cs: cb_alloc(bus 3): vendor 0x10ec, device 0x8139
PCI: Enabling device 03:00.0 (0000 -> 0003)
cs: IO port probe 0x0100-0x04ff: excluding 0x100-0x107 0x220-0x22f
0x250-0x257 0x330-0x337 0x378-0x37f 0x388-0x38f 0x408-0x40f 0x4d0-0x4d7
cs: IO port probe 0x0800-0x08ff: excluding 0x800-0x83f 0x850-0x87f
cs: IO port probe 0x0c00-0x0cff: excluding 0xc48-0xc4f 0xc68-0xc6f
0xc80-0xc9f
cs: IO port probe 0x0a00-0x0aff: clean.
8139too Fast Ethernet driver 0.9.26
PCI: Setting latency timer of device 03:00.0 to 64
eth0: RealTek RTL8139 at 0x4800, 00:02:44:8c:51:fa, IRQ 11
eth0: Identified 8139 chip type 'RTL-8139C'
8139cp: 10/100 PCI Ethernet driver v1.2 (Mar 22, 2004)
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x1001
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
pciehp: acpi_pciehprm:get_device PCI ROOT HID fail=0x1001




What should I do to get my lan card recognized ?


Tks a lot for your help


Escobar
 
Old 07-14-2006, 02:33 AM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,821

Rep: Reputation: 1591Reputation: 1591Reputation: 1591Reputation: 1591Reputation: 1591Reputation: 1591Reputation: 1591Reputation: 1591Reputation: 1591Reputation: 1591Reputation: 1591
Quote:
eth0: RealTek RTL8139 at 0x4800, 00:02:44:8c:51:fa, IRQ 11
eth0: Identified 8139 chip type 'RTL-8139C'
8139cp: 10/100 PCI Ethernet driver v1.2 (Mar 22, 2004)
Run as root:
Code:
modprobe 8139too
If it succeeds then use your distro's network tools to configure your network
If you get any errors post them here.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Lan card problem - Two devices for the same card e-freak Fedora 4 08-25-2005 12:07 PM
question on lan card new2server Linux - Networking 1 09-04-2004 04:11 AM
How to know LAN card can use? vanhelsing Linux - Software 1 07-13-2004 12:15 PM
Wireless LAN card 802.11b and Ricoh card bus Abdul Mueid Linux - Wireless Networking 4 02-10-2004 04:10 PM
How to install a LAN card kennethpardue Linux - Hardware 2 03-31-2003 07:23 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 04:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration