LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 07-09-2005, 07:12 AM   #1
systemhackerz
Member
 
Registered: Jul 2005
Distribution: RHEL4, FC5, BackTrack
Posts: 56

Rep: Reputation: 15
Error Mounting a shared file from NFS


Help: NFS error (No route to host)
Please help me I am new to this forum and i really need help.
I have set a NFS server and exported the /var/ftp/pub directory to all clients on the network 192.168.0.0/255.255.255.0 and have run the the following commands:
exportfs -a -v
service nfs start
chkconfig nfs on
service portmap restart
chkconfig portmap on

they all where successfuly done, but still when I try to mount this directory
/var/ftp/pub i get the an error message similar to this nfs "192.168.0.254" server down

also I made the same shared directory on a client PC and when I try to mount it from the server i get this error message:
mount: RPC: Remote System Error - No Route to Host

Please Help Me

Last edited by systemhackerz; 07-09-2005 at 05:04 PM.
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 07-09-2005, 02:29 PM   #2
systemhackerz
Member
 
Registered: Jul 2005
Distribution: RHEL4, FC5, BackTrack
Posts: 56

Original Poster
Rep: Reputation: 15
can any one help me ????
 
Old 07-09-2005, 05:53 PM   #3
systemhackerz
Member
 
Registered: Jul 2005
Distribution: RHEL4, FC5, BackTrack
Posts: 56

Original Poster
Rep: Reputation: 15
Yipeeeeeeeeeeeeeeeeeeee
I have solved the problem
 
Old 07-25-2005, 10:35 AM   #4
DanielTan
Member
 
Registered: Sep 2004
Location: Malaysia
Distribution: FC6, Solaris
Posts: 340

Rep: Reputation: 30
Hi, i noticed u have solved the problem. Would u mind tell me how to solve it ? I'm also having it. Been cracking my head but still no answer. Thanks

Regards
Daniel



Quote:
Originally posted by systemhackerz
Yipeeeeeeeeeeeeeeeeeeee
I have solved the problem
 
Old 08-14-2005, 04:12 PM   #5
linux-rulz
Member
 
Registered: Dec 2004
Distribution: Windows XP Home, Ubuntu Hoary
Posts: 584

Rep: Reputation: 30
Quote:
Yipeeeeeeeeeeeeeeeeeeee
I have solved the problem
It would be greatly appreciated if you posted how you fixed this problem, so other people who are sitting in your former shoes can get it working too.
 
Old 08-15-2005, 04:54 PM   #6
systemhackerz
Member
 
Registered: Jul 2005
Distribution: RHEL4, FC5, BackTrack
Posts: 56

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by linux-rulz
It would be greatly appreciated if you posted how you fixed this problem, so other people who are sitting in your former shoes can get it working too.
Well Dont be sad my friend the solution was very easy just disable your iptables
$service iptables stop

If you want this service to keep runing with the NFS just add it as a rule to the iptables allow list
 
Old 01-25-2007, 02:26 PM   #7
rthunder
LQ Newbie
 
Registered: Jul 2006
Posts: 1

Rep: Reputation: 0
NFS through firewall In RHEL

Or in rhel run the command

% system-config-securitylevel

and add the firewall exception

nfs:tcp

This still didn't solve the problem for me, but reading this, I recognized it as one of the things I needed to do to make it possible.

I'm still getting

mount: mount to NFS server 'myhostname.mydomain.edu' failed: System Error: No route to host.
 
Old 01-26-2007, 07:59 PM   #8
xjlittle
Member
 
Registered: Aug 2003
Location: Indiana
Distribution: fc6 sles9 & 10 kubuntu ubuntu-server
Posts: 240
Blog Entries: 2

Rep: Reputation: 30
Quote:
System Error: No route to host
This means the machine that you are connecting from is not getting a TCP/IP ACK back from the server.

If turning off/adjusting iptables and/or selinux didn't fix it check your dns entries (use dig or nslookup) to make sure the ip address is correct or use the ip rather than the hostname.
 
Old 02-06-2007, 07:25 AM   #9
natv
Member
 
Registered: Mar 2006
Posts: 59

Rep: Reputation: 15
Hi guys,

I'm having the same problem and I've done all the above steps. I'm running Cent0S 4.4

Even stopping the iptables doesn't help.

The client server is able to ping the nfs server. I am using the mount command with the IP address directly.

I have in my /etc/exports file:


/root/install 192.168.1.112(ro,sync)


I ran exportfs -a -v

I started (and re-started) the nfs and portmapper, nfs is in my firewall rules,


I'm not sure what else to try (?)



Thanks
Nat
 
Old 02-06-2007, 07:29 AM   #10
natv
Member
 
Registered: Mar 2006
Posts: 59

Rep: Reputation: 15
oops my bad, I had a type in /etc/hosts on the IP address on the nfs server.

All is good now.

Nat
 
Old 07-23-2007, 08:22 PM   #11
CrazyToon
LQ Newbie
 
Registered: Jun 2003
Posts: 21

Rep: Reputation: 0
Thumbs up No route to host at bootup

I was having similar problem. It was only happening when I rebooted the server tho. So i figured it out and put a solution on my blog @ http://crazytoon.com/2007/05/11/cent...route-to-host/

Hopefully it will help somebody. I ran into this thread and wasn't able to get my answer from it when i was searching for answers.

Last edited by CrazyToon; 07-23-2007 at 08:23 PM.
 
Old 08-12-2007, 08:36 AM   #12
blackjackshellac
LQ Newbie
 
Registered: Aug 2007
Posts: 2

Rep: Reputation: 0
oh jeez

Quote:
Originally Posted by systemhackerz
Well Dont be sad my friend the solution was very easy just disable your iptables
$service iptables stop

If you want this service to keep runing with the NFS just add it as a rule to the iptables allow list
This is ABSOLUTELY NOT good advice. Don't just go turning off iptables unless you know what you're doing. And even if you do know what you're doing it's not a good idea.

The correct answer to this post is to say, it's probably your firewall setup, add nfs tcp/udp to your firewall configuration to allow your client access to the server. If you don't know what that means, dig around a bit, and replace the redhat iptables service with something like shorewall.
 
Old 08-12-2007, 01:41 PM   #13
reverse
Member
 
Registered: Apr 2007
Distribution: Gentoo
Posts: 337

Rep: Reputation: 30
/me does the "2005 originated thread brought back to life" dance
 
Old 01-25-2008, 01:49 PM   #14
robert.forster
LQ Newbie
 
Registered: Oct 2007
Location: Newport News, VA
Distribution: Solaris, Redhat, FC5.6.7.8
Posts: 11

Rep: Reputation: 2
The Answer to this as in what the previous person stated is correct. DO NOT just disable IPtables...

the issue is that the NFS needs a tcp/udp port through the firewall on the host from the client. Once the (for testing purposes only) firewall was disabled I was able to mount the NFS share. Next step is to learn which port is needed opening to permit MFS mounting from the client to the host
 
2 members found this post helpful.
Old 02-03-2008, 01:32 PM   #15
bilkay
LQ Newbie
 
Registered: Aug 2006
Location: Hopewell Junction, NY
Distribution: RedHat 9 (Shrike)
Posts: 12

Rep: Reputation: 0
I'm having the same problem upgrading from RH-9 (Shrike). I have no problem mounting from my old "Shrike" box, but can't connect to the "Werewolf" box unless iptables is disabled.

Looking at the nfs man page, it says


(for option port=n)
>
The numeric value of the port to connect to the NFS server on. If the port number is 0 (the default) then query the remote hostís portmapper for the port number to use. If the remote hostís NFS daemon is not registered with its portmapper, the standard NFS port number 2049 is used instead.
>

It would seem, then, that the server would have to have a portmapper running in order to tell the client what port to come in on. Shrike has a portmap service but Fedora does not. Something else must provide this service, but what is it?

By the way, I added 2049/tcp and 2049/udp with system-config-securitylevel to no avail.
 
  


Reply

Tags
awesomeness


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sendmail Error - No Route To Host mindfrost82 Linux - Software 3 11-17-2009 04:07 AM
No route to host error... alwaysrookie Programming 2 11-04-2005 12:33 PM
Error: No route to host! CRB314 Linux - Newbie 1 03-22-2004 03:37 AM
nfs setup on slack 9.1 - no route to host daceo Slackware 2 02-19-2004 05:04 PM
unexplanable 'no route to host' error, can anyone help? f1uke Linux - Newbie 0 04-10-2003 09:35 PM


All times are GMT -5. The time now is 02:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration