LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   help me connect redhat to the internet (https://www.linuxquestions.org/questions/linux-networking-3/help-me-connect-redhat-to-the-internet-26770/)

michaelangel 07-29-2002 12:48 PM

help me connect redhat to the internet
 
I have been trying for awhile to my mandrake to connect to the net but to great result, i am now trying again with redhat 7.3 and coming out with the same problem. i will like ask here a straight question.
i have cable modem on my windows xp runing fine.
SO HOW DO I CONFIGURE THIS LINUX TO BE ABLE TP BROWSE THE INTERNET?
please help me as a starter.
thanks in advance.
michaelangel@home.nl

utabintarbo 07-29-2002 01:11 PM

More info please!

Is your NIC set-up correctly? Type "ifconfig" as root and make sure you have an "eth0" section with a valid IP address and states that it is "UP" and "RUNNING".

How is your NIC connected to your cable modem? Are you using a router/switch? Do you have your dns servers set up (check /etc/resolv.conf)? ...

Please post more information!

Bob

michaelangel 07-29-2002 04:26 PM

the IP address i have is for windows os ,like this one here CP16009-A, which my linux have accepted .
moreover, my provider had ealier informed me that they will be of no help as far as linux.
my network card is up and running, but i think that i am messing with the so called gateway, dns server 1 and 2, also the NIC you mentioned is another case all together.
i will rather plead with you to see as newbie to linux,i am not running any network,i have a machine with winxp and redhat as second OS.
again whenever i try to my network in linux it would warn me that the device has been configured, which i suppose is refering to windowxp configuration.
michaelangel@home.nl


i am using @home cable net work in netherlands

5amYan 07-29-2002 05:06 PM

post what it says when you ifconfig -a

answer untar's ???
How is your NIC connected to your cable modem? Are you using a router/switch? Do you have your dns servers set up (check /etc/resolv.conf)? ...

turnip 07-29-2002 05:10 PM

Most cable services in the US use dhcp to get all information.
a command like
ifconfig eth0 down
dhcpcd -h <hostname> -i eth0
OR (not both)
pump -h <hostname> -i eth0

Should get you up and running. You're going to want to replace hostname with the name the cable comp gives you, if they give you one.


If either of those work for you ifconfig -a and route will print all the information they gave you.

5amYan 07-30-2002 11:19 AM

OR to have it done automatically on startup.
in /etc/sysconfig/network-scripts/ifcfg-eth0
There should be a couple lines in place.

something like

BOOTPROTO=DHCP #not static
ONBOOT=YES

that should automatically get all necessary info from DHCP server at boot time

michaelangel 08-03-2002 03:09 PM

i thought that it would be easy just like windows to get to the internet with my linux, but, still having the same problem after all these help from y'all.
many thanks for your time,i was able to get my linux to connect for a half day,and when i restarted i could not get it back on track,owing to the facts that i have tried many things before it did connect that one time i was not able to say for sure what i did to make it work.
i have tried allowing auto assign IP through DHCP but it did not respond. one thing i am sure is that my IP address which i use for winxp is 212.204.185.17 and hostname is @home.nl
and the rest about getway, netmask and getway make it more confusing than i ever imagined.
please help this who really wants to continue to study linux OS

5amYan 08-04-2002 12:44 PM

If your IP is always the same, then it's not DHCP
in in /etc/sysconfig/network-scripts/ifcfg-eth0

DEVICE=eth0
BOOTPROTO=static
BROADCAST= 212.204.185.255
IPADDR= 212.204.185.17
NETMASK=255.255.255.0
NETWORK= 212.204.185.0
ONBOOT=yes

if your ISP is using any sort of subnetting scheme some modification to the BC, NM, and NW maybe necessary.

in
/etc/sysconfig/network

NETWORKING=yes
HOSTNAME=@home.nl # whatever you want if you have the name
GATEWAY= # an IP address goes here look in xp to figure out you GW

in
/etc/resolv.conf

search bifurcating.net #your.domain here
nameserver 192.168.2.1 #your primary nameserver IP (maybe local if you run DNS)
nameserver 216.253.88.34 #you secondary nameserver IP

Start here and then let's go. If you unsure what to put as an IP find it in xp Control_Panek | Network_Connectios | connection_name | TCP/IP | properties |
or somewhere around there

michaelangel 08-05-2002 11:34 AM

i am glad and thank you very much,
my problem is that i can not access the network configuration, and i can't explain why at this time, also it is not just one particilar linux distro, mandrake, redhat ,suse and icepark are telling me that i don't have permision {as root} to access /etc/ifconfig/network-scripts/ifcfg -etho.
i strongly believe in everything you said here but, i can not do it since i can not do root service to any of these linuxes

Griffon26 08-05-2002 11:45 AM

You know, root is like... God. The only reason why God/root would not be able to do something is if he would have forbidden himself to do it (or maybe not even then) ;)

In other words if you can't change the file, one of four things is probably the case:
1) you can (duh)
2) it's not a file (duh!)
3) you've forbidden it (chmod)
4) you're not who you think you are (su)

P.S.: Wait a minute, is that an 'o' I see there?

Quote:

/etc/ifconfig/network-scripts/ifcfg -etho.
Yup! And what is that space doing there?

Guess it's situation 2 then. The file you should look for is:
/etc/ifconfig/network-scripts/ifcfg-eth0

Oh, and one other thing. That file is not something you should execute, you should open it in an editor.

5amYan 08-05-2002 08:09 PM

A bit harsh but Griffon is entirely correct

To edit from the command line try
vi /etc/ifconfig/network-scripts/ifcfg-eth0

or for a gui use gedit or kate
su
password: #enter passwd here
/usr/bin/gedit

then open
/etc/ifconfig/network-scripts/ifcfg-eth0
and edit away, don't for get to save.

You may want to try man vi before you jump in, if you use vi.

michaelangel 08-06-2002 03:35 PM

many thanks to y'all who rallied around provinding help till this day,
more credits to you 5AMYAN, for your detailed explanations.
iam on-line since last twenty four hours
again, denial of permisions as root was never a type fault , in some cases i have used root as the only account,but anyway, i should try again the vi thing. more thanks to you all

5amYan 08-06-2002 03:49 PM

welcome to linux

Griffon26 08-10-2002 05:38 PM

Quote:

Originally posted by 5amYan
A bit harsh but Griffon is entirely correct
Didn't mean to sound harsh. Probably just because english isn't my first language. Sorry for that. =]


All times are GMT -5. The time now is 12:10 PM.