LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 10-25-2014, 01:13 AM   #1
phucdv11
LQ Newbie
 
Registered: Oct 2014
Posts: 19

Rep: Reputation: Disabled
Help me!


Hi everyone.
I have installed NCTUns 5.0 on Fedora 10, but it's not success.
with the error i can't find on the internet.
would you help me to find down the problem.
i have enclose the picture about error.
Thank you so much!
Attached Thumbnails
Click image for larger version

Name:	NCTUns2.png
Views:	28
Size:	158.4 KB
ID:	16752  
 
Old 10-25-2014, 01:18 AM   #2
k3lt01
Senior Member
 
Registered: Feb 2011
Location: Australia
Distribution: Debian Wheezy, Jessie, Sid/Experimental, playing with LFS.
Posts: 2,900

Rep: Reputation: 637Reputation: 637Reputation: 637Reputation: 637Reputation: 637Reputation: 637
Fedora 10 is old, not supported, and way out of date. Fedora is now up to Fedora 20. Get Fedora 20, install it, then try to install a current version of NCTUns (which is version 6). If you still have trouble after using current versions come back and ask for help but with a more descriptive title.
 
Old 10-25-2014, 04:53 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,518

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641
← #2, @k3lt01 :
NCTUns-allinone-linux-2.6.27.7-f10.20090709 requires Fedora 10, 32bits.


Post #1, @phucdv11 :
$ cd /etc/yum.repos.d/
$ su
# mkdir backup
# mv * backup/
# gedit fedora10.repo
... and then copy / paste the below text to fedora10.repo, and save.
Code:
[fedora10]
name=Fedora10-i386 
baseurl=http://archives.fedoraproject.org/pub/archive/fedora/linux/releases/10/Everything/i386/os/
enabled=1
gpgcheck=1

[fedora10-updates]
name=Fedora10-updates-i386
baseurl=http://archives.fedoraproject.org/pub/archive/fedora/linux/updates/10/i386/
enabled=1
gpgcheck=1
... Then you can do # yum install <prerequisites>
EDIT : Looks like you got the wrong Fedora 10 ?
Must be F10-i686-Live.iso (or F10-i686-Live-KDE.iso)
http://archives.fedoraproject.org/pu.../10/Live/i686/


-

Last edited by knudfl; 10-25-2014 at 04:59 AM.
 
1 members found this post helpful.
Old 11-11-2014, 10:29 AM   #4
phucdv11
LQ Newbie
 
Registered: Oct 2014
Posts: 19

Original Poster
Rep: Reputation: Disabled
Problem

Hi there.
i have come back to install NCTUns after a long time i'm in busy with my thesis.
i still have a problem when install it.
so difficult for me.
can you please help me with a video how to install NCTUns 5.0 on fedora 10. i'm so appreciate that.or not, can you give me a step by step to install it.
Thanks for your help!
 
Old 11-11-2014, 11:56 AM   #5
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,518

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641
← #4 .

Please show the outputs from these two commands :
a) $ uname -m
b) $ cat /etc/redhat-release

And please read post #13 here very carefully :
http://www.linuxquestions.org/questi...4175523121/#13

Video : Sorry, I don't make video´s.
If you follow the linked post #13, etc. posts in that thread,
you can't fail. (Be aware that the thread is about Fedora 12.)
Actually the build of NCTUns isn't at all difficult.

-
 
Old 11-12-2014, 02:01 AM   #6
phucdv11
LQ Newbie
 
Registered: Oct 2014
Posts: 19

Original Poster
Rep: Reputation: Disabled
First error.

it's seem i'm missing some tool or library.
when i execute in a root
$ ./install.sh
error. Cannot find gcc or g++ compiler.
thanks for help!
 
Old 11-12-2014, 04:49 AM   #7
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,518

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641
← #6 .
Quote:
error. Cannot find gcc or g++ compiler.
REPEAT : Read http://www.linuxquestions.org/questi...4175523121/#13

And the above post #3 : Replace the files in /etc/yum.repos.d/.

Then you can do :
# yum install gcc-c++ tcsh autoconf automake libtool libXmu-devel \
xterm mkinitrd tcl-devel tk-devel ncurses-devel qt3

-
 
Old 11-12-2014, 02:16 PM   #8
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,628

Rep: Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652Reputation: 2652
Quote:
i still have a problem when install it.
so difficult for me.
can you please help me with a video how to install NCTUns 5.0 on fedora 10.
as all of the above
EVERYTHING on fedora10 is going to be VERY HARD

even for someone that has A LOT of fedora experience

trying to use a version of fedora that is 10 VERSIONS AND 5 YEARS!!!! out of date
and has not been updated in 5 YEARS
and has had the software repos deleted from almost all of the mirrors
you NEED to manually point yum to the VERY last updated repo
in the historical archive

see post #3

if you do not
then you will NEVER be able to install gcc ( and a old 5 year out of date version at that )
 
Old 11-12-2014, 03:43 PM   #9
k3lt01
Senior Member
 
Registered: Feb 2011
Location: Australia
Distribution: Debian Wheezy, Jessie, Sid/Experimental, playing with LFS.
Posts: 2,900

Rep: Reputation: 637Reputation: 637Reputation: 637Reputation: 637Reputation: 637Reputation: 637
Quote:
Originally Posted by John VV View Post
as all of the above
EVERYTHING on fedora10 is going to be VERY HARD

even for someone that has A LOT of fedora experience

trying to use a version of fedora that is 10 VERSIONS AND 5 YEARS!!!! out of date
and has not been updated in 5 YEARS
and has had the software repos deleted from almost all of the mirrors
you NEED to manually point yum to the VERY last updated repo
in the historical archive

see post #3

if you do not
then you will NEVER be able to install gcc ( and a old 5 year out of date version at that )
Which was the general gist of what I said in post #2. Trying to do this, while not impossible, for someone who doesn't know Fedora let alone such an old version just creates more problems than it is worth.
 
  


Reply

Tags
nctuns


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 11:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration