LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 04-03-2015, 08:33 PM   #1
elecomes
LQ Newbie
 
Registered: Apr 2015
Location: Melbourne
Posts: 8

Rep: Reputation: Disabled
HELP! ath9K AR9462, how to disable the 5GHz channel


Hi,

I am new to linux, but we have a project need to disable the 5GHz channel in the AR9462 due to the Approval issue.

We use "iw" to do the checking and found out the current EEPROM setting is 0x6c which enabled the 5GHz channel in passive and beacon scanning mode and caused the problem in the test lab for project~.
By the way, Is there anyone could help to advise how we could disable the 5GHz channel in the ath9k? we only need 2.4GHz only but chosen this dual band card for the project, so can't be changing.
Please help.

Thanks
Melvin
 
Old 04-04-2015, 01:55 AM   #2
dijetlo
Senior Member
 
Registered: Jan 2009
Location: RHELtopia....
Distribution: Solaris 11.2/Slackware/RHEL/
Posts: 1,491
Blog Entries: 2

Rep: Reputation: Disabled
You can hack the driver, create your own country and make the 5GHz channel a regulatory no-no.
Or you could find a country that's done such a thing and pretend you're there.
 
Old 04-06-2015, 09:49 PM   #3
elecomes
LQ Newbie
 
Registered: Apr 2015
Location: Melbourne
Posts: 8

Original Poster
Rep: Reputation: Disabled
Hi Dijetlo,

Thanks for your suggestion, I have tested it, it works after I set the command like "iw reg set KZ"

However, after I registered with our AP, the setting was changed and following our AP setting?
////////////////////////////////////////////
root@elecomes-550P5C-550P7C:~# iw reg get
country KZ:
(2402 - 2482 @ 40), (N/A, 20)
/////////////////////////////////////////////
/////// After connect to our AP //////////////
root@elecomes-550P5C-550P7C:~# iw reg get
country HK:
(2402 - 2482 @ 40), (N/A, 20)
(5170 - 5250 @ 40), (3, 17)
(5250 - 5330 @ 40), (3, 20), DFS
(5490 - 5710 @ 40), (3, 20), DFS
(5735 - 5835 @ 40), (3, 30)
////////////////////////////////////////////

I could see that we can see the 5GHz in our router but I couldn't connect it?
Anyway, it sounds like the setting it works, but the replied changed after AP connection caused a little bit issue for our internal team discussion.

Can you advise if it is a normal problem?

thanks

melvin
 
Old 04-07-2015, 11:01 PM   #4
dijetlo
Senior Member
 
Registered: Jan 2009
Location: RHELtopia....
Distribution: Solaris 11.2/Slackware/RHEL/
Posts: 1,491
Blog Entries: 2

Rep: Reputation: Disabled
I don't know you're use case so I can't really say if this would be a normal problem. I think you can probably trace down where it's throwing that complaint in the driver code and redirect it to the "driver complaint department" ( >>/dev/null) if you need to but the question your team is going to have to answer is does this invalidate the use case?
The best advice I can give you here is:
Nobody wants to reinvent the wheel, however ill considered shortcuts have a way of biting you in the rear end at some unspecified point down the line. Think the process through before deciding.
 
Old 04-10-2015, 07:14 PM   #5
elecomes
LQ Newbie
 
Registered: Apr 2015
Location: Melbourne
Posts: 8

Original Poster
Rep: Reputation: Disabled
Hi Dijetlo,

I have done couple of the testing, it sounds like it is a mechanism in the ath9k regulatory loading process, EEPROM >> USER setting >> Country IE request by router >>>

By the way, is there any other method to disable the 5GHz apart from using the country code???? I can see my router can select either 2.4GHz or 5GHz?
Do you know how to router manufacturer could manage it?

It will be helpful if someone can answer it.

thanks

melvin
 
Old 04-16-2015, 08:39 AM   #6
elecomes
LQ Newbie
 
Registered: Apr 2015
Location: Melbourne
Posts: 8

Original Poster
Rep: Reputation: Disabled
HI, I just find that the latest kernel 3.19 and 4.0 was updated the ath9k driver and claimed it can control and disable the 5GHz or 2.4GHz
http://lxr.free-electrons.com/source...h9k_platform.h

Is there anyone have more information? I have updated my kernel to 4.0 now, but I can't find there is any option for me to disable the 5GHz?
Is it hiding in somewhere? can anyone give us a suggestion?

thanks

Melvin
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't get Atheros AR9462 Bluetooth working, Nor Gobi2000 3G AND GPS omegaaf Linux - Hardware 2 05-30-2014 11:33 AM
Update to kernel 3.13 removed ability to set powersave on AR9462 (ath9k) TheCobra Linux - Laptop and Netbook 3 04-02-2014 10:26 AM
SSID not showing up on NetworkManager after changing wifi frequency channel to 5GHZ. Xchai Linux - Wireless Networking 2 01-11-2014 03:01 PM
Ath9k radio with different SSID and Channel configuration dkpradhan Linux - Wireless Networking 0 11-28-2013 10:44 AM
How to disable one of the TWO Fibre channel HBA adapter on redaht linux 5.3 server tarik007 Red Hat 2 02-11-2011 09:57 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration