Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 05-09-2008, 08:25 PM   #1
Registered: Sep 2005
Distribution: Ubuntu
Posts: 249

Rep: Reputation: 30
Guarddog not allowing incoming SSH

I am running Kubuntu Hardy 8.04 with Guarddog (version 2.6.0). I have been using Guarddog for years now and this is the first problem I have had like this.

After booting up, I cannot get Guarddog to allow incoming SSH connections until I restart the service, at which point it allows the connections.

I have tried everything, including remove ALL options except DNS and SSH for local and internet (with special ports defined for my SSH connection and in my /etc/ssh/sshd_config).

Like I said, if I restart the service using 'sudo invoke-rc.d guarddog restart' then I can connect. Help please.
Old 05-10-2008, 07:46 PM   #2
LQ Addict
Registered: Oct 2003
Location: Australia
Distribution: MX 16
Posts: 5,296

Rep: Reputation: Disabled
its been a long time since I used GD so more questions than answers

1) have you disabled your old firewall? and for all run levels?

2) how to you call GD? and assuming you are using runlevel 5 have you tried to rename your init.d service a higher number so all other services are up for GD to see?

ie run GD a bit like calling it from rc.local rather than from init.d

see if that makes a diff?
Old 05-10-2008, 07:52 PM   #3
LQ Addict
Registered: Oct 2003
Location: Australia
Distribution: MX 16
Posts: 5,296

Rep: Reputation: Disabled
cheating I look at my Mdv /etc/rc5.d/

iptables is S03

network is S10

network up is S50

shorewall (firewall) is S51

Yep do not use sshd and its disabled ( I am a rootkit hunter devotee)

but ssh would have a number lower than S51


guarddog, incoming, ssh

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Guarddog is not allowing my GMail A/c anindyanuri Debian 7 12-28-2008 02:37 PM
Not allowing incoming ftp through firewall. crackerB Linux - Networking 6 08-07-2006 02:51 AM
cannot Allowing Incoming X Connections with xhost + libin88 Linux - Enterprise 1 11-09-2005 04:25 PM
Fedora Linux allowing incoming SSH hwm Linux - Networking 5 09-06-2004 03:50 PM
Allowing for incoming ssh InsaneBob Linux - Software 11 04-12-2003 02:44 PM > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 09:30 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration