-   Linux - Networking (
-   -   Getting message "connect: Network is unreachable" trying to access the Internet (

denver1980 12-28-2004 04:11 PM

Getting message "connect: Network is unreachable" trying to access the Internet
Hi, here's the problem.
I moved my computers around for dusting purpose. Before moving, everything was working fine. I use my main computer (Windows XP) to play games and SSH on my Linux box (Red Hat 8).
My Linux has apache, proftp, etc.
My computers are linked together with a router which is cable connected to my modem.

What works :
- Windows can access my Linux's web pages.
- Windows can access router's administration web page.
- Windows can access the web.
- Linux box can access it's own web pages via LAN address.
- Linux can ssh connect to Windows XP CygWin.
- Linux can access router's administration web page.

What doesn't work :
- Linux Box CAN'T access the web ... except for one thing, i can retrieve address from traceroute :
root:~ $ traceroute
traceroute: Warning: has multiple addresses; using
socket: Network is unreachable

I looked at my /etc/resolv.conf and the address of my router is correctly set as default gateway :
root:~ $ less /etc/resolv.conf
; generated by /sbin/dhclient-script

I tried to run the script to rebuilt this file but i had to use another one :
root:~ $ /sbin/dhclient-script
/sbin/dhclient-script: configuration for not found.
root:~ $ /sbin/dhclient eth0
Internet Software Consortium DHCP Client V3.0pl1
Copyright 1995-2001 Internet Software Consortium.
All rights reserved.

Listening on LPF/eth0/00:05:5d:07:f7:46
Sending on LPF/eth0/00:05:5d:07:f7:46
Sending on Socket/fallback
DHCPREQUEST on eth0 to port 67
/sbin/dhclient-script: line 190: route: command not found
bound to -- renewal in 269356 seconds.

I tried to look at that file but I get the following message :
root:~ $ ls -al /sbin/route
ls: /sbin/route: Input/output error

Can anyone give me a hint ?

musicman_ace 12-28-2004 04:19 PM

Flush DNS? maybe bad data?

denver1980 12-28-2004 04:24 PM

Hmmmm, the only way I know to get my routing table is to route -n ... but I get the following :
root:~ $ /sbin/route -n
-bash: /sbin/route: Input/output error

denver1980 12-28-2004 10:11 PM

Now I'm totally lost ... the file re-appered :
root:~ $ ls -la /sbin/route
srw-rw-rw- 1 root root 0 dec 28 18:31 /sbin/route

But that is supposed to be an executable binary ... no ? :confused:

denver1980 12-29-2004 05:11 PM

Ok ... giving up... guess I'll take the opportunity to move to Feudora C1 or Slackware ...

I didn't lose or win , I got an opportunity.
Ce n'est pas une perte ou un gain, c'est une opportunitée.

Satriani 12-29-2004 05:22 PM

This message is a typical message that either the default gateway cannot be found, or maybe your router doesn;t allow you linux box to access the outside world.....
What do you get when you do an ifconfig ???

All times are GMT -5. The time now is 03:53 AM.