LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 04-19-2004, 08:31 PM   #1
schurt
Member
 
Registered: Nov 2003
Location: raleigh, nc
Distribution: fedora, arch
Posts: 78

Rep: Reputation: 15
getting home directories to automount with NIS


when i su testuzr for the nis username, the home directory associated with testuzr on the server doesn't get mounted to the machine, what steps do i need to take so that when i login to the NIS my associated home directory gets mounted properly?
 
Old 04-23-2004, 11:10 AM   #2
discostu
LQ Newbie
 
Registered: Feb 2003
Location: Los Angeles, CA
Distribution: RH 8.0
Posts: 17

Rep: Reputation: 0
Me Too, but here's some info

schurt,

Not sure what distro you are using, but I am using Redhat WS 2.1 and trying to get NIS+ working, the user can log in okay, but the /home directory is not getting automatically mounted.

1.) Make sure you do not have "medium" or "high" security firewall enabled; faster to re-install OS than undo firewall settings

2.) If using RedHat, or for some possible tips to your distro, check out:

http://www.redhat.com/mirrors/LDP/HO...WTO/index.html

3.) You have to install pam_unix2.so libraries, which are open source and included in the above document, then you have to make changes to your /etc/pam.d/login to reflect those libraries.

4.) I believe the next step involves editing /etc/auto.master, however, this is where I am stuck.

Anyway, I hope this helps you and I hope someone might be able to point me in the right direction.

-discostu
 
Old 04-23-2004, 12:34 PM   #3
discostu
LQ Newbie
 
Registered: Feb 2003
Location: Los Angeles, CA
Distribution: RH 8.0
Posts: 17

Rep: Reputation: 0
got it

schurt,

found the solution to my problem.

1.) stop "autofs" with /etc/init.d/autofs stop

2.) use "automount /home nisplus auto_home"

FWIW, here are the contents of my /etc/auto.master file (although I am not certain this matters):

/home auto_home.org_dir

The "autofs status" prodcues the following output:

[root@hostname init.d]# ./autofs status
Configured Mount Points:
------------------------
/usr/sbin/automount /home yp auto.home.org_dir

Active Mount Points:
--------------------

Hope this helps you or someone else!

--discostu
 
Old 04-23-2004, 01:55 PM   #4
schurt
Member
 
Registered: Nov 2003
Location: raleigh, nc
Distribution: fedora, arch
Posts: 78

Original Poster
Rep: Reputation: 15
thanks ill try your options this weekend and let you know what i come up with, only difference is im using NIS and not NIS+ and my workstation is gentoo and for some reason it keeps overwriting my my NIS server config and putting the domain nc.rr.com broadcast, rather than keeping domain flea(nisserver) broadcast, still haven't resolved that issue but the your suggestion with using automount ill check that out

thanks again
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
automount home directories with information from Active Directory (or NIS) alex r Linux - Software 5 08-30-2006 11:05 AM
NIS and home directories (Suse 10) linuxmfx Linux - Networking 3 10-19-2005 11:28 AM
Automount home directories??? BeauSanders Linux - Networking 2 09-15-2005 05:16 PM
automount home directories alex r Linux - Software 2 02-24-2005 11:02 PM
automount Solaris home directories onto RedHat ghouliajoolia Linux - General 3 09-07-2004 07:20 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 05:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration