LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Gentoo - Strange Problem with Network... (https://www.linuxquestions.org/questions/linux-networking-3/gentoo-strange-problem-with-network-128196/)

tr4nce 12-22-2003 05:25 PM

Gentoo - Strange Problem with Network...
 
Hello, im new in gentoo world, and I decided to install it, downloaded 1.4LiveCds... well i made up a Stage3 + GRP install, used Gentoo-Sources, everything works fine but...

here is my deal, I used dhcp for networing, because the server is WindowsMe, so i set up my eth0

Code:

# dchpdc eth0
But the problem is when i try to use lynx or something to see a webpage, my system stops for a while, until the page finish downloading... I can't even use Mozilla, because my system get so Slow i can't even move the mouse!!! it's like when eth0 starts to send information or get it, system stops or get extremly slow.

Can you help me? I tried Searching but no lucky =( Thx for All.

chort 12-22-2003 05:39 PM

Are you using a Realtek-based card by any chance? i.e. is the driver rl8139?

tr4nce 12-22-2003 05:44 PM

Yes, a ethernet 10/100MB chipbased Realtek8139

:cry:

chort 12-22-2003 08:10 PM

Yep, that sounds right. I'll bet you have a realatively low-end CPU. Those Realtek cards off-load a bunch of their operations to the CPU, so if you don't have a fast CPU, it will really slow down your whole system when you have a lot of traffic.

Intel makes much better cards, and you can get them almost as cheaply if you buy on-line. Check www.pricewatch.com and search for 82559, 82557, or 82555 (although you should find 82559s cheap enough). If that's not satisfactory for whatever reason, the 3COM PCI cards are generally quite good, and I've heard (although not verified) that Linksys cards are quite decent.

In fact, you can go right here and get an 82559 for $13. It even has WOL and netbooting!

tr4nce 12-22-2003 09:43 PM

thanks for the help

I been using Linux for a couple of years in the same computer, and i never got such a problem with ethernet cards, until yesterday Slackware9.1 and my realtek where so lovely :( snif snif I don't get it why now it's working so badly. Reading gentoo forums, find out that maybe its a bug in gentoo-sources, and maybe you should try using vanilla-sources (www.kernel.org source with no mod). Anybody fixed up?

chort 12-22-2003 11:48 PM

Well yes, if it worked fine with other Linux kernels, then chances are it's a bug with Gentoo.


All times are GMT -5. The time now is 08:36 PM.