LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Networking (http://www.linuxquestions.org/questions/forumdisplay.php?f=3)
-   -   Gentoo Linux install: links won't connect. (http://www.linuxquestions.org/questions/showthread.php?t=4175448404)

Rick Calvin 02-02-2013 07:52 PM

Gentoo Linux install: links won't connect.
 
My ISP is blocking port 80 so I get the server not found message. Is there a way to change the port usage?

Emerson 02-02-2013 08:23 PM

Your ISP is blocking incoming connections. Should not prevent you from installing Gentoo or making connections to remote servers. Please describe your problem in more detail.

Rick Calvin 02-03-2013 04:48 AM

Gentoo Linux install:
 
I have an iphone, nook, and a windows PC that surf without issue. My minimal install of Gentoo 20130110 fails at links http://www.gentoo.org/main/en/mirrors.xml with a host not found message. I can actively ping www.goggle.com and www.gentoo.org, as written, no problem. Switched to LivdDVD 20121221 and start Konquerer. Every web site I try, same problem - Unknown host and additional information contains host not found.
Switched to Fedora 18 and start Konquerer. Same problem - Unknown host and additional information contains host not found. I can take the PC to work and connect to the network there (different ISP) and everything works fine. I contacted my ISP and was told that Konquerer uses HTTP (didn't think that odd) and that they were blocking port 80 (along with several other ports). I am going to start developing embedded control systems with Gentoo at work and I need to have it at home as well (I really like the Portage concept). Thanks in advance for any insight you can provide.

Emerson 02-03-2013 05:49 AM

What is it, wired or wireless? Is it a DSL connection at home? If yes, what MTU are you using?

Rick Calvin 02-03-2013 06:07 AM

Gentoo Linux install: links won't connect.
 
It is cox cable to a wireless cable gateway (Linksys WCG200). The windows PC and linux PC are wired ethernet to the gateway. The windows PC is normally wireless but to access the configuration menus via http, I have it wired. I also brought home a Gentoo Linux laptop from work and it has the same problem (also wired direct).

Emerson 02-03-2013 06:43 AM

A quick Google revealed Linksys WCG200 has broken firmware which may not work properly when it's internal firewall is enabled.

Rick Calvin 02-03-2013 07:10 AM

Gentoo Linux install: links won't connect
 
I saw that, but the posts seemed to indicate that the problem was with hardware version 1 (I have 2) and with the other devices all working fine (which still doesn't mean it's not a firmware issue) I gave it a low probability. I turned off the firewall and conducted the Fedora Konquerer test again with the same result. I also made sure I could ping (by address) the WAN IP (70.178.6.146) the Gateway (70.178.6.1) and the DNS servers (first one is 68.105.28.11). All responded. I am going to get a new cable modem right now. I will post again when I have it installed and tested. This is driving me (and I'm sure you) nuts!

Rick Calvin 02-03-2013 11:55 AM

Gentoo Linux install: links won't connect.
 
The new cable modem is installed. Problem solved!! Thank you Emerson for your time and effort! If you are ever in Northwest Arkansas I have a cold one ready for you.


All times are GMT -5. The time now is 10:49 PM.