-   Linux - Networking (
-   -   ftp not returning from STOR <file> (

keefobeefo 06-03-2009 10:39 AM

ftp not returning from STOR <file>
Hi All,

I've tried searching on this but to no avail so far. Maybe you good people can help?

I'm running a file transfer using the shell client from Linux (RHEL4) to some external box running *nix but not sure of the o/s details. Similarly I don't know what the FTP server software is at t'other end...

However, everything works fine until I try shipping a file of between 10 and 11 Mb, when it hangs on the STOR command having sent the whole file (checked the file size at both ends are the same). It seems to work fine for smaller files (a few Kb). I'm using .netrc to log in.

This behaves the same regardless of whether I run it interactively or via a script.

See debug output below:

/home/oracle/scripts/export> ftp -d
ftp> open
Connected to
220 Matrix WSA FTP
500 'AUTH': command not understood.
500 'AUTH': command not understood.
KERBEROS_V4 rejected as an authentication type
---> USER xxxx_upload
331 Password required for xxxx_upload.
230 User xxxx_upload logged in.
---> SYST
215 UNIX Type: L8 Internet Component Suite
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> put extract20090603.txt
local: extract20090603.txt remote: extract20090603.txt
---> TYPE I
200 Type set to I.
ftp: setsockopt (ignored): Permission denied
---> PASV
227 Entering Passive Mode (77,68,53,120,19,66).
---> STOR extract20090603.txt
150 Opening data connection for extract20090603.txt.

The 150 is the last line output - and it hangs like this (after the file has been completely copied) for over an hour (then I get bored and kill it).

Has anyone seen anything like this before and if so discovered why? Any help will be much appreciated.

Many thanks in anticipation.


grepmasterd 06-03-2009 04:24 PM

did you try using active mode (toggle 'passive')?

keefobeefo 06-04-2009 02:36 AM

Hi grepmasterd,

We can't use active as the server is outside our firewall. Thanks for the suggestion, tho'.


All times are GMT -5. The time now is 06:14 PM.