-   Linux - Networking (
-   -   ftp connection refused (vsftpd on RedHat 9.0) (

rajibshovan 01-03-2007 01:09 AM

ftp connection refused (vsftpd on RedHat 9.0)
Can't restart the vsftpd process...

when "service vsftpd status" command is entered, the following msg is shown...

vsftpd dead but subsys locked

So when try to "ftp localhost", connection refused....

what can I do now??? :confused:

plz help....

IBall 01-03-2007 03:53 AM

Is there any reason why you are using Redhat 9? This is very old and unsupported now (Redhat stopped supporting it in 2004).

I suggest that you get a more recent version of Linux, such as Fedora Core 6 (successor to Redhat 9).


rhoekstra 01-03-2007 04:32 AM

And to help you out on this one, you can try 'service vsftpd start' and if that doesn't work preceed it with a 'service vsftpd stop' to clean the lock.

See if that helps..

rajibshovan 01-04-2007 05:19 AM

Thanx...I've tried to stop the service...but the subsys is still locked....

rhoekstra 01-04-2007 07:15 AM

I tried to reproduce the problem by starting with 'service vsftpd start', followed by 'kill -9 <pid_of_vsftpd>'.

'service vsftpd status' tells me that it's dead but still locked. A simple 'service vsftpd start' remedies the issue.

Try to just start vsftpd 'service vsftpd start' and check with 'service vsftpd status' it should say that it is running again.

If not, check your logs for error messages. Perhaps a faulty config causes vsftp to die unexpectedly?

rajibshovan 01-05-2007 03:07 AM

Dear rhoekstra

When I restart the service, it says [0k]

when stop the service, it says [FAILED]

But there is no running pid for vsftpd...then what to kill!!!
Then I tried few things also:
0)view the log files,,,but nothing found
1) removed vsftpd lock file from /var/lock/subsys
2)remove xinetd lock file
3)reboot the server..
4)again tried to start/stop the service....

and I think that the vsftpd.conf is in default configuration now..

but no help....the problem is really annoying...
thanx for ur help....any more??? plz

rhoekstra 01-05-2007 04:45 AM

When you do 'service vsftpd start'
what does 'ps -ef|grep vsftp' say ?

Do you have vsftp also configured through xinet? try not to do so... for example, for testing, disable xinetd, start vsftpd and try the ps command. Is it running?

BTW.. did it work before? and what has been changed since?

rajibshovan 01-06-2007 10:21 AM

'ps -ef|grep vsftp' says its runnig process Info like:

root 2276 2174 0 21:12 tty1 grep vsftp

No i didn't configure vsftpd through xinet..

Yeh It worked before....I was editing the vsftpd.conf file..but no big deals i think..

When the pc shutdown, then It also show the message that

service vsftpd stop [FAILED]

I think...there's no way but reinstall the u think so??


All times are GMT -5. The time now is 09:30 PM.