-   Linux - Networking (
-   -   Frustrating (

PlanetNEO 12-08-2002 01:17 PM

Still trying to get a linux box on my home network. I tried Mandrake 9, but it wouldn't detect my network card (Netgear FA310TX). So I tried RedHat 8.0 with the same result, even though I checked the hardware compatibility list on RedHat and it specifically lists my card. Didn't detect it and didn't list it as an option on the hardware installation list.

These days getting a PC connected to a network is a pretty basic process. And since most of you have them on networks, there has to be something I'm missing. Both distros are really nice, both detected my video card and monitor, but it's a paper weight if I can't get it on the network. Is there a really basic howto somewhere? Maybe an overview of the process. Network connections for linux dummies? All the howtos I've been able to find are way out of date.

TheCoffeeMug 12-08-2002 01:25 PM

Maybe we could solve the problem here.

Try to run this in a console as root:


and tell us what you get.

sudo 12-08-2002 01:30 PM

what nic do u have??

PlanetNEO 12-08-2002 01:54 PM

NIC is a Netgear FA310TX

I logged in as root, ran ifconfig from /sbin and got the following:

LINK encap: Local Loopback
inet addr: mask:
RX packets:150 errors:0 dropped:0 overruns:0 frames:0
TX packets:150 erros:0 dropped:0 overruns:0 frames:0
collisions:0 txqueulen:0
RX bytes:9940 (9.7 Kb) TX bytes: 9940 (9.7 Kb)

Hey, I'm just proud of being able to find my way into a root console. lol.

sudo 12-08-2002 01:58 PM

ok... try to ping
if that works..
what does the file /etc/sysconfig/network-scripts/ifcfg-eth0 say??

TheCoffeeMug 12-08-2002 02:05 PM

Try as root to write:

insmod tulip

And then:


To see if it worked.

PlanetNEO 12-08-2002 02:12 PM

Ping was successful. Funny it just keeps running, lol.

I found the directory, but there is no ifcfg-eth0. There's a ifcfg-lo, but no config file for eth0, if I'm phrasing that right.

PlanetNEO 12-08-2002 02:15 PM

Okay, after ismod tulip it gives me a long directory name at the end it says something about tulip/tulip.o and then another line about int_module: no such device and then something about how module errors are caused. Do you need the exact wording? It's a bit lengthy.

TheCoffeeMug 12-08-2002 02:30 PM

On it says that your network cars should work perfectly.
I would be nice to see the output from insmod. If you think that it is too long for this forum then mail it to me.

PlanetNEO 12-08-2002 02:36 PM

Not too long. It'll take me a few minutes, I have to keep turning my monitor switch back and forth.

PlanetNEO 12-08-2002 02:41 PM

[root@localhost root]# insmod tulip

Using lib/modules/2.4.18-14/kernel/drivers/net/tulip/tulip.o
/lib/modules/2.4.18-14/kernel/drivers/net/tulip/tulip.o init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters
You may find more information in syslog or the output from dmesg

TheCoffeeMug 12-08-2002 02:48 PM


cat /etc/modules.conf

And tell us what you get. If there is nothing about eth0 then add the line.

alias eth0 tulip

And try to use insmod once more.

How do you obtain a IP address? Static or dynamic?

PlanetNEO 12-08-2002 02:52 PM

Now this is really do you add a line? eth0 isn't there. It's dynamic NAT IP's from a linksys router/hub.

PlanetNEO 12-08-2002 03:02 PM

Ah, good old vi is still there. Okay, added

alias eth0 tulip

Tried insmod once more but got the same result as before.

TheCoffeeMug 12-08-2002 03:03 PM

Make a copy of the file first:

cd /etc
cp modules.conf modules.conf.bak

Now edit it in the console with "pico -w modules.conf" or in XWindow with "xedit modules.conf". You can also edit it with another text editor (clear text, not with a word processor like StarOffice, KWord, or what ever they are called)

All times are GMT -5. The time now is 05:59 PM.