LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Flat line in MRTG graph (https://www.linuxquestions.org/questions/linux-networking-3/flat-line-in-mrtg-graph-191114/)

orko 06-08-2004 10:32 AM

Flat line in MRTG graph
 
hi all,

i've a MRTG server in RedHat Linux 8.0 which shows bandwidth consumption of my clients. the problem is , the MRTG graph shows a straight line fixed bandwidth consumption of client PC when the client PC remains off.

have a look to the follwing graph:

Straight Line Graph

From 20:00 pm to 11:00 am , the client PC was shutdown. but in graph it is showing that the client is consuming 20+ kbits/s for that time instead of 0 kbits/s. i think at the time of shuting down the bandwidth consumption of the client pc was 20+ kbits/sec.

i used --ifref=ip statement to the cfgmaker command. and the kernel didn't give any kind of error message when i used cfgmaker command and indexmaker command.

can i fix it by editing any file or i've to make cfg file again ??

thanx in advance

Astro 06-08-2004 01:35 PM

I think I had this problem once or twice, I don't remember what I did though to remedy it. I do however remember that when I removed the log file for that host and removed the graphs it never did it again. http://www.tyrantanic.net/mrtg/

ppuru 06-08-2004 10:52 PM

2 possibilities

1. You are shutting off the mrtg script for some duration.
2. MRTG is not getting an SNMP response each time it sends a query

MRTG reads the last entry in its log and continues to write that on to its graph.

orko 06-09-2004 12:12 AM

i've noticed that the straight line begins after shutting down the client PC.

i've deleted cfg file and all related files frm /var/www/html/mrtg and run cfgmaker and inexmaker again. but the result is same.

-----------------

ppuru 06-09-2004 12:19 AM

If you want to start with a clean slate, you will need to delete the mrtg logs.

Check for the entry WorkDir: <home directory>

The log files are in this directory.

orko 06-09-2004 01:31 PM

yah sir,
i've deleted all files including log files.

wateve , i got the solution myself by using the option "unknaszero"

i got it from the following link. i think it will be a good refernce for futer:

http://people.ee.ethz.ch/~oetiker/we...reference.html

another question : can i show the maximum traffic within each 5 minutes instead of 5 minutes average traffic ?

ppuru 06-09-2004 10:40 PM

you will need to make that change in the cron files...in /etc/cron.d/mrtg

and thank you for the unkaszero parameter ... my trying to help you has helped me too :D


All times are GMT -5. The time now is 11:17 AM.