LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 12-21-2017, 01:48 PM   #1
venkibellu
LQ Newbie
 
Registered: Jun 2016
Posts: 18

Rep: Reputation: Disabled
Firefox latest version unable to connect to internet


I am using Fedora 27 in Virtual Box. I just upgraded Firefox to latest version using "dnf install firefox". But after the update the firefox gave "Certificate error" to all the major websites like google, facebook, youtube etc. I tried "ping www.google.co.in" and it just worked fine. So I downgraded Firefox and things started to work fine again. Is there something wrong with latest Firefox Release? Or is there a glitch in my system?
 
Old 12-21-2017, 02:47 PM   #2
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, and whatever VMs I happen to be playing with
Posts: 13,113
Blog Entries: 18

Rep: Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448
I'm using Firefox v. 57.0.2 (64-bit) on Slackware with no issues. I also have v, 57.0.1 in a VirtualBox VM of Ubuntu 16.04 LTS which works just fine.

Try starting Firefox from the command line. Perhaps it will through a useful error message. Also, a web search for the specific error message you are receiving may help. A general search for "Firefox certificate error" yielded too much variety to be useful.
 
Old 12-21-2017, 05:38 PM   #3
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 16,227

Rep: Reputation: 2304Reputation: 2304Reputation: 2304Reputation: 2304Reputation: 2304Reputation: 2304Reputation: 2304Reputation: 2304Reputation: 2304Reputation: 2304Reputation: 2304
F/F 57.0.1 runs fine in F27 here. Can't remember when it was originally installed, been upgraded so often.
 
Old 12-21-2017, 05:52 PM   #4
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,398
Blog Entries: 3

Rep: Reputation: 403Reputation: 403Reputation: 403Reputation: 403Reputation: 403
test this involves browsing to about:config and setting browser.tabs.remote.autostart2 to false.
 
Old 12-21-2017, 10:32 PM   #5
venkibellu
LQ Newbie
 
Registered: Jun 2016
Posts: 18

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by frankbell View Post
I'm using Firefox v. 57.0.2 (64-bit) on Slackware with no issues. I also have v, 57.0.1 in a VirtualBox VM of Ubuntu 16.04 LTS which works just fine.

Try starting Firefox from the command line. Perhaps it will through a useful error message. Also, a web search for the specific error message you are receiving may help. A general search for "Firefox certificate error" yielded too much variety to be useful.
Actual error was something like this, "Google is using outdated certificates. Your connection may not be secure". Same type of error for facebook, youtube etc. I even checked my system timings and it was upto date. Some websites like "www.pdfdrive.net" which doesnt have https encryption was working just fine. Problem was I think only with https websites.
 
  


Reply

Tags
certificates, fedora, firefox


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] how to update to latest firefox version on slackware 14.1 contozo Linux - Newbie 3 08-12-2016 09:01 PM
Firefox latest version from current staus Slackware 13 03-30-2016 10:36 AM
How to upgrade Firefox, but not to latest version? laredotornado Linux - General 5 09-16-2011 09:12 PM
latest version of firefox jone kim Linux - General 2 04-22-2010 01:54 PM
unable to install latest gcc version sapadman Linux - Newbie 1 07-20-2004 06:22 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 01:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration