LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 06-29-2013, 11:23 AM   #31
lleb
Senior Member
 
Registered: Dec 2005
Location: Florida
Distribution: CentOS/Fedora
Posts: 2,285

Rep: Reputation: 394Reputation: 394Reputation: 394Reputation: 394

copy/paste the exports and the directory permissions you are trying to share.
 
Old 06-29-2013, 02:23 PM   #32
mspear20
LQ Newbie
 
Registered: Apr 2013
Posts: 20

Original Poster
Rep: Reputation: Disabled
Alright here it goes.
Just to give a bit more on my setup.
I have 2 RPi's, and a laptop which is running debian as suggested.
The laptop has an IP address of 192.168.1.1/24 - One Pi has 192.168.1.2/24 - Second Pi has 192.168.1.3/24...All three are running into a switch.

My exports file on the laptop looks like:
Code:
/srv/nfs/motion_back *(rw,sync,no_root_squash,no_subtree_check)
/srv/nfs/motion_counter *(rw,sync,no_root_squash,no_subtree_check)
From my previous post, I changed location of the folders.

Permissions on the /srv/nfs:
Code:
drwxrwxrwx 2 nobody nogroup 4096 Jun 29 14:12 motion_back
drwxrwxrwx 2 nobody nogroup 4096 Jun 29 11:18 motion_counter
The fstab file on both Pi's with the path changed to their respective directories:
Code:
192.168.1.1:/srv/nfs/motion_counter /etc/motion/motion nfs auto,noatime,nolock,bg,nfsvers=3,intr,tcp,actimeo=1800 0 0
Now heres the interesting part. I have one of the Pi's working the way it should (/srv/nfs/motion_back). In order to do that I had to edit the /etc/rc.local file to have it start the service "rpcbind" start on boot. I have made that change on both Pi's
Since the other Pi is not working, when I go to mount it manually with the command:
Code:
mount -t nfs 192.168.1.1:/srv/nfs/motion_counter /etc/motion/motion
Thats when I get the error message:
Code:
mount.nfs: access denied by server while mounting 192.168.1.1:/srv/nfs/motion_counter
I should also mention I have edited the /etc/hosts.allow file with the following code:
Code:
portmap: 192.168.1.2
portmap: 192.168.1.3
Now, please have at it, and let me know what you all think.

Thank you!
Mike
 
Old 06-30-2013, 04:21 PM   #33
mspear20
LQ Newbie
 
Registered: Apr 2013
Posts: 20

Original Poster
Rep: Reputation: Disabled
Hey guys,

Good news I got it working. Went back and looked at everything, found that it was the smallest spelling mistake.

One last question hopefully. How cant I make nfs not time out? I just want it to be connected all the time?

Thanks,
Mike

---------- Post added 06-30-13 at 05:21 PM ----------

Hey guys,

Good news I got it working. Went back and looked at everything, found that it was the smallest spelling mistake.

One last question hopefully. How cant I make nfs not time out? I just want it to be connected all the time?

Thanks,
Mike
 
Old 07-01-2013, 10:38 AM   #34
lleb
Senior Member
 
Registered: Dec 2005
Location: Florida
Distribution: CentOS/Fedora
Posts: 2,285

Rep: Reputation: 394Reputation: 394Reputation: 394Reputation: 394
nfs by default has no "time out" that i am aware of. that would/could be a networking issue.

also as i mentioned earlier it could depend on how you are mounting the NFS share. are you using autofs, fstab, or some other means to mounting the share?

autofs will handle network disconnects much more cleanly if you put in both a timeout, bg, and a ghost option. i think i posted those earlier.

fstab will mount, but may the gods help you if you have a network hickup and loose connection with the NFS server. you system very well could hang and become unresponsive as it tries to connect to something that is no longer there. remember as far as the local system is concerned the NFS share is a local resource and as such the system will continue to attempt to access the data for ever.

the use of autofs, or its newer replacement sorry forget what its called off of the top of my head, will handle those types of issues much better.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Arch Linux on Raspberry Pi Running XFCE LXer Syndicated Linux News 0 01-15-2013 10:30 AM
Running startup script fails because network share isn't ready (Perforce on Debian) tstein Linux - Software 1 05-21-2012 06:57 PM
Bash script for listing FTP usage as the file name of a file created in each share jojothedogboy Programming 1 12-05-2008 03:35 PM
script to upload backup file to smb share c_mitulescu Linux - Networking 1 03-15-2007 11:34 AM
Running a script file johnlb Linux - Newbie 2 02-19-2003 02:17 AM


All times are GMT -5. The time now is 12:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration