-   Linux - Networking (
-   -   fedora core 8 no internet!!!!! (

sam103329 02-22-2008 07:39 AM

fedora core 8 no internet!!!!!
i have recently been looking through versions of linux and i decided on fedora core 8, i have used ubuntu ,kubuntu ,gentoo,and some other linux software before. and normally on install the internet works instantly due to me been hooked up to a router over enthernet. i have the new sky router. however in fedora on eth0 it does not work cannot find ip over dhcp i get the same when i swap the ports now i have tried typing the static ip and network mask which which kinda works the computer sees the connection and sas connected however still no accsess to the internet

i really need some help onfiguring my fedora internet ive tried all i can think they just dont want to talk evan when i type in static adresses. my internet works on all other versions of linux straight away and definatly works on xp on my other partition..

can anyone help i would really appreciate it????

im using the onboard lan on a asus striker extrme
thanks for anything you can contribute

b0uncer 02-22-2008 07:51 AM

If you're connected to a router trough the usual ethernet cabling (RJ-45...), then it shouldn't be a problem. Do you know the device it uses to connect? It's probably eth0 (especially if you only have one ethernet card), but make sure. After you know that, simply issuing (as root)

dhclient eth0
or if you have dhcpcd instead of dhclient as your DHCP client,

dhcpcd eth0
and a short moment's wait should send DHCP requests and get the answers (provided that there is a DHCP server at the other end of the cable, which there is if your other operating systems work via dhcp). Try both dhcpcd and dhclient if you have them, or then the one you have.

It really is that simple - provided that the device works. If dhcp doesn't work, and neither does static address configuration, probably there's something wrong with the device (i.e. between the device and your operating system).


ifconfigh eth0 down  #brings interface down
ifconfig eth0 up  #brings interface up
dhcpcd  #(or dhclient) configure the device via DHCP

sam103329 02-23-2008 09:04 AM

im not sure
i dont quite understand what you want me to do with it my pc still isnt working and is not connecting automatically but i still have no internet accsess i havent done what you said above because i dont know exactly what your telling me to do im new to the more complex side of linux

if you could explain it to me i would really appreciate it

thanks for all the help hope to get a reply soon


jdavis2 02-23-2008 10:38 AM

What b0uncer is telling you is to try to type either dhclient eth0 or dhcpcd eth0 at the command line and one of them should help you get an ip address from your router. Then you can check to see if you got one by typing ifconfig eth0 at the command line.

If it does not then you may have a defective network device. You also might need to check to see if you have a firewall enabled that is blocking network communicaton.

sam103329 02-23-2008 10:40 AM

do you mean the terminal when u say command line becauase i tried doing it in the terminal and it said unknown command

jdavis2 02-23-2008 10:56 AM

Yes I did mean terminal. It should work.

pentode 02-23-2008 12:16 PM

You have to do it as root user.

All times are GMT -5. The time now is 06:40 AM.