-   Linux - Networking (
-   -   fedora core 6 KDE network wizard under administration (

landonmkelsey 11-21-2006 01:31 AM

fedora core 6 KDE network wizard under administration
You will not believe this...screenshots available.

I brought up the KDE administration network configuration dialog and entered primary and secondary DNS IP addresses. I have DSL and it uses DHCP.

After rebooting, the contents of the dialog are back to where they started before I enetered the primary and scondary DNS IP addresses.

I made a screensnapshot of the problem and I could not believe what happened (nor will you).

The screensnapshot I made appears when I select the "devices" tab.

Micro420 11-22-2006 01:31 AM

I had this problem at work and it took me awhile to figure it out. What happened was that one of my computers was set to obtain IP automatically through the DHCP server, and within that DHCP I could configure the DNS servers. So no matter how many times I told Ubuntu what the DNS should be, it kept pulling the IP from the DHCP server, which then kept assigning it its own DNS server. I finally went into the DHCP server and changed the DNS server to what I wanted. That fixed my problem.

So in a nutshell, I believe you. Your DSL is pushing out the IP address AND the DNS, which Fedora Core 6 is picking up. No matter how many times you change the DNS, Fedora Core 6 will always use the DNS assigned by the DHCP server (your DSL provider) for as long as you are obtaining the IP address from it. Set your FC6 to a static IP or get a router or something.

landonmkelsey 11-22-2006 10:42 AM

yeah but can you imagine what happened
I took a screenshot of the dialog in the device state

and the snapshot got stuck in the device tab display?


This dialog was prob just thrown out so something would be there.

Thereis no dialog to set the network mask


jwcourt 12-02-2006 12:31 AM

This is how I resolved it under Gnome

Hit this problem myself today but was under Gnome not KDE.
However I suspect the mechanisms are similar as I was trying
to fix it using System->Administration->Network Configuration.

The short story seems to be that you can stop it from getting
the DNS as well as IP address for the interface from DHCP.
The steps to ensure this seem to be :

1) Double click the eth device under the "Devices" tab.
This should bring up the "Ethernet Device" dialog.
2) Under the "Automatically Obtain IP address settings with DHCP"
section in this dialog, make sure the "Automatically obtain
DNS information from provider" tick box is OFF.
3) Save the changes and restart the network with
"service network restart"
4) Get back into the Network Configuration UI and go to
the "DNS" tab and enter your primary and secondary.
5) Save the changes and restart the network again with
"service network restart"

The primary and secondary should be set now and stick on

Now I did try changing both the device and dns setting in
one go but that didn't do it for me and I suspect it has to
do with the order things are done on the restart of the
network (I haven't time yet to track down the shell scripts

For those that are interested I suspect the culprit line
that needs to be present in the /etc/sysconfig/network-scripts/
ifcfg-ethX file is "PEERDNS=no" and that is what gets added
when you remove the Device tick box setting.

Hope this helps someone


John Court

landonmkelsey 12-02-2006 12:57 PM

now hear is what we need
positive friendly help

thanks for the info...trying it right now!

The big mystery is insane!

Somehow I did a snapshot of the network config window (for report)

and it got stuck under the devices tab. It persists to this day!

rebooted 20 times since then!

I can make a screenshot of the mystery!

landonmkelsey 12-02-2006 12:59 PM

how do I set the network mask using this network admin dialog?
how do I set the network mask using this network admin dialog?

I can use netstat...I quess!

jwcourt 12-03-2006 12:46 AM

I would be surprised if you want to set the network mask
if you are using DHCP for address assignment, they usually
act as an inseperable tuple. Certainly no DHCP server will
give you an address without an accompanying net mask.
If you really want to set a net mask
different to what the DHCP server is providing I would suggest
sticking with assigning both IP address and net mask statically.



All times are GMT -5. The time now is 03:43 AM.