LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 07-22-2005, 07:30 AM   #1
hoyLANd
LQ Newbie
 
Registered: Jul 2005
Distribution: Fedora Core, Mandrake
Posts: 10

Rep: Reputation: 0
Fedora Core 3 will not connect to Cisco 2514 router


Hi,

I'm attempting to study for my CCNA and recently bought an old cisco 2514 router with 2 10 mbps ethernet transceivers connected to AUI ports. I was attempting to set up a little network with two hosts, one on either end of the router. All the interfaces have different static IP addresses. One host is a linux box running fedora core 3, the other a windows XP laptop. The linux box has an integrated 10/100/1000 NIC on the motherboard. I think it's a Broadcom.

When I connected my windows laptop, line protocol went up and the router and laptop could ping each other. But the linux box will not connect. The router's AUI0 port has a static IP of 192.168.0.1 netmask 255.255.255.0 and is running at 10 mbps. The linux box has a staic IP of 192.168.0.100 with the same netmask. When I type ifconfig eth0 up, the NIC on the linux box goes up, but the router does not connect and they can't ping each other. I assumed they weren't autonegotiating line speed correctly so I typed

ethtool -s eth0 speed 10 duplex full autoneg off

but that didn't appear to do anything. I have tried switching the AUI interfaces to see if it was the router, and when I connected the windows box to AUI0 line protocol went up, so I'm sure it's not the router's fault. Is there some problem with the syntax of the above command? Or am I doing something else wrong? Any help is appreciated.
 
Old 07-23-2005, 02:44 AM   #2
birdee
LQ Newbie
 
Registered: Jul 2005
Posts: 6

Rep: Reputation: 0
can you post yr running config so that we can all take a look.

Regards, birdee
 
Old 07-23-2005, 03:08 AM   #3
birdee
LQ Newbie
 
Registered: Jul 2005
Posts: 6

Rep: Reputation: 0
Smile

one more thing, you can try to use the mii-tool in the command line.

You can do a "man mii-too" to see the various options of using this command.If i am not wrong, you can try : mii-tool -F 10baseT-HD to see if it helps.

just my 2 cents

HTH

birdee
 
Old 07-23-2005, 05:55 PM   #4
hoyLANd
LQ Newbie
 
Registered: Jul 2005
Distribution: Fedora Core, Mandrake
Posts: 10

Original Poster
Rep: Reputation: 0
Hey birdie, thanks but your suggestion didn't work. Here is my running-config from the router. I don't think the problem is on the router side but then again I'm very new to Cisco. See anything out of place?

Using 754 out of 32762 bytes
!
version 10.2
!
hostname crisco
!
enable secret 5 [deleted]
enable password [deleted]
!
no ip routing
!
interface Loopback0
ip address 172.0.0.1 255.255.255.255
no ip route-cache
!
interface Loopback1
ip address 172.0.1.1 255.255.255.255
no ip route-cache
!
interface Ethernet0
ip address 192.168.0.1 255.255.255.0
no ip route-cache
loopback
!
interface Ethernet1
ip address 192.168.1.1 255.255.255.0
no ip route-cache
loopback
!
interface Serial0
no ip address
no ip route-cache
shutdown
!
interface Serial1
no ip address
no ip route-cache
shutdown
!
line con 0
line aux 0
line vty 0 4
password [deleted]
login
!
end
 
Old 07-24-2005, 06:55 AM   #5
scowles
Member
 
Registered: Sep 2004
Location: Texas, USA
Distribution: Fedora
Posts: 620

Rep: Reputation: 31
Since you are studying for your CCNA, I'm going to reply with some pointers that should steer you in the right direction in resolving your problem.
----
In the past, I've had problems with certain NIC cards and auto-negotiation. Setting the speed and duplex at each end always seems to fix this problem.

With the above in mind, checkout the "speed" and "duplex" commands while configuring the associated interface on your cisco router. Use ? after typing speed or duplex.

BTW: This has nothing to do with your speed/duplex problem, but did you notice the following command in your cicso config? no ip routing.
 
Old 08-02-2005, 07:33 AM   #6
hoyLANd
LQ Newbie
 
Registered: Jul 2005
Distribution: Fedora Core, Mandrake
Posts: 10

Original Poster
Rep: Reputation: 0
Thx scowles. I set the speed and duplex on the router and the NIC and it worked. Appreciate your help! And yes, i was aware of the no ip routing command in my config... i was trying to get everything conencted before i set up any routes.

Also, I recently read a book that I found immensely helpful in setting up NAT and DHCP on my router... if anyone wants a good primer on configuring cisco routers, check out the O'Reilly cisco Cookbook.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora Core 3 Cisco 350 wb575 Linux - Wireless Networking 1 03-16-2005 08:33 AM
Cisco VPN 4.6.00 on Fedora Core 3 ldonkers Linux - Software 4 01-28-2005 08:26 PM
Cisco Aironet 340 on Fedora Core 3 deviousz Linux - Wireless Networking 2 12-15-2004 02:06 AM
Cisco Router and Fedora Linux? carlosinfl Linux - Networking 4 06-30-2004 09:42 PM
Fedora Core 1 can connect to Router but not out to internet Eleavings Linux - Newbie 4 03-26-2004 12:58 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration