LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Fedora Core 2 - Internet is slow, why? (https://www.linuxquestions.org/questions/linux-networking-3/fedora-core-2-internet-is-slow-why-184514/)

ExTerminator 05-22-2004 12:06 PM

Fedora Core 2 - Internet is slow, why?
 
Hi!

I am Using the Fedora Core 2, and a ZyXEL Prestige 650 HW33 ADSL modem/router.
2 computers is behind the router, i am using NAT. (1 Windows and 1 linux box)

The problem is: Most of the webpages just stand in "resolving host...." like 1 minute before it starts to load the page.
I have tryed Mozilla, Firefox and Conquorer. Cookies is enabled.

When i try to ping a page with the problem i get 0% packetloss..

So i just wonder if it could be my router?
MTU is 1500. ISP is Tele2, ADSL 1024/256 Kbit

The Windows box is working just fine.

Any ideas?

kenzo 05-26-2004 12:14 PM

I have exactely the same probleme :( .... 1-2 min/ a webpage

maxut 05-26-2004 12:25 PM

u both have linux. so u can run named. it will work as a caching nameserver
u must use static ip. if linux gets ip from DHCP it will change default nameserver.
start named (BIND)
and change /etc/resolv.conf like this:
nameserver 127.0.0.1

and let me know if it solved your trouble.

ExTerminator 05-26-2004 01:27 PM

That is exactly how i am running the system, with no DHCP.
Only using static internal IP's, and the nameservers from my ISP.

But you say i should set the name server to 127.0.0.1?? I guess that is just an example internal IP from you, but you doesnt really mean that i should use an internal IP adress as nameserver?

Anyway, I have tryed Mandrake 10 and the SUSE LIVECD 9.1 to test if its my hardware or the distro, and i had same problem with them.

kenzo 05-26-2004 01:53 PM

i tryed to change resolv.conf

Quote:

search localdomain
nameserver 127.0.0.1
or
Code:

search localdomain
nameserver 192.168.0.1

but its not better :(

maxut 05-27-2004 02:06 AM

Quote:

Originally posted by ExTerminator

But you say i should set the name server to 127.0.0.1?? I guess that is just an example internal IP from you, but you doesnt really mean that i should use an internal IP adress as nameserver?

u can use internal ip as nameserver, if u start named (bind) service. u will have your own nameserver. i already use local named service to resolve domain names. actually i use my own nameserver to test services such as mail server and others. it works greatly here.

Huw Evans 07-05-2004 11:36 AM

Hi all
I've been having the exact same problem. Found this solution at http://weblogs.mozillazine.org/darin...es/005753.html

"Users of Mozilla on Fedora Core 2 may experience unusually long delays in resolving hostnames. This results from the fact that IPv6 is enabled by default in Fedora Core 2. If you do not need IPv6 support (which is most likely the case), then it is advised that you disable it in the kernel. To do this run the following command as root:

echo "alias net-pf-10 off" >> /etc/modprobe.conf

You will need to reboot to have this take effect (or simply unload the ipv6 kernel module)."

This worked for me - internet is flying again.
Good luck!


All times are GMT -5. The time now is 11:07 AM.