-   Linux - Networking (
-   -   Fedora 9 network and mnb dead on boot-up (

Tom Douglas 07-19-2008 07:16 PM

Fedora 9 network and mnb dead on boot-up
I just installed Fedora 9 and find the network and nmb services are dead on boot. I need those to start when it's booted up. In the GUI Service Config, I see the mnb and network servers are set to run upon boot. On the CLI, I run service nmb status; same for network -- both are down.

I clicked the disable, and enable, and restart bottons on the GUI. Ran chkconfig nmb on and chkconfig network on at the CLI. No luck with either of these upon reboot.

In any case, when I run service network start, and service nmb start, they run, until I shut down or reboot.

What am I missing in my configs?

Thank you!

Tom D.

amani 07-20-2008 12:06 PM

Check the config of system services too

daveginorge 07-20-2008 12:27 PM

Hi I know the problem, took me a while to find a solution.

I found that once I had been into the "System -> Administration -> Network" Select the interface and choose "Edit" make no changes click "OK" Go to "File -> Save", Open "System -> Administration -> Services" and restart "Network" everything started to work.... who knows the reason why. I have re-installed FC9 on the same machine twice now and always had the same problem with networking, but the above always gets me going....:)

What is really annoying me with FC9 is that Firefox always starts in the OFFLINE mode, I need to go to File -> Work Offline and remove the mark before I can use it..... if you have an answer to that I would like to hear it.


SD-user 07-20-2008 05:42 PM

Dave - I have similar problems with my network connections. I have a wired NIC card and a wireless card. Whenever I start Fedora 9, it automatically loads the wireless card and disables the wired NIC card - regardless how I configure/set/save using the Network Device Control. I never had problems with the Network Device Control not saving my settings in the past.

I tried your sequence and still no luck. Anyone have any ideas?

Also, I agree, the Firefox 3 "Offline" mode is a major pain. I read some documentation that that was linked to Firefox's ability to automatically recognize whether you are connected to the internet. My guess is that our network connections problems are directly associated to the firefox problem. As far as I know, there's no quick fix or permanent way to prevent firefox from entering the "Offline mode".

Let me know if you find anything out, as I will do likewise.

daveginorge 07-21-2008 12:59 AM

This is true, the network icon at the top of the screen is always telling me I have no network connection but I am able to get out on the web and contact my severs.

The system I am working with is a test system so I can trash it as much and as often as I like, I never change the OS on my servers until I am satisfied the new OS will perform the same as the last, looks like I will be staying with FC8 for a while yet on the servers.

I will keep you all informed with any major solutions.

I have been installing and setting up machines since RedHat 7 with a few minor changes to my routine this is the first time I have not been able to see a solution within a few hours. I have a feeling this is a bug and a solution will find it's way to us but I need to be a little more sure before I report it..

Tom Douglas 08-01-2008 08:24 PM


Originally Posted by daveginorge (Post 3220749)
Hi I know the problem, took me a while to find a solution.

I found that once I had been into the "System -> Administration -> Network" ....

That cured the problem. I tried your suggestion and rebooted....Samba and network services came right up. Seems strange that you'd have to edit and save the NIC config.

At any rate, thanks for that fix. It would have taken me forever to find!

Tom D.

mike327 08-03-2008 07:22 PM

Count me in on Network Icon has x in it even though I can use the internet. In Firefox I must un-check "work off line" during each session. I must also click "go on line" in Evolution mail. I am a Linux newbie running Fedora 9 and the above happened after I changed network settings from DHCP to a static ip address.
The solution proposed by Dave that worked for Tom worked in Firefox only for me until reboot. One thing I noticed & someone else posted something similar.
I went into Network connections with 5 tabs
first is Wired, second is wireless etc.
Under Wired "wired connection1" _________never
is set (never is grayed out)- I believe that could be related to the problem...however, I have tried everything short of deleting the connection to change it and have not found a way.
Seems like I am not alone on these problem(s)/annoyance(s)

mike327 08-04-2008 12:02 AM

Came up with solution for Fedora 9. In Network put a check mark in "enable IPv6 for this device" Click "save" and either reboot computer or restart Network in services. Firefox 3 works online all the time. Evolution Mail works online all the time and Network Icon with x in it disappears. You can always add Network Icon to Panel if you so desire. I'm so sick of seeing the x and unchecking "work offline" in Firefox and "clicking "go online" in Evolution Mail...I don't care to see it anyway. I just want it to work - thank you very much. :-)

To get to Network <system><Administration><Network>

mike327 08-05-2008 10:24 PM

Follow Up :
I wanted to fully test my solution so I went back into Services and noted that Network Manager was no longer there. I then went back into Network configuration, edit and put a check mark in Let Network Manager handle Network and kept the check mark in start Network Device at Start up.
Saved and rebooted - everything is fine. I then went back into services and Network Manager was back again but disabled. I enabled it and rebooted. The Network Icon returned to Panel with no check mark and everything is fine and dandy in Firefox and evolution mail. So putting the check mark in enable IPv6 was indeed the solution with no other variables I can see coming into play.

All times are GMT -5. The time now is 07:44 AM.