-   Linux - Networking (
-   -   Fedora 8 - No Internet - Compaq Presario 1700 (

ImP^o^Rt 02-23-2008 12:45 AM

[FIXED] Fedora 8 - No WWW/POP3
EDIT: Fixed. Turns out the only problem was that it wasn't resolving IPs. I just had to specify the DNS servers for the ethernet card, and straight-away it worked. I figured this out after pinging random websites, finding the IPs and then typing the IPs in Firefox. Firefox would immediately go to that website, which showed that the only problem was with resolving IPs. I looked at my router's DNS specs, put them in system-config-network and it was all OK.

Also, I had to change the router's firewall such that it allows DNS and DHCP from external networks. I also made it allow FTP and telnet for my convenience.


I've searched the forums and haven't found anything that's as unique as mine. Most people's connections seem to not work at all.

I got into *NIX not too long ago because a requirement of my university course is to learn the operating system. While It's interesting and nice to fiddle around with, I've encountered a problem right off the bat.

I can't access any websites via Firefox, or receive POP3 emails via "Evolution."

The strange thing is that at one time Firefox would load pages about halfway, and then seem to stop trying (still working, but no further data seems to be transferred). Google wouldn't work and, ironically enough, the fedoraproject website worked :p

POP3 mail isn't working at all. I've tried to Send/Receive about 10 times and it's timed out all 10 times. SMTP isn't working either (tried to send e-mail, timing out).

Another strange phenomenon is that I tried to ping some sites via Terminal (bash) and it worked. Pinging Google (which obviously then got resolved to an IP) worked, so I don't think it's a DNS problem.

Another thing that I noticed was that I can connect to my router (, but otherwise the connection to outside websites would either slow to a crawl or not work at all.

I'm thinking that it's my router. I find it interesting that some protocols are working and some aren't. Any help would be appreciated.

Technical details:
Router: D-Link DSL-504T 4-port router (wired, RJ-45 cable)
Linux distribution: Fedora 8 - i386

PC Specifications:
Processor: Intel Pentium III - 800Mhz
Modem: Conexant Something-or-other (if this is the problem do tell, so

Imp :D

unSpawn 02-23-2008 06:20 AM

What iptables rules does your machine have (/sbin/iptables -n -L')?
What firewalling does your router do?
If you are on a campus network, does it require you to use their proxies?
Else what does running tcptraceroute show connecting (or manually telnetting) to the IP addressses of your SMTP?

ImP^o^Rt 02-23-2008 07:30 PM

Fixed. Thanks for your reply, unSpawn (read first post)

Thanks for your reply.

I'm rather new to *NIX so I'll try to do what you instructed me to do.

I'm going to be using this laptop at home always (no proxies).

My router seems to have 3 types of protection as a firewall? One is DoS Protection (checks for SYN flood), the other is port scan protection, and this one which is starting to make me think, which is "Service filtering". This is blocking an item called "DHCP from External Network" and "DNS from External Network." It may be treating the PC as an external network, since it doesn't recognise the PC's name, but only gives it the name "unknown." Clue?! I made it so that it doesn't block FTP, DNS or DHCP from unkno

iptables result:


[root@presario1700 ~]# /sbin/iptables -n -L
Chain INPUT (policy ACCEPT)
target    prot opt source              destination          RH-Firewall-1-INPUT  all  --  
Chain FORWARD (policy ACCEPT)
target    prot opt source              destination         
REJECT    all  --            reject-with icmp-host-prohibited 
Chain OUTPUT (policy ACCEPT) target    prot opt source              destination         
Chain RH-Firewall-1-INPUT (1 references) target    prot opt source              destination         
ACCEPT    all  --             
ACCEPT    icmp --            icmp type 255 
ACCEPT    esp  --             
ACCEPT    ah  --             
ACCEPT    udp  --          udp dpt:5353 
ACCEPT    udp  --            udp dpt:631
ACCEPT    tcp  --            tcp dpt:631
ACCEPT    all  --            state RELATED,ESTABLISHED 
REJECT    all  --            reject-with icmp-host-prohibited

I can't "tcptraceroute" (command not found) but I can, from my DOS knowledge "tracert" to the SMTP server. However, it can't seem to use DNS to resolve the IP. Whenever I traceroute it, it says "Tracing route to (" However, if I ping it first (which resolves the IP) then traceroute, it resolves the IP as shown in the screenie here. Strange.

Thanks for your help,
Imp :D

unSpawn 02-24-2008 10:16 AM

Well done fixing this yourself.

All times are GMT -5. The time now is 04:52 PM.