LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 05-27-2008, 07:12 AM   #1
revof11
Member
 
Registered: Nov 2003
Location: Macungie, PA
Distribution: Fedora Core 9, Gentoo 2008.0
Posts: 108

Rep: Reputation: 15
FC9 : SSH OK but unable to connect via FTP, VNC, etc.


I can successfully connect to my PC on my local network via SSH. However, I cannot connect to it by any other means (my primary concerns being FTP and VNC). I have disabled the local firewall and the SELinux enforcement (I am behind a firewall on the network already and it is not necessary) but still cannot connect.

The system is:
Quote:
$ uname -a
Linux revof11-fedora 2.6.25.3-18.fc9.i686 #1 SMP Tue May 13 05:38:53 EDT 2008 i686 i686 i386 GNU/Linux
You can see the GUI-based config options here:
I can connect to the server successfully using localhost as you can see here:
Quote:
]$ ftp localhost
Connected to localhost (127.0.0.1).
220 (vsFTPd 2.0.6)
Name (localhost:myuser):

$ vncviewer localhost:1

VNC Viewer Enterprise Edition E4.4.0 (r12094) for X
Built on May 6 2008 10:43:38
Copyright (C) 2002-2008 RealVNC Ltd.
See http://www.realvnc.com for information on VNC.
However, doing so from any other computer on the network doesn't work:
Quote:
$ftp my.ip.address
> ftp: connect :Unknown error number
ftp>

>vncviewer my.ip.address:1

VNC Viewer : Error
unable to connect to host: A socket operation was attempted to an unreachable host. (10065)
Does anyone out there have any suggestions/fixes?
 
Old 05-27-2008, 09:11 AM   #2
sunethj
Member
 
Registered: Nov 2006
Posts: 97

Rep: Reputation: 16
did you try ftp to the local ip address from the fc9 box (instead of the localhost put ip address and see.) if that fails then it may be because the server is not listening in that ip address.
 
Old 05-27-2008, 11:34 AM   #3
espiya7
Member
 
Registered: Jul 2007
Posts: 33

Rep: Reputation: 15
try checking these files:

/etc/hosts.allow
/etc/hosts.deny

try adding your service to the hosts.allow file if it is not included and remove your service if it's in the hosts.deny
 
Old 05-27-2008, 01:53 PM   #4
revof11
Member
 
Registered: Nov 2003
Location: Macungie, PA
Distribution: Fedora Core 9, Gentoo 2008.0
Posts: 108

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by sunethj View Post
did you try ftp to the local ip address from the fc9 box (instead of the localhost put ip address and see.) if that fails then it may be because the server is not listening in that ip address.
That does actually work. If I FTP or VNC to my.ip.addressort, it works just fine. It works exactly as if I was using localhost or 127.0.0.1.

So...

Quote:
Originally Posted by espiya7 View Post
try checking these files:

/etc/hosts.allow
/etc/hosts.deny

try adding your service to the hosts.allow file if it is not included and remove your service if it's in the hosts.deny
Both files where empty (well, they were commented, but there was nothing directly useful in there). I looked at the man 5 hosts_options page and was able to come up with the following for my /etc/hosts.allow file:

Code:
#
# hosts.allow	This file contains access rules which are used to
#		allow or deny connections to network services that
#		either use the tcp_wrappers library or that have been
#		started through a tcp_wrappers-enabled xinetd.
#
#		See 'man 5 hosts_options' and 'man 5 hosts_access'
#		for information on rule syntax.
#		See 'man tcpd' for information on tcp_wrappers
#

ALL: ALL: ALLOW
I restarted my network interface, my inet.d services, xinetd, etc. and had no luck. I rebooted and had no luck. I did the same using vsftpd: ALL: ALLOW with no luck as well.

However, while booting, I noticed messages for "enabling iptables firewall settings" (or something to that nature, it's not appearing in my /var/log/messages, /var/log/boot.log or dmesg). I'm going to try working with some other configurations with the firewall and SELinux both enabled to see if I can get it working that way...

Unless you have more suggestions...?
 
Old 05-27-2008, 02:02 PM   #5
revof11
Member
 
Registered: Nov 2003
Location: Macungie, PA
Distribution: Fedora Core 9, Gentoo 2008.0
Posts: 108

Original Poster
Rep: Reputation: 15
OK... I was actually able to get it all working by emptying my /etc/hosts.allow file and re-enabling the firewall via Gnome. When I did this, I set up the following:

That will suffice.

But I'm still curious as to why the rules were applied even after I explicitly turned it off via the GUI. Bug?
 
Old 05-29-2008, 12:06 PM   #6
richardedwards
LQ Newbie
 
Registered: May 2008
Posts: 1

Rep: Reputation: 0
I had exactly the same issue. Got to be a bug...surely two of us can't make foolish errors!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to connect with telnet, ssh, ftp, etc... djlerman Linux - Server 1 09-05-2007 04:13 PM
Unable To Connect VNC carlosinfl Debian 1 06-29-2007 07:48 AM
Real VNC. Unable to connect joeman3429 Linux - Networking 4 10-18-2005 07:27 PM
Unable to connect VNC client puneetloiya Linux - Networking 5 04-29-2005 12:59 AM
unable to connect to server thru vnc... marvc Linux - Software 0 05-25-2003 07:24 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 10:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration