LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 03-25-2005, 07:51 AM   #1
sparks_lu
LQ Newbie
 
Registered: Mar 2005
Posts: 5

Rep: Reputation: 0
Question Failed to bring up ethernet interface


I have two ethernet card installed, eth0 is for internet connection and eth1 for home intranet. Now, (I think) both cards have been successfully recognized coz "ifconfig" output information for both cards, but eth1 simply failed to be brought up on both system start up and manully start up after boot. The output of "ifconfig" is as following:

eth0 Link encap:Ethernet HWaddr 00:20:78:04A:69
inet addr:130.88.190.62 Bcast:130.88.190.255 Mask:255.255.255.0
inet6 addr: fe80::220:78ff:fe04:da69/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:32508 errors:0 dropped:0 overruns:0 frame:0
TX packets:9251 errors:0 dropped:0 overruns:0 carrier:0
collisions:2855 txqueuelen:1000
RX bytes:16141247 (15.3 MiB) TX bytes:1124809 (1.0 MiB)
Interrupt:5 Base address:0xc400

eth1 Link encap:Ethernet HWaddr 00:05:5D:37:0D:CE
inet6 addr: fe80::205:5dff:fe37:dce/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:20 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:4176 (4.0 KiB)
Interrupt:9 Base address:0x3000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:3639 errors:0 dropped:0 overruns:0 frame:0
TX packets:3639 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:4645994 (4.4 MiB) TX bytes:4645994 (4.4 MiB)

And the output of "lspci" displays these:

00:00.0 Host bridge: Intel Corp. 82815 815 Chipset Host Bridge and Memory Controller Hub (rev 02)
00:01.0 PCI bridge: Intel Corp. 82815 815 Chipset AGP Bridge (rev 02)
00:1e.0 PCI bridge: Intel Corp. 82801AA PCI Bridge (rev 02)
00:1f.0 ISA bridge: Intel Corp. 82801AA ISA Bridge (LPC) (rev 02)
00:1f.1 IDE interface: Intel Corp. 82801AA IDE (rev 02)
00:1f.2 USB Controller: Intel Corp. 82801AA USB (rev 02)
00:1f.3 SMBus: Intel Corp. 82801AA SMBus (rev 02)
00:1f.5 Multimedia audio controller: Intel Corp. 82801AA AC'97 Audio (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 MX 440] (rev a3)
02:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
02:0f.0 Ethernet controller: Linksys NC100 Network Everywhere Fast Ethernet 10/100 (rev 11)

The highlighted device is the one has problem (eth1).
So why the system can recognize the card ( I guess this means the right module for the device has been installed, right?) but can not bring it up and use it? I am running Fedroa Core 3 and the error message when the system tries to bring the interface up is: Determining IP information for eth1...Internal network device eth1 is not ready. Aborting.. Both card are working perfectly under windows xp. So anybody has any idea on the problem? Thanks in advance!
 
Old 03-25-2005, 09:23 AM   #2
mickyg
Member
 
Registered: Oct 2004
Location: UK
Distribution: Ubuntu/Kubuntu
Posts: 249

Rep: Reputation: 30
How is the IP address assigned in Windows? Is it dynamic or static? I'm no expert but looks like it's trying to get an IP address for eth1 but can't find one cos nothing is assigning it one (i.e. a DHCP server) and so is failing. Have a look at your settings under windows, if it is a static IP for eth1 then you'll need to set that up in FC3.

To find this out in xp, go to contol panel > network connections, double click the connection and select the select the "internet protocol (TCP/IP)" item and click properties. If it's got "use the following IP address" ticked and has ip address, subnet mask and default gateway filled out then it's a static address. Make a note of these! If this is the case then in FC3, assuming you're using Gnome and not KDE go to Application menu > System Settings > Network.

Click eth1 > edit, put a tick in the "Statically Set IP addresses" section and fill out the details as they were in windows. If not ticked make sure "Activate device when computer start" is ticked. Click Ok then with eth1 highlighted, click "Activate".

All this being said, if in windows it's dynamically assigned by DHCP then, provided FC3 is set to look for DHCP then I don't know why it doesn't work.

Last edited by mickyg; 03-25-2005 at 09:28 AM.
 
Old 03-25-2005, 03:55 PM   #3
Imanerd
Member
 
Registered: Dec 2004
Location: Bay Area, California
Distribution: Fedora Core 3
Posts: 65

Rep: Reputation: 15
Quote:
Originally posted by mickyg


Click eth1 > edit, put a tick in the "Statically Set IP addresses" section and fill out the details as they were in windows. If not ticked make sure "Activate device when computer start" is ticked. Click Ok then with eth1 highlighted, click "Activate".

Wouldn't you want to use a different IP address than the one the Windows machine is using to avoid conflicts?
 
Old 03-26-2005, 08:15 AM   #4
sparks_lu
LQ Newbie
 
Registered: Mar 2005
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by mickyg
How is the IP address assigned in Windows? Is it dynamic or static? I'm no expert but looks like it's trying to get an IP address for eth1 but can't find one cos nothing is assigning it one (i.e. a DHCP server) and so is failing. Have a look at your settings under windows, if it is a static IP for eth1 then you'll need to set that up in FC3.

To find this out in xp, go to contol panel > network connections, double click the connection and select the select the "internet protocol (TCP/IP)" item and click properties. If it's got "use the following IP address" ticked and has ip address, subnet mask and default gateway filled out then it's a static address. Make a note of these! If this is the case then in FC3, assuming you're using Gnome and not KDE go to Application menu > System Settings > Network.

Click eth1 > edit, put a tick in the "Statically Set IP addresses" section and fill out the details as they were in windows. If not ticked make sure "Activate device when computer start" is ticked. Click Ok then with eth1 highlighted, click "Activate".

All this being said, if in windows it's dynamically assigned by DHCP then, provided FC3 is set to look for DHCP then I don't know why it doesn't work.
The problem's solved by set the static IP address to eth1. Thanks mickyg!
 
Old 03-27-2005, 08:04 AM   #5
mickyg
Member
 
Registered: Oct 2004
Location: UK
Distribution: Ubuntu/Kubuntu
Posts: 249

Rep: Reputation: 30
No problem, glad to help.

Imanerd:
I assumed the machine was dual booting FC3 and XP, if it is then you'll never have windows and linux running at the same time so you shouldn't get any DNS conflicts, but if they were a different machine then you would set the ip addresses to be different from each other.
 
Old 03-27-2005, 11:57 AM   #6
Imanerd
Member
 
Registered: Dec 2004
Location: Bay Area, California
Distribution: Fedora Core 3
Posts: 65

Rep: Reputation: 15
Quote:
Originally posted by mickyg
No problem, glad to help.

Imanerd:
I assumed the machine was dual booting FC3 and XP, if it is then you'll never have windows and linux running at the same time so you shouldn't get any DNS conflicts, but if they were a different machine then you would set the ip addresses to be different from each other.
Ahh... that makes more sense.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't bring up eth0 Interface at boot robertmenezes Linux - Networking 8 02-21-2005 02:13 AM
pppd: how to bring up an interface? J_Szucs Linux - Networking 2 08-08-2004 09:02 AM
FC2 won't bring up interface eth0 Cikotic Fedora - Installation 4 07-09-2004 04:24 PM
Can't Bring Ethernet Up / Can't Active Ethernet / Guigo Linux - Newbie 8 04-03-2004 09:31 AM
couldn't bring up interface eth0 mikez Linux - Networking 9 02-28-2002 01:02 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 07:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration