LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 10-21-2004, 04:44 AM   #1
bones996
Member
 
Registered: Sep 2003
Location: Pennsylvania
Distribution: Debian Squeeze
Posts: 106

Rep: Reputation: 15
failed ssh


I recently reinstalled a firewall/router that I have been trying to setup & I can no longer log into it using ssh. I have removed my $home/.ssh file & still can't get in, so can anyone help me restore my ssh sessions? This is getting really frustrating, because I have reinstalled the firewall twice & enabled everything to try to ssh in. This is a redhat 9 box btw. Thanks for any help.
 
Old 10-21-2004, 05:06 AM   #2
BillJennings
Member
 
Registered: Oct 2004
Location: Big River, California, USA
Distribution: Debian
Posts: 48

Rep: Reputation: 15
Is the firewall a redhat 9 box, or is the redhat 9 box the one you are trying to ssh from?

If the firewall is the linux box, then...

What exactly happens when you try to ssh into the firewall?

Is the ssh daemon running (sshd) on the firewall?

If so, could you post the contents of /etc/ssh/sshd_config on the firewall?

Sincerely
Bill Jennings
 
Old 10-21-2004, 02:38 PM   #3
bones996
Member
 
Registered: Sep 2003
Location: Pennsylvania
Distribution: Debian Squeeze
Posts: 106

Original Poster
Rep: Reputation: 15
The firewall box is redhat 9, so is one of the 2 other boxes I'm using the other is suse 9 pro. I have tried using the ssh server running on each of the boxes, but the connection keeps timing out. I was able to ssh in fine before I reinstalled redhat 9, but not anymore. I'll post my sshd_config file when I get home.
 
Old 10-21-2004, 03:39 PM   #4
BillJennings
Member
 
Registered: Oct 2004
Location: Big River, California, USA
Distribution: Debian
Posts: 48

Rep: Reputation: 15
Also, check to see if the ssh server is actually running on the target machine. Type:

ps aux | grep [s]shd

You should see at least one instance of sshd running (the square brackets around the first "s" in sshd are so you won't get a match on the "grep" command, which WILL be running when you make the check).

Sincerely
Bill Jennings
 
Old 10-23-2004, 03:26 AM   #5
bones996
Member
 
Registered: Sep 2003
Location: Pennsylvania
Distribution: Debian Squeeze
Posts: 106

Original Poster
Rep: Reputation: 15
The sshd server is currently running on all 3 computers, but since the re-install I still can't log back in.I'm beginning to think about reinstalling my media box as that is what I've been using to administer my firewall, but I have an uptime of 21 days & don't want to ruin that because its better than I ever did in windows & want to see how long I can keep it up without a major power spike or anything.
 
Old 10-23-2004, 03:31 AM   #6
bones996
Member
 
Registered: Sep 2003
Location: Pennsylvania
Distribution: Debian Squeeze
Posts: 106

Original Poster
Rep: Reputation: 15
I just noticed that I can still login to my suse box from my media box & vice-versa - which still leaves me to wonder why I can't login to my firewall (I know I'm probably overlooking something dumb, but thats what it takes to learn sometimes I guess ).
 
Old 10-30-2004, 09:46 PM   #7
bones996
Member
 
Registered: Sep 2003
Location: Pennsylvania
Distribution: Debian Squeeze
Posts: 106

Original Poster
Rep: Reputation: 15
Thanks for the help, I finally found ou t what my problem was. I misconfigured the firewall & couldn't get in except from the console - I'll know better when I redo it this time ( there are some other problems that I still have to figure out due to the modem having it's own assigned address - but thats another thread later if needed ).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mozilla through ssh failed eantoranz Linux - Software 5 11-18-2004 01:57 PM
SSH Failed Password Monitoring KPOM Linux - Security 1 10-10-2004 12:25 AM
many failed ssh attemps mindcry Linux - Security 3 08-09-2004 02:02 PM
Failed Login through SSH? Help PLEASE tangman Linux - Newbie 8 03-31-2004 04:02 PM
ssh failed login question nelly_boy Solaris / OpenSolaris 3 02-26-2004 09:52 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 06:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration