-   Linux - Networking (
-   -   Ethernet driver for gigabyte ga-h77-ds3h motherboard (

SpicySpicySpice 11-26-2012 09:51 PM

Ethernet driver for gigabyte ga-h77-ds3h motherboard
I recently installed Linux mint 14 on a new desktop. Everything worked fine, except the ethernet port. I'm 99% sure it just needs a driver.

I looked here:
and it mentions

"The Intel Gigabit Ethernet board is supported by an Intel-written driver. Contact Intel directly for more information."

I tried to find it on the intel download center however, I couldn't. Please help.

Motherboard specs:

pan64 11-27-2012 10:13 AM

probably here: you can find a useful tip

SpicySpicySpice 11-27-2012 04:52 PM

I've done all the basic tests in the terminal everything points to linux simply not detecting eth0, furthermore the ethernet port lights up and is definitely working. So, I'm pretty sure all I need is the proper driver. However, points me to the Intel download center and I'm unable to figure out what driver I need to download from them.

SpicySpicySpice 11-27-2012 08:35 PM

By the way none of the advice in the thread helped. I previously used lsmod, ifconfig -a and other tests I can't remember and it didn't show up. I always got an error message along the lines of eth0 no such device.

Can someone either point me to another location of the driver, or help me find it on the intel website? I've googled everywhere and found nothing.

unSpawn 11-27-2012 08:47 PM

Just post your

lspci -vks $(lspci | awk '/Ethernet/ {print $1}')

SpicySpicySpice 11-27-2012 09:13 PM

Ethernet controller Atheros Communications AR8161 Gigabit Ethernet (rev 10)
capabilities:<access denied>

I'm searching for the Atheros driver now, I had been unable to get the specific model until now, I'll post more if anything goes wrong.

edit: compiling is taking forever, but problem seems to be solved. I found drivers here:

SpicySpicySpice 11-27-2012 10:34 PM

argh so it's still not working.
I downloaded the file at the link I posted.
copied the commands.

it then displayed this in the terminal:

Now run:

sudo make unload to unload all: wireless, bluetooth and ethernet modules
sudo make wlunload to unload wireless modules
sudo make btunload to unload bluetooth modules

Run sudo modprobe driver-name to load your desired driver.
If unsure reboot.

I wasn't sure what to do at this point so I tried:

sudo make unload, then
sudo modprobe atl1 and atl2,
but nothing happened. I rebooted and tried again and still nothing.

Not really sure how to proceed.

unSpawn 11-28-2012 06:04 AM

Me neither. Granted you found the ALX driver yourself, which is good, but you rather talk about things and running commands rather than posting exact output. When asked you post incomplete output and when the instructions say you should run certain commands you make up your own. Most build processes will tell you if they exited OK and else they can save nfo to post with for example 'make [whatever args] 2>&1 | tee /tmp/log', tools like modprobe have switches like "--verbose", "--dry-run" and "--show-depends" to display diagnostics and dmesg often contains clues.

All times are GMT -5. The time now is 09:14 PM.