-   Linux - Networking (
-   -   Ethernet connection failure with different router/modem. (

zmpetro 11-28-2011 07:23 PM

Ethernet connection failure with different router/modem.
Hello LQ, time for my first post. I have an old Dell Inspiron 1520 Laptop that I installed a CRUX knockoff on: MineOS CRUX. The problem: the ethernet is not working. I installed this OS at a friends house a week ago to try it out, and the ethernet worked out-of-the-box. I come back to my house and reinstalled the OS on the same computer (don't ask why, it's a long story) and the ethernet did not work. Noticeably, the ethernet port on the side of the laptop blinks orange when I put it into the laptop. At my friend's house, there was a Netgear router, which ran on AT&T DSL, as opposed to a Belkin router here (I'm not sure if this matters) which runs on Comcast Cable. I used to have Windows on this PC and the ethernet worked fine. I am not sure what the problem could be. MineOS CRUX is a very barebones knockoff of CRUX. Stangely, when I went into my router's DHCP client list directly after installation, I could see the hostname "mineos" with the IP of, but not anymore. Any help would be appreciated, as this is somewhat urgent.

ifconfig output:

eth0 Link encap:Ethernet HWaddr 00:1C:23:8F:26 : D7
RX packets : 1551 errors:0 dropped:0 overruns:0 frame:0
TX packets:1255 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:484608 (473.2 Kb) TX bytes:156979 (153.2 Kb)

lo Link encap:Local Loopback
inet addr: Mask:
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0b)


03:00.0 Ethernet controller: Broadcom Corportation BCM4401-B0 100Base-TX (rev 02)

leandean 11-28-2011 10:32 PM

Did you plug in the cable after the machine had booted?? Is the ethernet cable good? Does the router require a password?? Have you bypassed the router to try it? Have you tried manually restarting networking?? sudo /etc/init.d/network restart

zmpetro 11-29-2011 03:42 PM

I have plugged the cable in before and after the machine has booted. The ethernet cable is good because when I plug it into a neraby desktop on Windows 7, it works fine. The router does require a password, but I never thought (from experience) that you needed to enter a password when connecting with an ethernet cord. Im not sure what "bypassed the router to try it" means. Sorry. I have tried to manually restart the network. This is either a really dumb mistake by me or an unfixable problem, as pessimistic as that sounds.

I have also noticed that data IS being sent through the eth0 connection. If you look at the RX and TX packets, there are some. Something must be going on here, although I'm certainly not positive what RX and TX packets are.

All times are GMT -5. The time now is 07:04 PM.