-   Linux - Networking (
-   -   Ethernet card stopped working all of a sudden (

nsfx 12-19-2006 07:00 PM

Ethernet card stopped working all of a sudden
Recently I put together a cheap machine using scrap parts I've accumulated over the years. When it was finished I decided to test out Frugalware 0.5. It's a nice distro!, but that's beside the issue. Anyway, today I turned it off to move it to a new location and when I got it back up and running, my ethernet card stopped working. It's a 3Com Broadcam that came with a Dell I bought many years ago. It was working perfectly just earlier today, and I didn't do any serious config changes since then (except alter my iptables which mysteriously didn't save even after iptables-save?).

So far, I've ruled out the CAT 5 cable and the router, and the card itself seems to working okay. The LEDs on the card are blinking. Peeking ifconfig eth0 reports that the card is sending and receiving packets, but it always times out on a dhcpcd. One suspicious item I noticed here is that RX overruns is at 1. I also tried setting the IP and mask explicitly, as well as adding a default routing rule to my gateway's IP. I also looked at dmesg and syslog but I didn't see anything suspicious, though I may be overlooking something. I also issued iptables -F and iptables -P INPUT ACCEPT.

Running out of ideas here. I think I might try running a Live CD just to see if another system config can pick up an IP. Any tips?

Thanks in advance!

nsfx 12-19-2006 07:16 PM

Update: I tried booting from the network; DHCP failed. At that point I thought the card was dead, but then I tried Damn Small Linux just for the hell of it and got an IP! Then I went back into Frugalware and also got an IP!!! Now I'm really confused. I did zero config changes. Did Damn Small Linux write to the card's EEPROM or something?! I'd like to understand what just happened. Maybe someone can elucidate things?

Update again: It's a completely tempermental problem. Restarted again and lost functionality. Tried the Damn Small Linux trick and it didn't work this time. I give up.

Quakeboy02 12-19-2006 08:18 PM

"Anyway, today I turned it off to move it to a new location"

When in doubt, switch to the backup. In this case, you might try taking it back to the old location just to see if it still works there.

All times are GMT -5. The time now is 08:13 AM.