LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   ethernet card is not detected? (https://www.linuxquestions.org/questions/linux-networking-3/ethernet-card-is-not-detected-206990/)

sha77 07-19-2004 01:34 PM

ethernet card is not detected?
 
Hi,

I'm new and I couldn't find any previous threads that help.

I just installed linux redhat 9 and I cannot connect to the internet. I have an onboard ethernet card Intel(R) PRO/1000 CT on ABIT IC7-G MAX II motherboard.

When I configured the network connection, this card did not seem to be listed in the list of the adapters. How can I know whether this card is automatically detected by linux? How to get the card to be listed there and how to install the driver?

Thanks

nafsnipe685 07-19-2004 01:55 PM

are you using dhcp, which gives you a default gateway to give a path to the internet, or are you using dialup, i need more info.

sha77 07-19-2004 02:28 PM

Hi,

I'm using static IP instead of DHCP. I type in my own IP address, gateway and so on.

Any ideas on how to get linux to detect my ethernet card?

Thanks.

bruj3w 07-19-2004 02:35 PM

im assuming kudzu is not detecting it at boot? try google'ing for the module that correponds to your nic, then lsmod <modulename>.

you may find that its not supported.

good luck.

Pete M 07-19-2004 02:48 PM

sha77

If you have a standard Redhat install with default Kernel you will need a driver for your onboard ethernet card

Available from Intel Here

At the bottom of the page it lists 'Intel® PRO/1000 CT Network Connection'

You are looking for 'e1000-5.2.52.tar.gz' unpack the driver and read the Readme for install instructions

Pete

sha77 07-20-2004 01:01 AM

Hi,

I unzipped the e1000-5.2.52 as what you said.

hmm.... where do I type all those commands stated in the README file? Do I type at the terminal(right click -> new terminal)?

Then, I encountered error when I type "make install". The error was:
"Makefile: 66 : ***Linux kernel source not found. Stop."

What does this mean? Any suggestions on how should I proceed with the driver installation?

Thanks.

Pete M 07-20-2004 03:36 AM

sha77

It means exactly what it says, you don't have the Kernel source installed

Go to

System Settings -> Add/remove/applications -> Development -> Kernel Development -> Standard Packages -> kernel-source

Put the appropriate CD in the drive when prompted

Pete

sha77 07-20-2004 04:33 AM

Hi,

Sorry, I'm a newbie. I'm still not able to install it.

After installing the kernel source like what Pete M said, I tried to install the driver again and I got the following error msg:

Fatal: can't create e1000_main.o: Permission denied
make:***(e1000_main.o) Error 2

Do I have to build the binary RPM in order to avoid such error message?

Thanks.

Pete M 07-20-2004 12:47 PM

sha77

To make the driver you will have to be root, that's why you get 'Permission denied' on the command line type su then your root password

Sorry I forgot to mention this

Try again let me know how you get on

Pete

sha77 07-20-2004 02:09 PM

First of all, I would like to thank you Pete for helping me through this thing. I still need more help in the future considering my experience in linux is still limited.

So, back to the topic.

This time I logged in as administrator and it worked half way...some improvements.

After I typed "make install", the process went well without any error. Then, the next part is "insmod e1000 <parameter>=<value>". What should I do over here? I've tried reading the whole manual but I didnt seem to understand it.

Thanks alot.

WMD 07-20-2004 02:30 PM

I could've sworn that an Intel Pro/1000 driver came with the default kernels....

But anyway, you should be using modprobe, not insmod. Type modprobe e1000_main. That should load the driver.

Still, I'm almost certain that you could've done modprobe e1000 without downloading anything new. :confused:

Pete M 07-20-2004 04:01 PM

WMD

Linux Compatibility Test Redhat 9

Take a look Here
Quote:

Network Interface Intel Pro/1000 CT
Quote:

Network Test Network card did not auto probe and detect properly. It had to be selected manually after updating drivers from Intel's website. Driver as selected is '10/100 Adapter Base Driver'.
sha77

As root try

sbin/insmod e1000.o
or
sbin/modprobe e1000.o

This will give you default parameters which should be OK

Pete

sha77 07-20-2004 06:49 PM

Hi,

I'm totally lost.

as a root from the terminal window:

[root@localhost, root] # sbin/insmod e1000.o <- didnt work
[root@localhost root] # sbin/modprobe e1000.o <- didnt work

[root@localhost root] # modprobe e1000 <- didnt work
[root@localhost root] # modprobe e1000_main <- didnt work

Then I tried all above from the src file from the installed e1000-5.2.52.
[root@localhost, src] : (I typed everything above and nothing happened)

Where exactly should I type all thos commands? From root or the from the file that I installed?

I did some research on the internet but couldnt find anything that help.

Any ideas?

Thanks.
Sharence

chop 07-20-2004 11:52 PM

What does 'lspci' say?
Maybe you've disabled integrated LAN?

Pete M 07-21-2004 03:31 AM

sha77

Hi again

First off check that the e1000 module has actually been made and put in the correct place, should be

/lib/modules/2.4.20-8/kernel/drivers/net/e1000/e1000.o
or
/lib/modules/2.4.20-8/kernel/drivers/net/e1000.o

2.4.20-8 this will be your kernel version if you have a default Redhat install then I assume you will only have one kernel in /lib/modules and it's probably this one

If e1000.o is in there then try this on the command line as root

sbin/insmod /lib/modules/2.4.20-8/kernel/drivers/net/e1000/e1000.o
or
sbin/insmod /lib/modules/2.4.20-8/kernel/drivers/net/e1000.o

Use the full path to the module depending where you found it

Also you need to get back to the root folder

[root@localhost]

To do this once you have entered su then password issue the command
cd /

this should get you from

[root@localhost root]
to
[root@localhost]

In fact before you do the above from the root folder just try

[root@localhost]# sbin/insmod e1000
or
[root@localhost]# sbin/insmod e1000.o
or
[root@localhost]# sbin/modprobe e1000
or
[root@localhost]# sbin/modprobe e1000.o

On my Redhat install I always have to use sbin in front of commands should'nt have to but that's the way mine is

Good luck

Pete


All times are GMT -5. The time now is 08:11 AM.