LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 07-09-2004, 11:53 AM   #1
yildiz
LQ Newbie
 
Registered: Jul 2004
Posts: 15

Rep: Reputation: 0
ethernet card does not seem to be present


Hi,

I just installed a new kernel to my redhat 7.3; kernel 2.4.18. I got 3 ethernet cards which use modules 3c59x,e1000 and eepro100 in its regular kernel. When compiling new kernel I tried both M and * options but neither of them worked.

I checked loaded modules by 'lsmod' but it is empty. Moreover the directory /lib/kernel/2.4.18/drivers has only one directory 'net' and it only has one file 'dummy.o'


if anyone could help, I would be pleased.

Thanks,

ercan
 
Old 07-09-2004, 12:21 PM   #2
Tuttle
Senior Member
 
Registered: Jul 2003
Location: Wellington, NZ
Distribution: mainly slackware
Posts: 1,291

Rep: Reputation: 52
did you "make modules" and "make modules_install"?

do you mean "/lib/modules/2.4.18/drivers"?

Last edited by Tuttle; 07-09-2004 at 12:23 PM.
 
Old 07-09-2004, 02:42 PM   #3
yildiz
LQ Newbie
 
Registered: Jul 2004
Posts: 15

Original Poster
Rep: Reputation: 0
yes i did do both make modules and make modules install

yeap, i mean lib/modules/2.4.18/drivers

do you have any idea what the problem is?

thanks
 
Old 07-09-2004, 04:40 PM   #4
Tuttle
Senior Member
 
Registered: Jul 2003
Location: Wellington, NZ
Distribution: mainly slackware
Posts: 1,291

Rep: Reputation: 52
hmm, I just checked my old modules folder (as i have put all my hardware straight in the kernel for my current kernel) and there they are, all the modules in /lib/modules/2.4.26/kernel/drivers/net. I konw that compiling produces LOADS of messages, maybe theres a way of telling it to only print warnings and find out if something is going wrong there during the configure/make process?


btw, just check if the permissions are at least rwx------- for /lib/modules just in case, you would not be able to put modules in there if you couldn't write!!!

Last edited by Tuttle; 07-09-2004 at 04:41 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No state is present for card Modem jrdioko Slackware 1 08-17-2005 07:14 PM
Ethernet card on laptop: I installed my D-Link ethernet card into Redhat 9, not detec brighamr Linux - Hardware 0 05-18-2004 12:33 AM
why do I get an error message saying my ethernet card is not present? Bronzzy Linux - Networking 18 03-28-2004 07:55 AM
D-link RTL8139D w/Redhat, RTL card not present BigBike Linux - Networking 5 12-05-2003 12:47 PM
RH 7.3 GRUB boot issue with no Video card present dpcook Linux - Newbie 3 12-16-2002 07:33 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 02:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration