LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Ethernet bonding with Nvidia hardware on slackware64 (https://www.linuxquestions.org/questions/linux-networking-3/ethernet-bonding-with-nvidia-hardware-on-slackware64-746011/)

omghai2u 08-08-2009 07:17 AM

Ethernet bonding with Nvidia hardware on slackware64
 
i have a server with 2 ethernet ports that im tring to setup 802.3ad bonding,

eth2 and eth3 are the bonded ports and they are on the nvidia forcedeth driver

i have setup the HP switch for LACP and the switch recognises the bonded connection.

However, it seems that eth2 is used only for Tx and eth3 is used only for Rx. Its like its running in half duplex?? I can use the connection fine but i cant get them to cooperate in full speed...

I have tried round-robin mode which works fine, i have also tried different 802.3ad hashing modes.

Does anyone have 802.3ad bonding working on the forcedeth driver?


This is the bond in /etc/rc.d/rc.inet1.conf , the rest of the interfaces are blank for now:
Code:

IFNAME[4]="bond0"
IPADDR[4]="10.1.1.3"
NETMASK[4]="255.255.255.0"
USE_DHCP[4]=""
DHCP_HOSTNAME[4]=""


This is /etc/rc.d/rc.bond which is called by rc.M on startup
Code:

#!/bin/sh

case "$1" in
  'start')
    echo "Starting Bonding..."
    modprobe bonding mode=4 miimon=100 max_bonds=2
    modprobe forcedeth
    ifconfig bond0 up
    ifenslave bond0 eth2
    ifenslave bond0 eth3
  ;;
  'stop')
    ifconfig bond0 down
    rmmod bonding
    rmmod forcedeth
  ;;
  *)
    echo "Usage: $0 {start|stop}"
  ;;
esac



All times are GMT -5. The time now is 08:53 AM.