LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 04-13-2004, 05:09 PM   #1
Splin
Member
 
Registered: Apr 2004
Distribution: CentOS 5.1
Posts: 42

Rep: Reputation: 15
eth0 wont start with boot process


Hi, lately I installed RH9...rh9 has old kernel and thus it was not able to install my integrated 3com940 network card right away. After I updated kernel to newer version I was able to install card.
Installation instructions told me to unpack the tarball... and then "make load" and after that "ifconfig eth0 up".
After that process rh was able to detect network card in network wizard and I was able to enable it. But my problem is that every time I make restart the eth0 wont come up. I have to make "make load" in that dir again and after that reenable it in network wizard.
I really dont know where to start, any help appreciated...
 
Old 04-13-2004, 05:29 PM   #2
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 60
The last script run on bootup in redhat is the /etc/rc.d/rc.local file. Put needed bootup stuff in there.

# Red Hat links
Red Hat Linux Manuals
Get your mp3 support here
Maximum RPM
rpmfind
Easier software management: apt4rpm - Red Carpet
Red Hat 8.0 Tips & Tricks

# Red Hat 7.3 down configuration commands
setup leads to several configuration tools

# Red Hat 7.3 up configuration commands
Configure soundcard:
redhat-config-soundcard
Configure X server:
redhat-config-xfree86
Configure network:
redhat-config-network
Manage software:
redhat-config-packages
Red Hat Linux 8.0 Package Management Tool
Red Hat 9.0 Package Management Tool
Manage users
redhat-config-users

# Handling NTFS
New Technology FileSystem (NTFS) HOWTOs
Linux NTFS project

# Compiling/installing kernel modules
You will need to have installed:
1. The developmental packages (compiler)
2. The kernel-source code that matches your running kernel
3. The module source or install code

Check out your system and look under the hood and see if you installed the stuff you need to do the job. Open an x terminal and type in this sequence of commands to see what kernel we are running and see if you have the kernel source installed:
Code:
[fancy@tinwhistle fancy]$ su -
Password:
[root@tinwhistle root]# uname -r
2.4.20-28.7
I am running kernel version 2.4.20-28.7. Do I have the proper source code?
Code:
[root@tinwhistle root]# cd /usr/src
[root@tinwhistle src]# ls -alc
total 3
drwxr-xr-x    4 root     root          136 Jun 12 14:53 .
drwxr-xr-x   16 root     root          424 Jun  4 12:04 ..
lrwxrwxrwx    1 root     root           14 Jun  4 12:11 linux-2.4 -> linux-2.4.20-28.7
drwxr-xr-x   16 root     root          584 Jun  4 12:11 linux-2.4.20-28.7
drwxr-xr-x    7 root     root          168 Jun  4 12:08 redhat
[root@tinwhistle src]#
I do have the same kernel version source code installed in the directory /usr/src/linux-2.4.20-28.7 and there is a symbolic link named linux-2.4 pointing to it.

If you don't see something similiar to this (but in color), you will need to install the kernel source.

NOTE: I noticed that Red Hat didn't make the symbolic link /usr/src/linux that all of the INSTALL files that I have read mentioned that I need. I may as well make one now to save editing the files in the source code every time I need to compile anything concerning the kernel. So, I'll make that link just now:
Code:
[root@tinwhistle src]# ln -s linux-2.4.20-28.7 linux         
[root@tinwhistle src]# ls -alc
total 3
drwxr-xr-x    4 root     root          160 Jun 12 15:46 .
drwxr-xr-x   16 root     root          424 Jun  4 12:04 ..
lrwxrwxrwx    1 root     root           14 Jun 12 15:46 linux -> linux-2.4.20-28.7
lrwxrwxrwx    1 root     root           14 Jun  4 12:11 linux-2.4 -> linux-2.4.20-28.7
drwxr-xr-x   16 root     root          584 Jun  4 12:11 linux-2.4.20-28.7
drwxr-xr-x    7 root     root          168 Jun  4 12:08 redhat
[root@tinwhistle src]#
Ah, there it is, so that's done.

Next, did I install the compiler?
Code:
[root@tinwhistle src]# gcc -v          
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/2.96/specs
gcc version 2.96 20000731 (Red Hat Linux 7.3 2.96-113)
[root@tinwhistle src]#
Yes, I have a compiler installed.

If you don't have those two things installed, you have to install them first off your install CD.

If they are installed, download the source and happy compiling. Make sure you carefully read the README and INSTALL files after extracting and before compiling/installing.

Last edited by fancypiper; 04-13-2004 at 05:34 PM.
 
Old 04-13-2004, 05:32 PM   #3
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
have a look at this

http://www.linuxquestions.org/questi...497#post347497

i think your answer is there.
good luck.
 
Old 04-13-2004, 05:55 PM   #4
Splin
Member
 
Registered: Apr 2004
Distribution: CentOS 5.1
Posts: 42

Original Poster
Rep: Reputation: 15
thank you guys both for very informative links...
Great RH info pages fancypiper..all went straight to bookmark, thx PACEDOG....I really should have done that search one more time
thx again
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Start eth0 on boot Bloged Linux - Newbie 6 06-15-2009 04:07 AM
Start process at boot frkstein Ubuntu 1 05-15-2005 01:53 PM
Start noip2 process at boot up kt8993 Mandriva 1 05-06-2005 10:47 PM
SOHOware Ethernet Adapter(SFA110A) mandrake linux 9.2 (eth0 wont start) Mr.Ampersand() Linux - Networking 4 03-25-2004 03:30 PM
boot process can't activate eth0 Manuel Tejada Linux - General 3 10-14-2002 11:40 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration