LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 06-18-2004, 06:38 AM   #1
ratgod
Member
 
Registered: Jun 2004
Location: Niagara Falls, Canada
Distribution: Ubuntu
Posts: 30

Rep: Reputation: 15
Unhappy eth0 not working on fedora running in VMware 4 on WinXP pro machine


Hi there,
I have installed Fedora Core 1 on both my desktop machine and laptop machine and upon booting the eth0 will not work.
Due to my temory dependence on Windows (yuck) I'm having to run it within VMware 4, my windows is XP pro on my desktop and home on the laptop yet have the same problem (note: also same problem under VMware 3.5).

When it comes to initalizing eth0 it comes up with this:

Bringing up interface eth0:
Determining IP information for eth0... failed: no link present. Check cable?
[failed]

My network works great outside of VMware on both machines.

any sugestions?

it also fails the console mouse services and smartd, but im not too concerned about these just yet.
 
Old 06-18-2004, 10:01 AM   #2
LinuxLala
Senior Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: Fedora 7
Posts: 1,305

Rep: Reputation: 45
Could you please copy the result of
ifconfig

Just type ifconfig at the console and copy and paste the output here.
 
Old 06-18-2004, 01:44 PM   #3
ratgod
Member
 
Registered: Jun 2004
Location: Niagara Falls, Canada
Distribution: Ubuntu
Posts: 30

Original Poster
Rep: Reputation: 15
OK here it is:

[root@VM-Athlon root]# ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:244.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX oackets:5367 errors:0 dropped:0 overruns:0 frame:0
TX oackets:5367 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:4303162 (4.1 Mb) TX bytes:4303162 (4.1 Mb)

[root@VM-Athlon root]# uname -a
Linux VM-Athlon 2.4.22-1.2115.nptl #1 Wed Oct 29 15:31:21 EST 2003 i686 athlon i386 GNU/Linux


I did the uname incase you needed the information.

thanks
 
Old 06-19-2004, 05:25 AM   #4
LinuxLala
Senior Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: Fedora 7
Posts: 1,305

Rep: Reputation: 45
As you can see you have not provided the ip for eth0.

Just type
ifconfig eth0 ipaddress

That should get you working.
 
Old 06-22-2004, 12:41 PM   #5
ratgod
Member
 
Registered: Jun 2004
Location: Niagara Falls, Canada
Distribution: Ubuntu
Posts: 30

Original Poster
Rep: Reputation: 15
I gave up and wiped my laptop and put Fedora Core 2 on it works great.

I forgot to plug in the network cable before booting though and had to do ifconfig eth0 192.168.0.5 to get network up. but it wouldnt resolve URLs, how do I get the to work without rebooting?
 
Old 06-22-2004, 01:23 PM   #6
LinuxLala
Senior Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: Fedora 7
Posts: 1,305

Rep: Reputation: 45
You can try two things,

1. service network restart
This restart the network services and bring up eth0 if bring up at boot is enabled
2. ifconfig eth0 up
This is brings up eth0

Plus tell me, do you also have some subnet mask or something which you need to provide. I mean do a ifconfig and check all the values if they are fine.

And, does eth0 connect to a local network or to a cable network?
 
Old 06-22-2004, 04:04 PM   #7
ratgod
Member
 
Registered: Jun 2004
Location: Niagara Falls, Canada
Distribution: Ubuntu
Posts: 30

Original Poster
Rep: Reputation: 15
I have a router connected to my cable network and basically all my machines are in the 192.168.0.x ranges and I usually use the subnet mask of 255.255.255.0 dunno if that helps.

I ended up rebooting anyway, its all working, I'm just curious incase I have to use the internet again and have forgot to plug the cable in
 
Old 06-22-2004, 10:36 PM   #8
LinuxLala
Senior Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: Fedora 7
Posts: 1,305

Rep: Reputation: 45
Ok good. So then(incase you forget to pluging the cable) you can do
service network restart
or
ifconfig eth0 up

Both will work fine.
 
Old 06-23-2004, 08:00 AM   #9
ratgod
Member
 
Registered: Jun 2004
Location: Niagara Falls, Canada
Distribution: Ubuntu
Posts: 30

Original Poster
Rep: Reputation: 15
well, ifconfig eth0 up and also service network restart works, but how do I bring up the DNS? still doesn't seem to resolve names.
 
Old 06-23-2004, 09:47 AM   #10
LinuxLala
Senior Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: Fedora 7
Posts: 1,305

Rep: Reputation: 45
did you check out the router firmware? You have to do
http://192.168.XX.XX in the browser, which is the address of the router. Therein you need to provide the DNS which is the same as your default gateway.

Does this help or did I not understand your question?
 
Old 06-23-2004, 05:12 PM   #11
ratgod
Member
 
Registered: Jun 2004
Location: Niagara Falls, Canada
Distribution: Ubuntu
Posts: 30

Original Poster
Rep: Reputation: 15
My settings in my router are set ok
its set has DHCP server and all works great, linux picks up the DNS server if I have the cable in during boot, but if i dont have the cable in during boot and initialize it after with the cable in then it doesnt resolve DNS or ask the router for DNS even.

I think its the way I'm wording it unfortunaly

thanks for the help eitherway I really apreciate it.
 
Old 06-24-2004, 01:28 AM   #12
LinuxLala
Senior Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: Fedora 7
Posts: 1,305

Rep: Reputation: 45
From my experience, I've never seen this. Sorry dude, can't help you fix this issue

Anyways, it's not much of a bug, so...

Cheers.
 
Old 06-24-2004, 12:13 PM   #13
ratgod
Member
 
Registered: Jun 2004
Location: Niagara Falls, Canada
Distribution: Ubuntu
Posts: 30

Original Poster
Rep: Reputation: 15
no worries, ill just reboot it whenever I come across it again

thanks for the sugestions, they may not have solved it but they are usefull all the same
 
Old 06-24-2004, 12:18 PM   #14
LinuxLala
Senior Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: Fedora 7
Posts: 1,305

Rep: Reputation: 45
Cheers
 
Old 06-25-2004, 04:45 PM   #15
Qball44
LQ Newbie
 
Registered: Jun 2004
Posts: 2

Rep: Reputation: 0
ratgod,

Did you give up on trying to get Red Hat 9 to work? I have been running into the same problems. I have a virtual machine with 7.3 working just fine. For some reason RH9 doesn't seem to work.

Has anyone been able to get RH9 to work when using VMware?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cant network slack in vmware in winxp pro glorsplitz Slackware 2 04-01-2005 07:18 PM
Installing Mandrake9.2 on a Fedora winxp dual boot machine dhanakom Mandriva 2 07-04-2004 09:24 AM
Running Slack 9.1 in a VMWare machine? Dee-ehn Slackware 4 04-20-2004 10:11 AM
How do I install Fedora on my comp running WinXP Pro, WinXP Home and Win2000 Server pureheartedsoul Linux - Newbie 3 03-30-2004 02:45 PM
tightVNC set-up with Fedora and WinXP pro.. sxa Linux - Software 14 01-29-2004 09:30 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration