-   Linux - Networking (
-   -   eth0 not getting IP address from DHCP server (

Venefyxatu 05-04-2005 04:48 PM

eth0 not getting IP address from DHCP server

I have this computer I use to play around with linux (let's call it a test system :) ) and all was well ... until our internet connection got upgraded - we moved from IP addresses starting with 192. to a range starting with 82. The Windows computers (my father's, brother's and my other one) are fine, no problem at all, but the linux computer suddenly refused to load the module for the NIC.

After some searching I found what module it should load (tulip) and uncommented this line in /etc/rc.d/rc.modules

Still no go.

Some searching around left me with a few topics here that seemed more or less relevant at the time (when I was looking for the correct module to load) but, unfortunately, none of them had a solution to offer.
What they did offer me was a few commands I should run and that you might need.

ifconfig -a gives me this :


eth0      Link encap:Ethernet  HWaddr 00:C0:26:C1:61:6A 
          RX packets:117 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:4 dropped:0 overruns:0 carrier:8
          collisions:0 txqueuelen:1000
          RX bytes:7020 (6.8 Kb)  TX bytes:0 (0.0 b)
          Interrupt:11 Base address:0xe400

lo        Link encap:Local Loopback 
          inet addr:  Mask:
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

lsmod gives me the following :


Module                  Size  Used by    Tainted: P 
snd-pcm-oss            36704  0  (unused)
snd-mixer-oss          12152  0  [snd-pcm-oss]
uhci                  24284  0  (unused)
usbcore                58860  1  [uhci]
snd-cmipci            16704  0
gameport                1420  0  [snd-cmipci]
snd-pcm                54504  0  [snd-pcm-oss snd-cmipci]
snd-opl3-lib            5860  0  [snd-cmipci]
snd-hwdep              4352  0  [snd-opl3-lib]
snd-timer              13412  0  [snd-pcm snd-opl3-lib]
snd-mpu401-uart        3200  0  [snd-cmipci]
snd-rawmidi            12320  0  [snd-mpu401-uart]
snd-seq-device          3812  0  [snd-opl3-lib snd-rawmidi]
snd                    31268  0  [snd-pcm-oss snd-mixer-oss snd-cmipci snd-pcm snd-opl3-lib snd-hwdep snd-timer snd-mpu401-uart snd-rawmidi snd-seq-device]
snd-page-alloc          4712  0  [snd-mixer-oss snd-pcm snd-hwdep snd-timer snd-rawmidi snd-seq-device snd]
soundcore              3396  4  [snd]
nvidia              3643836  0  (unused)
ide-scsi                9392  0
tulip                  39200  0
crc32                  2880  0  [tulip]
agpgart                45092  0  (unused)

And lspci -v gives me this result (if you need the full output, just let me know ... I thought I'd cut back on size by omitting everything that's not a network card :P). The NIC itself is a LevelOne FNC-0111TX.


00:09.0 Ethernet controller: Linksys Network Everywhere Fast Ethernet 10/100 model NC100 (rev 11)
        Subsystem: Accton Technology Corporation: Unknown device 1216
        Flags: bus master, medium devsel, latency 64, IRQ 11
        I/O ports at e400 [size=256]
        Memory at ef000000 (32-bit, non-prefetchable) [size=1K]
        Expansion ROM at ee000000 [disabled] [size=128K]
        Capabilities: [c0] Power Management version 2

I tried running dhcpcd (as a background process, should that matter) but after some time it exits with code 14 (whatever that means).


Another thing I came across was someone who solved a problem by getting rid of the dhcpcd-eth0.cache, and (which I don't have) in the /etc/dhcpc dir through his shutdown script (which makes me assume they don't need to exist when the computer boots).
I tried manually renaming these files by adding .bak to the end. The only result of this is that now at boot, I also get the message


dhcpcd[82]: broadcasting DHCP_DISCOVER
which wasn't previously there.

When doing this through the rc.6 script (inserting the mv command right after the code that gets rid of the dhcpcd) the exact same thing happens : a DHCP_DISCOVER without a result.

I'd start to think that the DHCP server was unreachable, but both the linux computer and the computer I'm using atm are connected to the same hub, which is then connected to the cable modem via another hub. The hardware all seems to be fine as far as I can tell.

Any ideas on what the problem could be in the first place? (solutions are more than welcome as well of course, but I don't mind doing some searching if I know what to look for :P)

kencaz 05-04-2005 05:30 PM

Try in a root terminal

ifdown eth0
ifup eth0


Venefyxatu 05-04-2005 05:42 PM

First of all, thanks for taking the time to read all that. I assume that by ifdown eth0 you mean ifconfig eth0 down.

eth0 was already down (since it did not show up when running ifconfig, only with the -a option). So to my (untrained) eye, the only effect of this is that I don't need the -a option when running ifconfig to see eth0.

kencaz 05-04-2005 06:07 PM

Your on a router with 2 other systems? Try to restart service

in root terminal
cd /etc/init.d
./network restart


Venefyxatu 05-04-2005 06:45 PM

I think I created a small misunderstanding somewhere : I don't use a router, only two hubs. Hub1 is attached to the cable modem. Hub2, my father's computer and my brother's computer are also attached to Hub1. My two computers are attached to Hub2

As for the network service : I have but one dir called init.d on my system and that's located in /usr/lib/mozilla-1.7.5/
Searching for a file named "*network*" returned a lot of HTML and other documents, icons, lib files?
Searching for a file named "network" did the same thing, only with fewer results (duhh :rolleyes: )

Am I missing a package somewhere?

(note : netwatch tells me that there is no eth0 device to work with, even though it still shows up in ifconfig!)

All times are GMT -5. The time now is 02:07 PM.